locked
Manifesting for Windows 8.1 in Sources file RRS feed

  • Question

  • According to this article:
    https://msdn.microsoft.com/en-us/library/windows/desktop/dn302074%28v=vs.85%29.aspx

    In order to make my C console application compatible with Windows 8.1 or later I can either manifest it, or:

      "... include _NT_TARGET_VERSION=$(_NT_TARGET_VERSION_LATEST) in the source file"

    However I am using Visual Studio 2010 and there does not appear to a SOURCES file, just the VCXPROJ file.

    So where do I add this define?  I tried adding it to:
    Configuration Properties->C/C++->Preprocessor->Preprocessor Definitions

    However GetVersionEx still returns 6.2 instead of 6.3.

    Where do I specify this define in Visual Studio 2010?

    Thanks.


    • Edited by Neil Weicher Wednesday, November 25, 2015 9:10 AM
    Wednesday, November 25, 2015 9:10 AM

Answers

All replies