Cannot connect to "Reporting Services" server remotely, using SQL Server Management Studio


  • I'm having trouble connecting to a remote Reporting Services server from my machine using SQL Server Management Studio.   But, when I open a terminal service session to the Reporting Services server, using the same windows account, and a SQL Server Management Studio connection to the Reporting SErvices server, it works just fine.  

    In addition, when connecting through the IE browser to the reporting server (http://servername/Reports/Pages/Folder.aspx?ViewMode=List), from my machine, I was able to connect to it just fine.

    Below are the errors I receive:


    The underlying connection was closed: An unexpected error occurred on a receive. (Microsoft.SqlServer.Management.UI.RSClient)

    Program Location:

       at Microsoft.SqlServer.ReportingServices2005.RSConnection.GetSecureMethods()
       at Microsoft.SqlServer.ReportingServices2005.RSConnection.IsSecureMethod(String methodname)
       at Microsoft.SqlServer.ReportingServices2005.RSConnection.ValidateConnection()
       at Microsoft.SqlServer.Management.UI.RSClient.RSClientConnection.CreateConnection(String connectionString)
       at Microsoft.SqlServer.Management.UI.RSClient.RSConnectionInfo.CreateConnectionObject()
       at Microsoft.SqlServer.Management.UI.RSClient.RSConnectionInfo.RSTypeImpl.GetConnectionObject(UIConnectionInfo ci)
       at Microsoft.SqlServer.Management.UI.ConnectionDlg.RSType.GetConnectionObject(UIConnectionInfo ci)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.ObjectExplorer.ValidateConnection(UIConnectionInfo ci, IServerType server)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.ObjectExplorer.ConnectToServer(Object connectionInfo, IDbConnection liveConnection, Boolean validateConnection)


    Unable to read data from the transport connection: An established connection was aborted by the software in your host machine. (System)

    Program Location:

       at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
       at System.Net.PooledStream.Read(Byte[] buffer, Int32 offset, Int32 size)
       at System.Net.Connection.SyncRead(HttpWebRequest request, Boolean userRetrievedStream, Boolean probeRead)


    An established connection was aborted by the software in your host machine (System)

    Program Location:

       at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
       at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)

    Monday, July 28, 2008 5:17 PM

All replies

  • What are you using for server name in Mgmt Studio to connect?

    http://servername/reportserver  should work

    If you want to use machine\instance to connect, check the UrlRoot setting in your rsreportservice.config file. It should be:


    Monday, July 28, 2008 6:25 PM
  • Thanks for the quick reply.


    I've tried both the instance and the URL name and neither worked.


    As for the rsreportservce.config file, I thought that was a server side config file.   Since I am connecting from my local machine (laptop), and connecting to the server machine directly via Terminal Services does not cause me the same issue, wouldn't changing the config file be moot at this point?


    Is there a switch or configuration that I need to do on my machine to enable me to connect to the reporting services server remotely?   Also, I seem to be having the same issue using VS 2005.    I can't deploy updated reports since I am not able to connect to the server remotely.   :-(


    BTW.   I don't believe permissions on the server is an issue as I am administor on the server, and the Reporting Services instance.


    Monday, July 28, 2008 6:42 PM
  • Hi.   I got some new findings.  


    When connecting via "Windows Authentication", I was Not able to connect to the remote Reporting Services server.   However, when I switched to "Basic Authentication", using the same windows account, it worked!!   It seems I found a workaround but I don't understand why the "Basic Auth" worked and the "Windows Auth" didn't.   I would prefer I connect via "Windows Auth". 


    I also found the following.   My Microsoft SQL Server Management Studio version is 9.00.3042.00.   I found another machine whose Microsoft SQL Server Management Studio version is 9.00.1399.00.   The machine running the 1399 version is able to connect to the remote server using windows authentication.   So, I think when I upgraded my machine to SP2 (version 3042), the Windows NT authentication connection to a remote RS server no longer worked.


    Thoughts anyone?

    Monday, July 28, 2008 7:40 PM
  • I was having a similar problem, but I fixed my problem.  What I did was to go to the RSWebApplication.config file located at


    C:\Program Files\Microsoft Sql Server\MSSQL\Reporting Services\ReportManager\RSWebApplication.config


    and changed an invalid server name at ...ReportServerURL...https://invalidservername/ReportServer/<url>  to



    and this solved the problem for me.

    Tuesday, September 23, 2008 3:55 PM