none
Credentials provided for the Integration Services service are invalid. RRS feed

  • Question

  • I just finished installing SQL Server 2008 on SBS 2008.  I am running the repair application from the installation DVD and I'm getting the following error:

    The credentials you provided for the Integration Services service are invalid.  To continue, provide a valid account and password for the Integration Services service.

    Error code 0x84B40000.

    Where do I change the account and password for the Integration Services service?

     

    Monday, March 7, 2011 11:29 PM

Answers

All replies

  • I should note that changing the service Properties does not work.  Therefore, if I select the bullet for "Local System account" on the "Log On" tab of the service Properties dialog, the problem is not fixed.
    Monday, March 7, 2011 11:53 PM
  • Hello,

    Please use SQL Server Configuration Manager as explained in the following link:

    http://technet.microsoft.com/en-us/library/ms345578.aspx    

    Try using a domain account for starting the service.
     
    Regards,

    Alberto Morillo
    SQLCoffee.com

    Tuesday, March 8, 2011 2:13 AM
    Moderator
  • So far, changing the permissions of SSIS does not affect the error message. I was sure to follow the whole set of directions including the Additional Considerations section. I'm beginning to wonder whether I can even install this on SBS 2008. The real problem is the inability to connect to the server after installation. Therefore, I am unable to connect to the server (Error 26) after installation even though Shared Memory, Named Pipes and TCP/IP are all enabled. Any other ideas? Microsoft's website link for support on installing SQL Server 2008 on a domain controller doesn't even work, so I'm up a creek there.
    Tuesday, March 8, 2011 6:47 PM
  • Hello,

    Please disable Windows Firewall or disable it to be able to connect to the SQL Server instance.

    http://msdn.microsoft.com/en-us/library/ms175043.aspx

    If you installed a named instance of SQL Server, please see the following post:

    http://blogs.msdn.com/b/sql_protocols/archive/2007/05/13/sql-network-interfaces-error-26-error-locating-server-instance-specified.aspx

     About the service account starting the integration services please change it to a domain account, and then repair the instance.

    Hope this helps.   
     
    Regards,

    Alberto Morillo
    SQLCoffee.com

    Tuesday, March 8, 2011 7:59 PM
    Moderator
  • Ok. This is what I did. 1) Created user account to be used with the server. This was a part of the initial installation. I used SQLADMIN. 2) Installed SQL Server. This is were problems occurred. When I reinstalled the second time, I did not use SQLADMIN as the user. I think I used LocalSystem or something. This is what the repair application was complaining about. After the last post, I did the following: 1) Uninstalled SQL Server. 2) Installed SQL Server using the SQLADMIN as the user "Log On" for all services. 3) Success. Everything works fine now. It was a very simple mistake. Thanks for reminding me about the user account. -Michael
    Tuesday, March 8, 2011 11:43 PM