An error 1069 - )The service did not start due to logon failure) occurred while performing this service operation ... RRS feed

  • Question

  • Hi All,


    We seem to be being plagued by the error below by our SQL Server agent. This happens almost everytime we restart the server that has been running for a day or two.


    Our SQL Server Agent uses a none expiring domain credential. I understand that this problem only happens when the profile being used by the SQL Servr Agent has changed (password change). What puzzles me is that the login is A ok and no changes has been made to it's password.


    We always resolve this problem by changing the login used in the SQL Server Agent to local and after that, returning it back to it's original domain login. Unfortunately, we cant always do this everytime something goes wrong.


    Can anyone please help us shed a light on this? We're using SQL2k with SP3a. Thanks!



    An error 1069 - )The service did not start due to logon failure) occurred while performing this service operation on the SQLServerAgent service.





    Wednesday, October 10, 2007 8:53 AM


All replies

  • Assuming there are no external factors like event log messages indicating problems connecting to the domain controller then it sounds like there's an issue with that domain account.

    I can only suggest that you try deleting and recreating that account in AD, if you have not tried this already.

    I'd also recommend you apply SP4, but that does not have anything to do with this issue.


    Wednesday, October 10, 2007 9:53 AM

    I was getting the same error since I had changed the password. I found a work around for it to connect to SQL server.

    Go to Run-->services.msc--> MSSQLSERVER . On the "log on as" tab right click and check your login information. i suggest delete the password and retype it again. It works !!

    • Proposed as answer by Kelvinay Wednesday, February 1, 2012 8:03 PM
    • Marked as answer by Joseph Ollero Wednesday, July 18, 2012 7:42 AM
    Friday, January 11, 2008 9:03 PM

    We already have an SP4 installed. As for the AD account, other services in the same server also uses the same account as SQL Server does and we dont encounter any problems with them. The strange part is that this does not happen very often. Once or thrice a week, mostly random occurances based on what we have experience. Any thoughts?
    Tuesday, January 22, 2008 12:35 PM
  • We are having the same type of problem.

    For some reason, when rebooting a SQL server, the service will not start.  When trying to start by hand, we will get the service did not start due to logon failure message.

    Resetting it to the same password, gives the "logon as a service has been granted" message.  Then the service will start up correctly.  The account is a domain user account and it only used for the SQL service (on this machine and a few others).  The problem seems to happen on at least 2 different SQL machines.  The password has not been changed lately.  This almost seems like when setting the password on the service, it is not being saved properly and when it is rebooted, it is using some other password that may have been cached.


    Not sure what is going on, but it is very strange.





    Tuesday, January 29, 2008 8:50 PM

    Hmmm, just a thought. SQL Server 2000 will be stopping it's support this year. Does that mean if theres a problem with this, we will not be able to resolve this issue anymore?

    Tuesday, February 12, 2008 1:55 PM
  • Ran into this error, and the password was correct. What the System Event Log said:

    Code Snippet
    Event Type: Error
    Event Source: Service Control Manager
    Event Category: None
    Event ID: 7041
    Date: 10/8/2008
    Time: 9:33:09 AM
    User: N/A
    Computer: ComputerName
    The SQLSERVERAGENT service was unable to log on as DomainName\SQLAgent with the currently configured password due to the following error:
    Logon failure: the user has not been granted the requested logon type at this computer.

    Domain and account: DomainName\SQLAgent

    This service account does not have the necessary user right "Log on as a service."

    User Action

    Assign "Log on as a service" to the service account on this computer. You can use Local Security Settings (Secpol.msc) to do this. If this computer is a node in a cluster, check that this user right is assigned to the Cluster service account on all nodes in the cluster.

    If you have already assigned this user right to the service account, and the user right appears to be removed, a Group Policy object associated with this node might be removing the right. Check with your domain administrator to find out if this is happening.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp


    ...sure enough it had been removed from the "Logon as a service" list. Hope this helps.

    • Proposed as answer by Rashid Amin Monday, July 16, 2012 6:23 PM
    Wednesday, October 8, 2008 1:58 PM
  • I have the same error but its related to a brand new installed sql server 2000 SP4 but instead of SQLSERVERAGENT is  SQLSERVER.


    Any ideas ?


    Sorry about my poor English.

    Claudio Lins
    Saturday, March 26, 2011 3:22 PM
  • Solved it for me.  Thanks.
    Thursday, July 14, 2011 5:58 PM
  • Thanks very much!! this resolved my problem. I too had changed  my password. and the error with connecting to SQL occured  a few days later. I was unable to connect to it. thanks again!
    Wednesday, August 31, 2011 5:19 PM
    • Edited by John Guilbert Monday, December 12, 2011 10:06 AM
    • Proposed as answer by John Guilbert Tuesday, January 10, 2012 9:12 AM
    • Marked as answer by Joseph Ollero Wednesday, July 18, 2012 7:43 AM
    Thursday, December 1, 2011 11:26 AM
  • Hello

    hi anidutta

    my probelm get solved  this suggestion realy help who face the same problem.

    thanking you

    Saturday, April 28, 2012 11:33 AM
  • This fixed my issue. There was an explicit "Logon as service" GPO assigned to a certain group. I added Domain Admins to that group.
    Monday, July 16, 2012 6:24 PM
  • Check your Log in information by clicking Logon tab

    Thursday, November 20, 2014 7:31 PM