none
MS SSAS 2008 and HTTP interface called msmdpump.dll RRS feed

  • Question

  • I have following situation.

    • Computer A is my user computer on which I work. On this computer I would like to use Excel and be able to connect to SSAS thru HTTP.
    • Computer B is machine which holds IIS.
    • Computer C is machine which holds SSAS.

     

    • Computer A is under LAN A and ActiveDirectory A.
    • Computers B and C are under LAN B and ActiveDirectory B.
    • Computer A has access only to Computer B so that's why I have to use http proxy (msmdpump.dll) to get to Computer C.

    SSAS is running as domain service account. I've set Computer B as "trusted for delegation" and ssas-domain service account as "trust this user for delegation to any service" and registered his SPN (http/hostname:81; http/hostname.domain:81).

    When I try to connect to http url with Excel I get error. Also with SSMS I get error saying: unsupported data format.

    With Excel I try to connect with Data-FromOtherSources-FromAnalysisServices. I type server name as http://server-ip:81/OLAP/msmdpump.dll and specify my domain credentials for LAN B I get: unable to connect to data source, reason, unable to locate database server.

    But when I try to enter http://server-ip:81/OLAP/msmdpump.dll in browser I get soap fault which means it's successfully configured?

    <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
    <soap:Body>
    <soap:Fault xmlns="http://schemas.xmlsoap.org/soap/envelope/">
    <faultcode>XMLAnalysisError.0xc10e0002</faultcode>
    <faultstring>Parser: The syntax for 'GET' is incorrect.</faultstring>
    <detail><Warning WarningCode="1090584599" Description="The 'Invariant Language' locale for UI is not supported." Source="Unknown" HelpFile=""/>
    <Error ErrorCode="3238920194" Description="Parser: The syntax for 'GET' is incorrect." Source="Unknown" HelpFile=""/>
    </detail>
    </soap:Fault>
    </soap:Body>
    </soap:Envelope>

    Wednesday, August 3, 2011 9:01 AM

Answers

  • Problem solved, silly mistake on which I lost couple of hours. I had anonymous authentication enabled in IIS configuration. I've disabled and now works.

    • Proposed as answer by Thameem Wednesday, August 3, 2011 2:51 PM
    • Marked as answer by Jerry NeeModerator Sunday, August 21, 2011 12:51 AM
    Wednesday, August 3, 2011 10:48 AM

All replies

  • I forgot to mention that I'm using basic authentication in IIS configuration.
    Wednesday, August 3, 2011 9:08 AM
  • Problem solved, silly mistake on which I lost couple of hours. I had anonymous authentication enabled in IIS configuration. I've disabled and now works.

    • Proposed as answer by Thameem Wednesday, August 3, 2011 2:51 PM
    • Marked as answer by Jerry NeeModerator Sunday, August 21, 2011 12:51 AM
    Wednesday, August 3, 2011 10:48 AM