none
Error: 1474, Severity: 16, State: 1. RRS feed

  • Question

  • Dear All,

    mirroring disconnected it shows error in the log as following order...


    Unknown,Error: 1479<c/> Severity: 16<c/> State: 1.
    Unknown,The mirroring connection to "xxxx" has timed out for database "xxxx" after 10 seconds without a response.  Check the service and network connections.
    Unknown,Error: 1479<c/> Severity: 16<c/> State: 1.
    Unknown,The mirroring connection to "xxx" has timed out for database "xxxx" after 10 seconds without a response.  Check the service and network connections.
    Unknown,Database mirroring is inactive for database 'xxx'. This is an informational message only. No user action is required.
    Unknown,Database mirroring is inactive for database 'xxxx'. This is an informational message only. No user action is required.
    Unknown,Error: 1474<c/> Severity: 16<c/> State: 1.
    Unknown,Database mirroring connection error 4 'An error occurred while receiving data: '64(failed to retrieve text for this error. Reason: 15105)'.' for xxx.
    Unknown,Error: 1474<c/> Severity: 16<c/> State: 1.
    Unknown,Database mirroring connection error 4 'An error occurred while receiving data: '64(failed to retrieve text for this error. Reason: 15105)'.' for xxx.

    Error: 1474, Severity: 16, State: 1.

    Database mirroring connection error 4 'An error occurred while receiving data: '64(failed to retrieve text for this error. Reason: 15105)'.' for 'TCP://........'.


    When monitoring mirroring  both principle and mirror are in disconnected status.

    Status it is showing cannot connect to the mirror instance.


    Database mirroring connection is in Asynchronous mode.We are using sql server 2008.

    please help me..How to coneect again and to find the exact root cause.how to establish the connection and resent the unsent log.

    Looking for quick response.Its very urgent......

    Tuesday, November 30, 2010 9:27 AM

Answers

  • There are few things which may cause the problem. Please folow the KB and change TCP settings.

    http://support.microsoft.com/kb/942861 (Error message when an application connects to SQL Server on a server that is running Windows Server 2003: "General Network error," "Communication link failure," or "A transport-level error")



    Balmukund Lakhani | Please mark solved if I've answered your question, vote for it as helpful to help other user's find a solution quicker
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------------------------------------------------------------------
    My Blog: http://blogs.msdn.com/blakhani
    Team Blog: http://blogs.msdn.com/sqlserverfaq
    Wednesday, December 1, 2010 10:40 AM
    Moderator
  • Please Review http://support.microsoft.com/kb/951037 

    For disabling TCP chimney you can always run the following from the command prompt

    netsh int tcp set global chimney=disabled
    To Disable RSS
    netsh int tcp set global rss=disabled

    regards
    Please mark solved if I've answered your question, vote for it as helpful to help other user's find a solution quicker
    -------------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    -------------------------------------------------------------------------------------
    Sunday, December 5, 2010 7:51 AM

All replies

  • Have a look at the following previous posts answer...

    http://social.technet.microsoft.com/Forums/en-US/sqldatabasemirroring/thread/05f27453-65c9-4a97-b3d3-abf24f24a490/

    ...should help you see what is going on

     

    Thanks


    /Neil Moorthy - Senior SQL Server DBA/Developer (MCITP (2005), MCAD, OCA 11g) Please click the Mark as Answer button if a post solves your problem
    Tuesday, November 30, 2010 11:20 AM
  • Errror 64 = The specified network name is no longer available.

    1. Whats the the operating System?
    2. Are you able to ping each other?
    3. Please post the output of below command (run from cmd)
       
        netsh int tcp show global
        netstat -nt | findstr /i offloaded

    4.  You can stop and start the endpoints for quick relief (on both servers).

    ALTER ENDPOINT [Mirroring] STATE=STOPPED
    GO
    ALTER ENDPOINT [Mirroring] STATE=STARTED
    GO
    






    Balmukund Lakhani | Please mark solved if I've answered your question, vote for it as helpful to help other user's find a solution quicker
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------------------------------------------------------------------
    My Blog: http://blogs.msdn.com/blakhani
    Team Blog: http://blogs.msdn.com/sqlserverfaq
    Tuesday, November 30, 2010 11:53 AM
    Moderator
  • Hi BalMukund sir, Thanks for giving repaly. Please find the output for the command which you have given..

     

     

    TCP Global Parameters

     ---------------------------------------------------------

     Receive-Side Scaling State :enabled

    Chimney Offload State :automatic

    Net DMA State :enabled

    Direct Cache Acess <dca> :disabled

    Receive Window Auto_Tuning Level :normal

    Add-On Congestion Control Provider :ctcp

    ECN Capability :disabled

    RFC 1323 Timestamps :disabled

     

     

    Note:For time being we were confiured mirroring.However i would like to know exact process.

    Wednesday, December 1, 2010 10:23 AM
  • There are few things which may cause the problem. Please folow the KB and change TCP settings.

    http://support.microsoft.com/kb/942861 (Error message when an application connects to SQL Server on a server that is running Windows Server 2003: "General Network error," "Communication link failure," or "A transport-level error")



    Balmukund Lakhani | Please mark solved if I've answered your question, vote for it as helpful to help other user's find a solution quicker
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------------------------------------------------------------------
    My Blog: http://blogs.msdn.com/blakhani
    Team Blog: http://blogs.msdn.com/sqlserverfaq
    Wednesday, December 1, 2010 10:40 AM
    Moderator
  • i forgot to tel you  fewmore details,

    O/s is windows 2008 server and Mssql server 2008

    Wednesday, December 1, 2010 12:14 PM
  • I would still ask you to disable TCPChimey, RSS etc
    Balmukund Lakhani | Please mark solved if I've answered your question, vote for it as helpful to help other user's find a solution quicker
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------------------------------------------------------------------
    My Blog: http://blogs.msdn.com/blakhani
    Team Blog: http://blogs.msdn.com/sqlserverfaq
    Wednesday, December 1, 2010 12:58 PM
    Moderator
  • many thanks for your reply.

     path To disable TCPChimey, RSS etc i did not find these entries in my server

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters.

    if this in not where i have to change please  guide me  to do this .

     
     
     
     
     
    Thursday, December 2, 2010 1:53 PM
  • Please Review http://support.microsoft.com/kb/951037 

    For disabling TCP chimney you can always run the following from the command prompt

    netsh int tcp set global chimney=disabled
    To Disable RSS
    netsh int tcp set global rss=disabled

    regards
    Please mark solved if I've answered your question, vote for it as helpful to help other user's find a solution quicker
    -------------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    -------------------------------------------------------------------------------------
    Sunday, December 5, 2010 7:51 AM
  • Hi Balmukundsir,

    I am getting following message in my sql log and error 1418 on starting the Mirror and I am not able to telnet and My o/s on both server is WINDOWS SERVER 2008 standard without hyper-V  And SQL SERVER2008

    Database mirroring connection error 2 'Connection attempt failed with error: '10061(No connection could be made because the target machine actively refused it.)'.' for 'TCP://xxx.xxx.236.61:50795' this is message is generated in my sql server  log  after Coming Error 1418 on start Mirroring;

    where My Primary server is xxx.xxx.252.52:1433

    the accounts are running in the same domain accounts

    when I pinging they response to each other

    when I running the command netstat -ano  they are listening to each other  on processid=2704 of primary server which also match with select  serverproperty('processid') of the primary server.

     

    when I running the command netstat -ano on Secondary server  they are listening to each other  on different processid=4708 of secondary server whichdoesn't match with  select  serverproperty('processid') of the secondar server.

    I have created endpoints for both server

    create  ENDPOINT [mirroring_test]
        AUTHORIZATION [sa]
        STATE=STARTED
        AS TCP (LISTENER_PORT = 1433, LISTENER_IP = ALL)
        FOR DATA_MIRRORING (ROLE = PARTNER, AUTHENTICATION = WINDOWS NEGOTIATE
    , ENCRYPTION = DISABLED )
    GO

    create  ENDPOINT [mirroring_test]
        AUTHORIZATION [sa]
        STATE=STARTED
        AS TCP (LISTENER_PORT = 50795, LISTENER_IP = ALL)
        FOR DATA_MIRRORING (ROLE = PARTNER, AUTHENTICATION = WINDOWS NEGOTIATE
    , ENCRYPTION = DISABLED )
    GO

    please suggest me, I have already following these links

    http://msdn.microsoft.com/en-us/library/ms190941.aspx
    http://msdn.microsoft.com/en-us/library/ms189852.aspx

     Please suggest me



    Sunday, January 1, 2012 4:29 AM