none
SSMS restarts itself after I close it RRS feed

  • Question

  • Hi,

    This strange behavior started recently. If I close SSMS, it restarts itself as if it crashed and trying to restore itself. Even if I hit cancel as it's restarting, it will restart itself yet again. This happens twice. Any idea what's causing this?


    Thanks, Sam

    Thursday, March 14, 2013 2:19 PM

Answers

All replies

  • Hello,

    If you are using SSMS 2012, are you experiencing the issue explained on the following thread?

    http://connect.microsoft.com/SQLServer/feedback/details/774317/sql-server-management-studio-2012-crashes-when-closing

    Please provide a dump to Microsoft as requested on the thread.

    Regards,

    Alberto Morillo
    SQLCoffee.com


    Thursday, March 14, 2013 3:16 PM
    Moderator
  • The Connect thread pointed to above says that this has been fixed back in August 2013 but there is no way of finding out how to get this fix or even if it has been released to users. It's now nearly February 2014. What's going on? Why is it taking so long to get the fix out?

    Simon Jones
    If you found this post helpful, please "Vote as Helpful". If it actually answered your question, please remember to "Mark as Answer". This will help other people find answers to their problems more quickly.

    Thursday, January 23, 2014 10:23 PM
  • This happens to me, and it happens to my boss.  Something tells me it happens to a lot of people.  Why is there no response to this?  the other thread claims that the bug cannot be reproduced, but the steps to reproduce are clearly laid out and I can reproduce it easily. 

    Also, the other thread requires me to apply a hotfix even though this issue was reported well over a year ago.  seriously wtf.  No way I'm applying a hotfix, at this point I have little faith in the 2012 SSMS developers.

    Saturday, May 24, 2014 4:57 PM
  • I've been told that this "should be fixed in SQL 2012 SP2" which I believe is due "later this year". Not particularly edifying.

    Simon Jones
    If you found this post helpful, please "Vote as Helpful". If it actually answered your question, please remember to "Mark as Answer". This will help other people find answers to their problems more quickly.

    Wednesday, May 28, 2014 8:20 AM
  • What's even more 'awesome' is this still happens in SSMS 2014...I mean, really?
    Thursday, June 12, 2014 2:18 PM
  • I can absolutely confirm that this still happens in SSMS 2014. Extremely annoying.

    Update: It's bizarre that MS can't repro this, it's the same exact Event Viewer event as the one in the "answer" link above.

    Faulting application name: Ssms.exe, version: 2014.120.2000.8, time stamp: 0x5306c06d
    Faulting module name: KERNELBASE.dll, version: 6.1.7601.18409, time stamp: 0x53159a86
    Exception code: 0xe0434352
    Fault offset: 0x0000c42d
    Faulting process id: 0x22cc
    Faulting application start time: 0x01cfce953abe5d8f
    Faulting application path: C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn\ManagementStudio\Ssms.exe
    Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
    Report Id: d54905f7-3e79-11e4-a374-001bdc0f8775

    Wednesday, September 17, 2014 3:30 PM
  • My guess is that the fault does not appear if you start with a clean PC and just install SSMS 2014.

    If you previously had SSMS 2013 and upgraded the fault might affect SSMS 2014. Or it may be something to do with also having Visual Studio on the PC.

    Obviously more work is required but Microsoft don't see it as a priority. I was told just to keep SSMS running all the time to avoid the bug.


    Simon Jones
    If you found this post helpful, please "Vote as Helpful". If it actually answered your question, please remember to "Mark as Answer". This will help other people find answers to their problems more quickly.

    Wednesday, September 17, 2014 4:15 PM
  • This happens to me with a clean install of Windows 8, SSMS2014, and VS2013.

    I did not have 2012 previously on this box.

    Friday, February 27, 2015 1:23 PM
  • Happens to me as well. SSMS2014 and Windows 7.

    Any fix here yet?

    Regards,

    Glenn


    SQL Server, its a gas!

    Tuesday, March 17, 2015 2:41 AM
  • Happens to me. Just made a clean install of Windows 7 and SSMS2014. Nothing else. It's the first thing I put on (after Office). No upgrade, no import, no nothing.

    Just a restart every time I close it... :-(

    Tuesday, June 9, 2015 11:02 AM
  • I just repaved my machine for Windows 10, and freshly installed 2016 CTP 2.2 and it's still happening for me.

    It was happening to me before I formatted my hard drive, it's happened on multiple machines.

    The - "oh it's because you'd need to format your hard drive" to make it as difficult and time-wasting to diagnose is the kind of excuse I'd expect from my IT support team, not from Microsoft.

    Monday, August 3, 2015 12:18 AM
  • I think we can be sure that this bug is probably something to do with what else is also installed on your machine, and possibly what order you installed the applications in.

    I don't think it helps that SSMS 2014 installs an old version of Visual Studio Shell or that SSDT-BI also installs several old versions of Visual Studio Shell. Getting the latest versions of SSMS, SSDT-BI and VS installs a raft of Visual C++ redistributables from 2005, 2008, 2010, 2012, 2013 & 2015 and VS Shells from 2010, 2012, 2013 and 2015. It really shouldn't be this messy.

    I get that SSMS is built on the Visual Studio Shell but surely it should use the latest version, not install three different versions and a host of other bits and pieces. 


    Simon Jones
    If you found this post helpful, please "Vote as Helpful". If it actually answered your question, please remember to "Mark as Answer". This will help other people find answers to their problems more quickly.

    Monday, August 3, 2015 7:27 AM
  • I believe the reason this hasn't been fixed, is that it's a feature, not a problem.  SSMS is a jealous program and wants you to be sure you REALLY wanted to close it, so makes you close it twice.
    Wednesday, January 13, 2016 11:49 PM
  • Same here, using SSMS 2012 SP2.

    But it happens only since I changed to a mobile device, which often changes network (releasing from docking station, so it changes to wlan network and vice versa)

    Thursday, January 28, 2016 8:07 PM
  • Still happening almost April 2016 and MS still has not fixed this.

    I have SSMS 2012 running on Win 7.

    I wonder if having SQL Tools installed into my Visual Studio 2013 has something to do with it.

    Thursday, March 31, 2016 2:57 PM
  • Yes this is a HIGHLY DESIRABLE feature in an Enterprise Database product by Microsoft (Oracle eat your heart out).  I have the same issue with SSMS 2014. 

    Hey my car re-starts itself after I turn it off - answer just keep it running...)

    Tuesday, April 5, 2016 6:03 PM
  • Happens to me all the time on Windows 10, SSMS 2014. Sure would be nice to see a fix.
    Thursday, May 19, 2016 3:26 PM
  • This is also happening with SSMS 2016 RC3 (version 13.0.14000.36) on Windows 10.

    Since this was allegedly fixed back with SSMS 2012 SP2, I'm guessing the issue is not with SSMS itself, but rather with some specific combination of other software that's installed.

    Wednesday, May 25, 2016 12:25 AM
  • Happenning on a clean install of Windows 10, even with all non-Microsoft services disabled
    Saturday, July 9, 2016 4:37 PM
  • Happens on clean install on new machine.  It is not crashing, it simply restarts like a virus!  I love how one moderator said it was answered by another moderator....typical MS moderators.  You scratch my back for points and I scratch yours instead of actually helping the community. 

    Tuesday, August 2, 2016 4:59 PM
  • Yep, this annoying bug is still present in Version 13.0.15600.2. 
    Over 5 years of development, and the bug is still there. Shame on you microsoft!

    As I told some posts above from January, it seems to happen when SSMS is open and I take my notebook off the dock and so switching the network (from LAN to WLAN). Do the other commenters have a similar situation?

    I'll try update to 13.0.15700.28 now, but I do not expect any better behaviour :( 

    By the way, ssms tells me about an update from 13.0.15600.2 to 13.0.015700.28.... clicking the link, I am given the old website with v13.0.15600.2 again, so this seems to be another bug :(



    • Edited by CrazyMC Monday, August 29, 2016 6:47 PM
    Monday, August 29, 2016 6:44 PM
  • That's a really interesting observation and I'll have to watch for it.  I saw the restart today after I connected my docking station to a wired network port so it switched from WiFi.  I'm trying to recall whether I've seen the restart when I stayed on one mode or the other the whole time, but I'll watch for it.

    I'm currently using 2016.

    Monday, August 29, 2016 7:55 PM
  • Does it on 2012 and 2014 for me, has for a couple years now.   If only Nexus had a few more SSMS features I'd be 100% there as the tabbing saved results (and saved queries) is so nice...  anyway, ssms restart on close very frustrating, widespread.   
    Saturday, October 1, 2016 12:26 AM
  • Yep, this annoying bug is still present in Version 13.0.15600.2. 
    Over 5 years of development, and the bug is still there. Shame on you microsoft!

    As I told some posts above from January, it seems to happen when SSMS is open and I take my notebook off the dock and so switching the network (from LAN to WLAN). Do the other commenters have a similar situation?

    I'll try update to 13.0.15700.28 now, but I do not expect any better behaviour :( 

    By the way, ssms tells me about an update from 13.0.15600.2 to 13.0.015700.28.... clicking the link, I am given the old website with v13.0.15600.2 again, so this seems to be another bug :(



    Hey, i quote myself... nice :)

    So, now I am using SSMS 2016 (testet every version of 16.x) and the problem still exists. That is so time wasting. And now, I can tell, that it does not have to do something with a mobile computer leaving the network several times (LAN, WLAN, LAN, WLAN, ...). I do have the problem now also on my stationary pc at home. I don't know where, but somebody mentioned it happened since he used a full version of Visual Studio parallel. So is what I think now.

    Maybe, if my frustation level is high enough, I will do as Alberto Morillo suggested and send a crash dump to microsoft.... maybe.... I can not believe, that this problem does not appear to microsoft developers (at microsoft) as well?!?!

    Monday, October 10, 2016 7:16 PM
  • Yep, this annoying bug is still present in Version 13.0.15600.2. 
    Over 5 years of development, and the bug is still there. Shame on you microsoft!

    As I told some posts above from January, it seems to happen when SSMS is open and I take my notebook off the dock and so switching the network (from LAN to WLAN). Do the other commenters have a similar situation?

    I'll try update to 13.0.15700.28 now, but I do not expect any better behaviour :( 

    By the way, ssms tells me about an update from 13.0.15600.2 to 13.0.015700.28.... clicking the link, I am given the old website with v13.0.15600.2 again, so this seems to be another bug :(



    Hey, i quote myself... nice :)

    So, now I am using SSMS 2016 (testet every version of 16.x) and the problem still exists. That is so time wasting. And now, I can tell, that it does not have to do something with a mobile computer leaving the network several times (LAN, WLAN, LAN, WLAN, ...). I do have the problem now also on my stationary pc at home. I don't know where, but somebody mentioned it happened since he used a full version of Visual Studio parallel. So is what I think now.

    Maybe, if my frustation level is high enough, I will do as Alberto Morillo suggested and send a crash dump to microsoft.... maybe.... I can not believe, that this problem does not appear to microsoft developers (at microsoft) as well?!?!

    And it happens again and again ... every day ...  and no comment from moderators or ms professionals ... this is a shame! Ok, SSMS is for free, but please, please, please fix this time wasting issue. At the moment, we plan to buy another dba-like solution from e.g. quest/dell or from somebody else... and I do not want that to do so!
    Wednesday, October 19, 2016 10:34 PM
  • I also have the same issue.  I had Windows 10 with SSMS 2014 and constantly had to click the cancel button to stop the application from restarting upon close. Just moved to a fresh Windows 10 build with SSMS 2016 on an SSD and still get the same issue (only now, it restarts so fast that I don't get a chance to hit the cancel button!).

    One would have thought that M$ would have fixed this issue.  I am not the only one in my team that suffers from it, but what it really strange is that not everyone in my team does; and we all have the same initial setups, just different hardware.

    This is one of the more annoying bugs of what is actually a great product.  Come on Microsoft - help us out here!

    Tuesday, October 25, 2016 10:37 AM
  • I have SSMS2014 and SSMS2016. it happens only on SSMS 2016. tried to resolve this issue but no success. So i changed my way to close SSMS 2016. i save project/solution/files and then close all files and finally kill the SSMS 2016 process in task manager.
    Tuesday, March 21, 2017 10:33 AM
  • Along with everyone else, this happens to me.  

    Microsoft SQL Server Management Studio      11.0.5388.0
    Microsoft Data Access Components (MDAC)      10.0.15063.0
    Microsoft MSXML      3.0 4.0 6.0
    Microsoft Internet Explorer      9.11.15063.0
    Microsoft .NET Framework      4.0.30319.42000
    Operating System      6.3.15063

    It seems to happen when I'm exiting SSMS and have a modified query sql file open and it prompts me if I want to save it, to which I reply, no.  But it doesn't happen every time, but ought to give codes a place to look for some sort of bad code that doesn't handle the exiting properly.

    Thursday, May 18, 2017 2:37 PM
  • November 2017 and still happening with SSMS 2016.

    Tony

    Friday, November 3, 2017 2:37 PM
  • Just an update.  I am not sure when, but this issue appears to have vanished from our entire team.  I can only presume that an update to SSMS fixed the issue.
    Friday, November 3, 2017 3:12 PM
  • Not sure what version you are on, but I'm still getting it to this day with SSMS 2016 - and the same error in the event log.... It's so annoying when I want to close the application down and shut the PC down to go home, then it decided to restart...

    Faulting application name: Ssms.exe, version: 2015.130.16106.4, time stamp: 0x58891f43
    Faulting module name: KERNELBASE.dll, version: 10.0.16299.15, time stamp: 0x2cd1ce3d
    Exception code: 0xc0020001
    Fault offset: 0x001008b2
    Faulting process id: 0x59e4
    Faulting application start time: 0x01d3758248e9bce0
    Faulting application path: C:\Program Files (x86)\Microsoft SQL Server\130\Tools\Binn\ManagementStudio\Ssms.exe
    Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
    Report Id: d4e08249-ba15-4315-bf95-8175e9865fd5
    Faulting package full name: 
    Faulting package-relative application ID: 


    Friday, December 15, 2017 10:20 AM
  • At the moment I am using SSMS 2016 v13.0.16106.4 and SSMS 2008 R2 v10.50.1600.1.

    Here are my version details for my SSMS 2008 R2:

    Microsoft SQL Server Management Studio 10.50.1600.1Microsoft Data Access Components (MDAC) 10.0.15063.0
    Microsoft MSXML 3.0 6.0Microsoft Internet Explorer 9.11.15063.0
    Microsoft .NET Framework 2.0.50727.8794
    Operating System 6.3.15063


    and 2016:

    Microsoft SQL Server Management Studio 13.0.16106.4
    Microsoft Analysis Services Client Tools 13.0.1700.441
    Microsoft Data Access Components (MDAC) 10.0.15063.0
    Microsoft MSXML 3.0 6.0 
    Microsoft Internet Explorer 9.11.15063.0
    Microsoft .NET Framework 4.0.30319.42000
    Operating System 6.3.15063

    Cheers

    Tuesday, December 19, 2017 10:49 AM
  • As frustrated as I was after reading this thread, I kept searching, and found the solution; set the 'Auto Close' property on the database to False.

    See also: Best Practices from 2017, recommending this setting.

    Tuesday, July 23, 2019 9:39 PM