none
RC0: RS Installation Problem - The credentials you provided for Reporting Services service are invalid. To continue ...

    Question

  •  

    Hi

     

    When installing 2008 RC0 I get the following error message:

     

    "The credentials you provided for Reporting Services service are invalid. To continue, provide a valid account and password for the Reporting Services service.

     

    Error code: 0x84B40000"

     

    During the installation process it never prompted for the credentials to be used for the Reporting Services service (i.e. the Reporting Services service did not appear under the "Service Accounts" tab during the Server Configuration stage of the installation. The other services did appear). In the "Ready to Install" stage the Account under Reporting Services, Service Configuration is given as "udefined". Everything else installed without a problem.

     

    Any help would be appreciated.

     

    Thanks.

     

     

    Egmont

    Thursday, June 12, 2008 10:08 AM

Answers

  • I had a similar problem but solved it. In the installation window there are boxes for account and password  there are drop down lists but the default is blank. Choose the appropriate drop down and the password should be blank.

    Hope this helps.
    Paul
    Thursday, September 11, 2008 2:14 PM

All replies

  • I've got the same message - just about SQL Agent credentials. I was trying to upgrade default instance from February beta to RC0. Sounds like another major "drama"... 

     

    Friday, June 13, 2008 6:01 AM
  • I received the same message regarding the AGENT service.  I had a previous version installed and did two things to get around the issue:

     

    1.) Uninstalled the previous version

    2.) Installed RC0 using the network service as the service to run all accounts.

     

    Once installed, I went around changing the services to run under the accounts I wanted.

     

    Adam P. Cassidy

    Friday, June 13, 2008 2:57 PM
  • I had a similar problem but solved it. In the installation window there are boxes for account and password  there are drop down lists but the default is blank. Choose the appropriate drop down and the password should be blank.

    Hope this helps.
    Paul
    Thursday, September 11, 2008 2:14 PM
  • I had a same and similar issue.

    I finish the installation by providing SQL Agnt and SQL Service by NT AUTHORITY\NETWORK SERVICE and blank password. Once complete the installation I changed the Service Account by services.msc to SQL SA account.
    Reason: Service account is not granted for Log on as Service.
    Solution: Grant the SA to Log on as Service.

    Abu
    • Proposed as answer by jvelezc Tuesday, May 3, 2011 7:50 PM
    • Unproposed as answer by jvelezc Tuesday, May 3, 2011 7:50 PM
    Thursday, May 14, 2009 8:24 AM
  • I know this is ancient history ... but it is new to me .. so Thanks Paul
    Saturday, May 1, 2010 5:17 AM
  • Paul,

    I had the same problem.  Your solution took care of the problem.

    Thanks,

    Scott

    Tuesday, June 8, 2010 3:34 PM
  •  Hi I have a same issue. But I'm doing silent install. Is there any solution?

    Thursday, February 3, 2011 11:19 PM
  • here is the answer for this problem:

    when you promt for the credentials then selct the current user as the user name and password should be the same as you used to login the windows . that will defenetly let you continue the installation process.

    another option is

    you log off the windows and log back in as an administrator and try install the sql server keeping the administrator at the user name credential part. provided password should be the same as you used to login windows.

    Sunday, March 20, 2011 6:20 PM
  • I had a same and similar issue.

    I finish the installation by providing SQL Agnt and SQL Service by NT AUTHORITY\NETWORK SERVICE and blank password. Once complete the installation I changed the Service Account by services.msc to SQL SA account.
    Reason: Service account is not granted for Log on as Service.
    Solution: Grant the SA to Log on as Service.

    Abu

    Bad Idea When you first install Microsoft SQL Server to run under a Microsoft Windows NT account, SQL Server sets for that Windows NT account various Windows user rights and permissions on certain files, folders, and registry keys. If you later change the startup account for SQL Server (the MSSQLServer service) and the SQL Server Agent service by using SQL Server Enterprise Manager (SEM) or SQL Server Configuration Manager (SSCM), SEM automatically assigns all the required permissions and Windows user rights to the new startup account for you so that you do not have to do anything else. We recommend that you use this is the approach to change the service account.

    http://support.microsoft.com/kb/283811
    Tuesday, May 3, 2011 7:52 PM
  • The accounts used for the services have to be allowed to run as a service, run rsop.msc and look at
    “computer config > windows settings > security settings > local policies > user rights assignment” go to policy “log on as a service” and add the accounts/group here.
    If you cannot edit the local policy it´s probably because your server is in a domain and this is set by a GPO and then you will have to edit it or add a new GPO to override this setting.

    //Jimi

    Monday, June 20, 2011 8:19 AM
  • Thanks JimiSweden! I wasn't able to edit it on Windows 7. I was not able to sort it by GPO, but starting the policy manager from the control panel did the trick. It said it didn't allow adding the account but it did it anyway. Here's the link that pointed me to the control panel:

    http://support.gfi.com/manuals/en/webmon2011gsg/webmon2011gsg.1.29.html

    edit: after changing the security policies, I was still getting a few "invalid credentials" complaints from the sql server installer. I clicked "use same account for all", selected the user account. After that it was happy but it didn't actually propagate the setting to all services :P

    • Edited by Anke6831 Monday, April 23, 2012 8:13 PM added update
    Monday, April 23, 2012 8:05 PM
  • Thank you for your information, I just resolved the same problem with your method. Thank you again.

    Joy

     
    Friday, October 12, 2012 5:18 AM
  • Ensure the “SQL Server Database Engine” is set to Automatic. Set the <IP Address of the SQl Server\Username> and <password>, where the Username is the user name of the Administrator  for the built-in SQL Server system administrator account. This is the superuser account for the database.  Ensure that the “SQL Server Database Engine” Startup Type is set to 'Automatic'.

    Set the ‘SQL Server  Reporting Services’to 'NT AUTHORITY\LOCAL SERVICE  or NT AUTHORITY\NETWORK SERVICE from the drop down list, as applicable, and set the Startup Type to ‘Manual’

    Double-check that “SQL Full-text Filter Daemon Launcher” is set to startup type “Manual” and “SQL Server Browser” is set to Disabled. Both should have the account name set to “NT AUTHORITY\LOCAL SERVICE”

    Thursday, July 17, 2014 5:45 PM