none
trigger image is too big in ssrs RRS feed

  • Question

  • I created a simple report and subreport, everything is working fine. but image "+" is too big(the image is added auto), I am not sure what the problem is.

    use vs2013, web form + report viewer.

    like below, I cannot find any setting about the image, thanks for your help.

    Monday, July 3, 2017 2:03 PM

All replies

  • Hi AlbertLin,

    In your scenario,  I don’t understand the words “the image is added auto”. Did you mean that the image is not added when you designed the report in VS 2013? Did you add it by refer to corresponding code ? If so, you could try to resize it by setting its height and width to see whether it works or not. If not so, and if you add it when you design report in VS 2013, you could try to right click the image, configure its size in Image Properties->Size to see whether it works or not.

    In addition, did this issue only occur in web form page, it works well in VS preview and report view control? Or did this image is designed in sub report? If so, you could modify the image size in original report with above method.

    If you have any question, please feel free to ask.

    Best regards,
    Zoe Zhi


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, July 4, 2017 5:53 AM
    Moderator
  • Thanks Zoe Zhi,

     actually I didn't add any image on my report, my steps just like below:

    1. Drag a table control into the designer panel and add some fields into it.

    2. Create a sub report which includes a parameter to receive the value from main report.

    3. Click the table, right-click the detail row, and then click Insert Row Below to add a new row.

    4. Drag a subreport control into that new detail row, and set the its relative property.

    5. Click the second detail row, which contains the subreport, to select the entire row. In the Properties window, expand the Visibility category, and then click True in the Hidden property. Select Main Id textbox in the ToggleItem property drop-down list.

    the report was working before, I am not sure why the "+" is so big right now. by the way, the image comes from Reserved_ReportViewerWebControl, I cannot see the image when design.

    any idea?

     
    Wednesday, July 5, 2017 2:51 PM