none
permission granted to user are insufficient for performing this operation - test connection

    Question

  • I (think) i migrated a 2000 reporting service database over to 2008. I say i think because i'm getting some weird behavior. I have a folder where i place all the datasources. On most of them, if i click manage, and then test connection, i get an error of:

    The permissions granted to user <my login> are insufficient for performing this operation. (rsAccessDenied)

    I am listed as the system admin and system user under site settings, security. I tried changing it to just sys admin. That seems to have given me access to test at least some of the data sources.

    I compared the security settings on the ones i can test vs the ones i cant, and they are the same. I have no problems running the reports attached to this datasource. 

    Is this a permission issue on the source database? Because i tried creating a new datasource to the same source db and got the same error. But wouldn't the test connection button use the credentials supplied if i have NOT selected the otion to use windows credentials? Although one of the databases that i CAN use the test connection button on, i do not have permission to connect to using my windows login.

    So i really have no clue why i seem to be unable to 'test connection' on some of the datasources. Any suggestions?

    Friday, October 08, 2010 7:16 PM

Answers

  • Hi Ian,

    It seems that you are running SSRS 2008 R2. To find the root cause, i would suggest you create a sql account to access the source database, then change the source credential to "Credentials stored securely in the report server" and type the sql account to test the connection. If the issue persists, please give more detaile about "mylogin" in your system, if it is ok, please verify whether the "my login" account access the source database.

    thanks,
    Jerry

    Monday, October 11, 2010 10:31 AM
    Moderator

All replies

  • Hi Ian,

    It seems that you are running SSRS 2008 R2. To find the root cause, i would suggest you create a sql account to access the source database, then change the source credential to "Credentials stored securely in the report server" and type the sql account to test the connection. If the issue persists, please give more detaile about "mylogin" in your system, if it is ok, please verify whether the "my login" account access the source database.

    thanks,
    Jerry

    Monday, October 11, 2010 10:31 AM
    Moderator
  • Hi Ian

    I seems that I'm having the same situation.

    I have a user on a datasource that fail to "Test Connection" but still can run the report OK

    Did you resolve you problem above?

    (SQL 2008 R2)

     

    Thank in advance

     

    Monday, November 01, 2010 1:58 PM
  • Hi Ian

    It seems that I'm having the same situation.

    I have a user on a datasource that fail to "Test Connection" but still can run the report OK

    Did you resolve you problem above?

    (SQL 2008 R2)

     

    Thank in advance

     

    Monday, November 01, 2010 2:32 PM
  • I am also having the same issue as Ian and simchap, we upgraded our first two servers fine and were able to create new data sources and test connections fine. On this other server we can test connections on existing data sources, I don't dare try to change it, but any new data sources we create it doesn't work. This is with trying to test a connection between two different databases as well as testing a SQL account and a windows domain account. We were able to test connections using the two different accounts on the other SSRS servers fine.

     

    We upgraded from SSRS 2005 to 2008 R2.

    Wednesday, December 15, 2010 4:23 PM
  • The permissions granted to user <'Domain\windows_logged_in_user'> are insufficient for performing this operation. (rsAccessDenied)

    I have the same problem, the "Test Connection" button doesnt throw me error only when I am a local administrator on the reports server box.

    Did anyone solve this problem in SQL 2008 R2 reports server?

    I access http://reportserver/reports from my workstation to change the datasource servername.
    I change the server name then my shared  datasource sql user password prompts to be updated.
    my shared datasource is configured as in the image below "credentials stored securely in the report server" when I click "test connection" button it fails.
    Only succeds when 'Domain\windows_logged_in_user' is a local admin on the reports server box.

    Test Connection fails - Credentials stored securely in the reports server

    when I click I get the following error

    The permissions granted to user 'Domain\windows_logged_in_user' are insufficient for performing this operation. (rsAccessDenied) Get Online Help.

    I checked all my SPN, site/item level security settings.

    Any help to resove this problem is highly appreciated.

    Thanks


    • Edited by WeenDeen Monday, October 01, 2012 4:50 PM
    Monday, October 01, 2012 4:49 PM