none
Install SQL Server Native Client 2012 on SQL Server 2005 RRS feed

Answers

  • The error message is true, but I understand why you find it hard to believe, I did too when I found out. 

    SQL Server Native Client 2012 requires Windows Vista/Windows 7 and above.  I have no problem with that, because XP/2003 can use Native Client 2008 R2.  But the PHP driver's inability to utilise the 2008 R2 client, even when it's the best available for the operating system, is a problem.

    Your choices are:
    1. Upgrade Server 2003 to Server 2008
    2. Downgrade the PHP driver to version 2.0 with Native Client 2008
    3. Try my slightly modified build of Microsoft's latest PHP driver which works with Native Client 2008 on XP/2003 - a download link is here: http://robsphp.blogspot.co.uk/2012/06/unofficial-microsoft-sql-server-driver.html


    Rob

    Tuesday, August 14, 2012 11:25 PM

All replies

  • Sorry, the error says that I cannot install the native client because my Operative system don't support it. I have Windows Server 2003 SP Standard Edition

    Ernest5HN

    Tuesday, August 14, 2012 8:23 PM
  • The error message is true, but I understand why you find it hard to believe, I did too when I found out. 

    SQL Server Native Client 2012 requires Windows Vista/Windows 7 and above.  I have no problem with that, because XP/2003 can use Native Client 2008 R2.  But the PHP driver's inability to utilise the 2008 R2 client, even when it's the best available for the operating system, is a problem.

    Your choices are:
    1. Upgrade Server 2003 to Server 2008
    2. Downgrade the PHP driver to version 2.0 with Native Client 2008
    3. Try my slightly modified build of Microsoft's latest PHP driver which works with Native Client 2008 on XP/2003 - a download link is here: http://robsphp.blogspot.co.uk/2012/06/unofficial-microsoft-sql-server-driver.html


    Rob

    Tuesday, August 14, 2012 11:25 PM