none
SQL job failing complaining about Oracle Components. RRS feed

  • Question

  • Hi Gurus, 

    My package has Oracle source, create a flat file and FTP that file in the end.

    It ran fine on my local machine so I exported this package into Integration services Instance and ran, it ran fine.

    But when I created the agent job to run it is failing complaining as below:

       Description: SSIS Error Code DTS_E_OLEDBERROR.  An OLE DB error has occurred. Error code: 0x80004005.
    An OLE DB record is available.  Source: "Microsoft OLE DB Provider for Oracle"  Hresult: 0x80004005  Description: "Oracle client and networking components were not found. These components are supplied by Oracle Corporation and are part of the Oracle Version 7.3.3 or later client software installation.

    Provider is unable to function until these components are installed.".
    End Error

    But when I checked the server that has Oracle client 11g installed on it same as my local machine and SQL Server 2008R2.

    Please help me with this.


    • Edited by Spartaa Thursday, June 13, 2013 2:06 PM
    Thursday, June 13, 2013 2:01 PM

Answers

  • I think you must have same version of Oracle client installed on server, the same you have in development server.

    Thanks, hsbal

    Friday, June 14, 2013 1:59 PM

All replies

  • It must be the security setting of the driver.

    See the bottom of this post to resolve.


    Arthur My Blog

    Thursday, June 13, 2013 2:12 PM
    Moderator
  • It must be the security setting of the driver.

    See the bottom of this post to resolve.


    Arthur My Blog

    Hi Arthurz, 

    I have windows XP OS. I went to Oracle folder, right click and went to security and sharing but I dont know what to check here. 

    I see as below. What option is he referring in the post?

    Thursday, June 13, 2013 2:26 PM
  • Enable sharing

    Arthur My Blog

    Thursday, June 13, 2013 2:49 PM
    Moderator
  • Enable sharing

    Arthur My Blog

    I did enabled that and had my sys admin reboot the server. And I ran the job but still getting the same message. 

    This is what I did my server is Windows 2008R2 . What else could be the issue. ? Thanks

    


    • Edited by Spartaa Thursday, June 13, 2013 3:38 PM
    Thursday, June 13, 2013 3:38 PM
  • Just for testing, if you have BIDS installed on the server, fire up BIDS on server, and add your package on new BIDS project. Test it.


    Thanks, hsbal

    Thursday, June 13, 2013 7:54 PM
  • Just for testing, if you have BIDS installed on the server, fire up BIDS on server, and add your package on new BIDS project. Test it.


    Thanks, hsbal

    When I do that I am getting below error, which is same as above.

    TITLE: Connection Manager
    ------------------------------

    Test connection failed because of an error in initializing provider. Oracle client and networking components were not found. These components are supplied by Oracle Corporation and are part of the Oracle Version 7.3.3 or later client software installation.

    Provider is unable to function until these components are installed.

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    Thursday, June 13, 2013 8:21 PM
  • I think you must have same version of Oracle client installed on server, the same you have in development server.

    Thanks, hsbal

    Friday, June 14, 2013 1:59 PM
  • I think you must have same version of Oracle client installed on server, the same you have in development server.

    Thanks, hsbal

    They both have 11g but from what I see, looks like the one on server was not installed admin installation option. I will check with my DBA on Monday and update.Thanks
    Friday, June 14, 2013 7:48 PM