none
SQL Server 2000 DTS Designer components are required to edit DTS packages - in SQL 2008 RRS feed

  • Question

  • I m trying to open 2000 DTS package in SSMS of SQL 2008 and get the below error:

    Any solution?

     

    TITLE: Object Explorer
    ------------------------------

    SQL Server 2000 DTS Designer components are required to edit DTS packages. Install the special Web download, "SQL Server 2000 DTS Designer Components" to use this feature. (Microsoft.SqlServer.DtsObjectExplorerUI)

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

     

     

    thanks

     

    Wednesday, October 15, 2008 1:05 PM

Answers

  • I already went thru the above and installed - SQLServer2005_BC & SQLServer2005_DTS softwares.

     

    The issue was with PATH environment variable setting. 

    After changing the order in the path setting it got resolved.

     

    C:\Program Files\Microsoft SQL Server\80\Tools\Binn\;  should appear before the

    C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;

     

    Incase of 64 bit machine:

    C:\Program Files (x86)\Microsoft SQL Server\80\Tools\Binn\; 

     

     

    Be sure to restart the SSMS after changing the PATH env variable.

     

    Thanks

     

     

    Thursday, October 16, 2008 10:10 AM

All replies

  • You need to install the DTS Designer from the SQL Server Feature Pack, available here under Backwards Compatability: http://www.microsoft.com/downloads/details.aspx?FamilyID=c6c3e9ef-ba29-4a43-8d69-a2bed18fe73c&DisplayLang=en

     

    Wednesday, October 15, 2008 1:30 PM
    Moderator
  • I already went thru the above and installed - SQLServer2005_BC & SQLServer2005_DTS softwares.

     

    The issue was with PATH environment variable setting. 

    After changing the order in the path setting it got resolved.

     

    C:\Program Files\Microsoft SQL Server\80\Tools\Binn\;  should appear before the

    C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;

     

    Incase of 64 bit machine:

    C:\Program Files (x86)\Microsoft SQL Server\80\Tools\Binn\; 

     

     

    Be sure to restart the SSMS after changing the PATH env variable.

     

    Thanks

     

     

    Thursday, October 16, 2008 10:10 AM

  • I had same Issue but worked by below step
    Once you install DTS components  ON the server where you are OPENING the packages FROM and not working

    DTS Components need to be installed on your workstation, not the server.


    Let us know if it solved the problem .


    Thanks Faiz Farazi MCDBA,MCSA
    Wednesday, August 26, 2009 6:59 PM
  • Where is the PATH environment vairable setting to change in the above answer? I have tried a bunch of suggestions and have not been able to resolve my problem opening a DTS in SQL 2005 or 2008.

    Friday, October 16, 2009 7:50 PM
  • Go to the Start menu, right-click on Computer, and choose Properties. Select Advanced System Settings (the Advanced tab), and there should be an Environment Variables button in the lower portion of the dialog. You can update the PATH variable here - make sure you change it under the System variables section.


    John Welch | www.mariner-usa.com | www.agilebi.com | ssisUnit.codeplex.com
    • Proposed as answer by Kalman Toth Thursday, June 30, 2011 2:36 AM
    Saturday, October 17, 2009 2:49 PM
    Moderator
  • This (changing the path) worked for me as well when I had the problem.  Thanks very much for following up with your solution.
    Wednesday, December 23, 2009 11:51 PM
  • I already went thru the above and installed - SQLServer2005_BC & SQLServer2005_DTS softwares.

     

    The issue was with PATH environment variable setting. 

    After changing the order in the path setting it got resolved.

     

    C:\Program Files\Microsoft SQL Server\80\Tools\Binn\;  should appear before the

    C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;

     

    Incase of 64 bit machine:

    C:\Program Files (x86)\Microsoft SQL Server\80\Tools\Binn\; 

     

     

    Be sure to restart the SSMS after changing the PATH env variable.

     

    Thanks

     

     

    I used that way but every time the package strat load this error showed up

    Error HRESULT E_FAIL has been returned from a call to a COM component. (Microsoft Visual Studio)

    Note I am trying to open it from BIDS (Execute 2000 DTS task)


    Volcano "DATA is the Focus, Business is the Target”"
    Wednesday, May 19, 2010 2:54 PM
  • I tried to resolve this issue using the suggestions above and it still didn't work.

    My environment is a 64 bit SQL 2008 environment.

     

    Friday, January 21, 2011 7:05 PM
  • Solved mine problem with editing SQL Server 2000 DTS with Management Studio 2005 on Win7 64!

    Thanks!

    Thursday, March 3, 2011 6:18 PM
  • Mahesh,

    Thanks a BUNCH for your help, I was breaking my head over this and now it is solved!

    I am sane again. Thanks again:-)!!!

    Thursday, April 28, 2011 8:01 PM
  • I got the same issue and I fixed it by replacing stardds.dll by the newer version.
    Wednesday, June 22, 2011 8:16 AM
  • I got the same error too! Where can I get the newer version of stardds.dll?

    Thursday, June 30, 2011 2:22 AM
  • This solved my problem, thanks!!!

    Wednesday, October 12, 2011 4:20 PM
  • Thanks Mahesh, it solved my problem!
    Wednesday, October 19, 2011 11:59 AM
  • One thing to note on the environment variable. I had to set the variable as a System variable in Windows 7 (x64) and not as a User variable in system properties in order for the change to work. After setting the variable, I closed SSMS, reopened it and now I can open DTS packages.
    Kenny
    Monday, January 23, 2012 7:02 PM
  • Thanks Mahesh, I placed C:\Program Files (x86)\Microsoft SQL Server\80\Tools\Binn\; as my first entry in the path variable in x64 machine and it worked.


    Senthil.

    • Proposed as answer by SQL-ER Wednesday, July 11, 2012 4:41 PM
    Sunday, April 22, 2012 6:36 PM
  • For those who still struggles with the problem read this: http://technet.microsoft.com/en-us/library/ms143755%28v=sql.105%29.aspx

    It has very detailed description of what to do to enable DTS in SQL 2008 R2 tools.  Much better than playing with the environment variables.

    Wednesday, July 11, 2012 6:02 PM
  • I had this same problem but I resolved it with the information in this thread. 

    I, too, had already installed the SQL2005 Backwards Compatibility code, as well as the SQL 2000 DTS Design Components code, and still encountered the same error.  It was only after changing the PATH Environment Variables as given by HelloMahesh, that this code was finally operable.   Many thanks to HelloMahesh.

    --Paul


    --petrejo

    Wednesday, October 24, 2012 6:13 PM
  • Tks hellomahesh.

    Just like Senthil Duraisamy  i pasted "C:\Program Files (x86)\Microsoft SQL Server\80\Tools\Binn\; " in the beginning of the path variable and it worked.

    I first tried to follow the section “Installing Design-time Support for DTS Packages” of this link: http://technet.microsoft.com/en-us/library/ms143755%28v=sql.105%29.aspx and it didn’t word.

    Then I tried to past it right before the "C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;" path (but not in the beginning of the variable) and it didn't work at that time. Then a tried to put the first path in the beginning and it works fine.

    My environment is x64 Win 7.

    Note: Sorry about the english.

    Monday, November 5, 2012 3:03 PM
  • C:\Program Files (x86)\AMD APP\bin\x86_64
    C:\Program Files (x86)\AMD APP\bin\x86
    %SystemRoot%\system32
    %SystemRoot%
    %SystemRoot%\System32\Wbem
    c:\Program Files (x86)\Common Files\Roxio Shared\10.0\DLLShared\
    C:\Program Files (x86)\Common Files\Acronis\SnapAPI\
    C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static
    %systemroot%\System32\WindowsPowerShell\v1.0\
    C:\Program Files (x86)\Microsoft SQL Server\80\Tools\Binn\
    C:\Program Files\Microsoft SQL Server\100\DTS\Binn\
    C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\
    C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\
    C:\Program Files\Microsoft SQL Server\100\Tools\Binn\
    C:\Program Files (x86)\Microsoft SQL Server\100\DTS\Binn\

    This is what i have and i still am not able to edit/design DTS components from a 2000 server on my windows 7 pro x64 OS

    I have the same issue as described here:

    http://social.msdn.microsoft.com/Forums/en-US/sqlintegrationservices/thread/044de86d-7bb0-41f2-a4b0-7f0ab2de017b/

    **Edit: Turns out my coworker also cannot edit sql 2000 dts packages from his 64 bit windows 7....... From before: "copied a co-workers working PATH contents and his works mine doesn't. Still nothing fixed for me"



    • Edited by TheMafia Tuesday, February 5, 2013 7:40 PM
    Tuesday, February 5, 2013 3:07 PM
  • Able to open and migrated in sql2008 r2 - x694 thru
    designer 2000 but during first time when we open it gives SQLDMO.dll has not
    registered and when we click ok able to get thru.
    Wants to make sure its
    something needs to conceren or fix
    Friday, April 19, 2013 12:53 PM
  • Thanks, this helped. There were multiple entries for "C:\Program Files\Microsoft SQL Server\100\Tools\Binn\", so mine only worked after entering the new string before the first one.
    Monday, February 10, 2014 11:59 PM
  • Thanks a lot....been struggling with this issue for a while, after multiple installs of DTS components.
    This solved it!
    Wednesday, June 4, 2014 3:59 PM
  • Hi,

    I am also getting the same issue. Could someone please help me to solve the issue.

    Thanks,

    Raja


    Thanks, Raja

    Thursday, April 23, 2015 6:19 PM
  • Thank you hellomahesh for sharing the fix.
    Tuesday, August 7, 2018 9:08 AM