none
Balanced Data Distributor does not install

    Question

  • Hi All,

    We are trying to install the Balanced Data Distributor for SSIS, which is a really cool little transformation written (I think) by the SQLCAT Team.#

    The problem is, that despite having SQL Server 2008R2 Installed, SSIS Installed (Yes, the service is started) and BIDS 08 Installed, when trying to install it on a number of Dev VMs, we get the following error:

    The installation was not successful. Check the following pre-requsits:

    1)Either Integration Services or BIDS has to be installed

    2)The version of these components has to be either SQL Server 2008 SP2 (or furture SPs) or SQL Server 2008 R2 (or future SPs)

    For once, Mr Google has no ideas. Has anybody encountered this, or know of a solution?

    Thanks,

    Pete


    Peter Carter http://sqlserverdownanddirty.blogspot.com/
    Tuesday, October 04, 2011 10:00 AM

Answers

  • Do you have permissions over regedit entry HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\100\ ? The setup checks here the SQL version.


    Víctor M. Sánchez García (ES) (BI) Hope this help. Please vote if you find this posting was helpful. if this is an answer to your question, please mark it. http://bifase.blogspot.com | http://twitter.com/atharky
    Tuesday, October 04, 2011 12:59 PM
  • Hi Victor,

    I checked this initially, and it was showing the correct version. If I had dropped this version doen to the RTM version number, it would probably have worked, but I have just finished testing a rather more time-consuming work-around which did work.

    That was to uninstall SP1, install BDD, re-install SP1.

    Thanks for your help.

    Pete


    Peter Carter http://sqlserverdownanddirty.blogspot.com/
    Tuesday, October 04, 2011 1:39 PM

All replies