none
TCP Error

    Question

  • Dear all,

    any one help me on this issue

    when I try to connect localy(in the same machin) using Network protocol tcp\ip  I am getting this error

    Cannot connect to abcd\itach

    Additional Information:

    A network-related or instance-spacific error occured while establishing a connection to SQL server. The server was not found or was not accessible. Verify that the instance name is correct and that sql server is configured to allow remote connections. (provider:TCP Provider, Error:0 - An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full.), (Microsoft SQL Server, Error:10055)

    work arround I tried:- I can able to connect this from another machin using tcp of this machin, and remote connection has been enabled.

    Saturday, October 09, 2010 12:20 PM

Answers

  • 1.Service is not running

    2.SQL Browser is not running

    3.Posrt UDP 1434 not added to firewall

    4.Instance name is not correct


    Best Regards, Uri Dimant SQL Server MVP http://dimantdatabasesolutions.blogspot.com/ http://sqlblog.com/blogs/uri_dimant/
    Sunday, October 10, 2010 8:56 AM
    Answerer

All replies

  • Hello mcsri,

    ...using Network protocol tcp\ip  I am getting this error...

    How did you forced it to use TCP/IP protocol? If I use tcp:machine\instance or over the loopback device tcp:127.0.0.1\instance it works pretty fine and in sysprocesses I can see, TCP/IP is really used, if:

    - TCP/IP protocol is enabled (see How to: Configure Express to accept remote connections)
    - SQL Server Browser service is running.


    Olaf Helper ----------- * cogito ergo sum * errare humanum est * quote erat demonstrandum * Wenn ich denke, ist das ein Fehler und das beweise ich täglich http://olafhelper.over-blog.de
    Sunday, October 10, 2010 5:40 AM
    Moderator
  • Hi Olaf,

    Thanks for the update,

    while connecting to server, in login pane I have given server name abcd\itach and connection Properties I am pointing to tcp\ip (initialy it is default), it getting faile.

    If point to default it is connecting and  if check select * from sys.dm_exec_connections where session_id=@@spid it is showing named pipes which is not enabled.

    Sunday, October 10, 2010 8:33 AM
  • 1.Service is not running

    2.SQL Browser is not running

    3.Posrt UDP 1434 not added to firewall

    4.Instance name is not correct


    Best Regards, Uri Dimant SQL Server MVP http://dimantdatabasesolutions.blogspot.com/ http://sqlblog.com/blogs/uri_dimant/
    Sunday, October 10, 2010 8:56 AM
    Answerer
  • 1.Service is not running

    2.SQL Browser is not running

    3.Posrt UDP 1434 not added to firewall

    4.Instance name is not correct


    Best Regards, Uri Dimant SQL Server MVP http://dimantdatabasesolutions.blogspot.com/ http://sqlblog.com/blogs/uri_dimant/
    Sunday, October 10, 2010 8:56 AM
    Answerer