none
Report Server Cannot Open Connection to Report Server Database RRS feed

  • Question

  • Hi,

    I got consistent error of the following:

    ReportingServicesService!runningjobs!13!1/3/2007-10:45:21:: e ERROR: Error in timer Database Cleanup (NT Service) : Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerDatabaseUnavailableException: The report server cannot open a connection to the report server database. A connection to the database is required for all requests and processing. ---> System.Data.SqlClient.SqlException: An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
       at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
       at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
       at System.Data.SqlClient.SqlConnection.Open()
       at Microsoft.ReportingServices.Library.ConnectionManager.OpenConnection()
       --- End of inner exception stack trace ---

    The error happens on Reporting Service version 9.00.3017.00 (the version we are running in Production). The Reporting Service and its database are actually resided in the same physical server. And the strange thing is that it does not prevent any functionalities or features working except when I launch the Management Studio on that server, it usually takes 2 minutes to load up. (any other server would just take 5 -10 seconds).

    Can any one help?

    Thanks!

    William.

     

    Friday, January 5, 2007 8:57 PM

All replies

  • Hi William

     See in your SQL server where you have reporting services installed, configuration manager-  TCP/IP  and Named Pipes 'Enabled'

    I know this is very late reply but might helps someone :-)

    Kind regards

    JP


    JohnRenik


    • Edited by John Renik Wednesday, August 15, 2012 2:20 PM
    Wednesday, August 15, 2012 2:19 PM