none
KB970892 Sql server will not insall RRS feed

  • Question

  • SQL update will not install KB970892 error code 0x663. Now I can not open any of my programs that need sql. I have been on hold with microsoft on and off for two hours now. ANY HELP
    Thursday, October 15, 2009 4:08 PM

Answers

  • I was having the same problem so I did some digging and found out that if you have any SQL Server related services disabled then it will prevent the update from completing.  That being said, I had SQL Server (EXPRESS) disabled since I also have the full-blown version of SQL Server 2005 installed and it was eating up my memory/resources ... so I disabled it awhile back.  To get this update to go thru without failing I basically pulled up the Services console (ie:  goto Start-Run ... and type in services.msc) and changed the status from "Disabled" to "Manual" and I started the service just to be sure.  Then I reran the update and it went all the way through without any problems.  Afterwards I stopped the services and I'm hoping that by leaving the Status at "Manual" that I want have to stop it and disable it for future updates that could be impacted by this.  If not, I'll just continue to disable it manually because it is a resource hog.

    Hope this helps.
    Friday, October 16, 2009 3:11 PM

All replies

  • there are no error messages on my screen, but the yellow update icon always there. "Security Update for SQL 2005 service pack 3(KB970892) " check box is selected and it is gray. you can install it again and again and again...
    Thursday, October 15, 2009 11:43 PM
  • Same thing here. Running XP x64. SQL Server (Developer Edition) still works, though.
    Friday, October 16, 2009 7:44 AM
  • Same problem here for last 2 days on Vista Business Edition, SP2.

    Tried the obvious - clearing cache, tried with the service running and with it stopped, tried mix of related stuff stopped (e.g. SQL server active directory helper, Server browser etc) but all to no avail.

    We do use a lot of SQL server requests here... but on separate servers anyway (and they're running Linux with MySQL since we outgrew MSSQL on Server 2008) so I suppose the answer is to just disable the service and ignore the update, as most people don't need the server running locally anyway?



    Friday, October 16, 2009 8:37 AM
  • I was having the same problem so I did some digging and found out that if you have any SQL Server related services disabled then it will prevent the update from completing.  That being said, I had SQL Server (EXPRESS) disabled since I also have the full-blown version of SQL Server 2005 installed and it was eating up my memory/resources ... so I disabled it awhile back.  To get this update to go thru without failing I basically pulled up the Services console (ie:  goto Start-Run ... and type in services.msc) and changed the status from "Disabled" to "Manual" and I started the service just to be sure.  Then I reran the update and it went all the way through without any problems.  Afterwards I stopped the services and I'm hoping that by leaving the Status at "Manual" that I want have to stop it and disable it for future updates that could be impacted by this.  If not, I'll just continue to disable it manually because it is a resource hog.

    Hope this helps.
    Friday, October 16, 2009 3:11 PM
  • SQL update will not install KB970892 error code 0x663. Now I can not open any of my programs that need sql. I have been on hold with microsoft on and off for two hours now. ANY HELP

    Just by chance I mentioned this problem in my local pub and was overheard by a silver surfer, who asked me the obvious... "Why don't you just uninstall SQL Server then?".

    I didn't know if it would stop the rest of the system from working (It is Vista Business Edition, and Server 2005 was pre-installed when it came from Dell) or whether the Anti-Virus or Anti-Spyware would be affected... but was so fed up with the KB970892 glitch I thought I'd try... and it worked. Yes, everything works fine after removing SQL Server 2005, and the Microsoft update now go through without problem because it knows not to try to download the fix for server 2005 as I'm not using it.

    Now this isn't the fix for everyone I'm sure, as some people *do* use MSSQL locally... But it's worth a try, and it certainly didn't break my machine!
    • Proposed as answer by TheLinuxGuru Monday, October 19, 2009 7:34 AM
    Sunday, October 18, 2009 4:37 PM
  • Thanks.  I had the same problem as I occasionally need SQL locally but generally don't start the service to save memory. 

    Starting the two services that I have specified as Manual: "SQL Server" and "SQL Server Agent" enabled kb921896 to install. 

    It was not neccessary to change the Startup method, simply starting those two key services was adequate.
    Monday, October 19, 2009 12:58 PM
  • normally I see this quite a bit with SBS 2003, but this is what worked for me

    Under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft
    SQL\Server\MSSQL.1\Setup\Resume, if set to 1, change to 0. Once changed to 0

    This has worked for SQL 2005 SP2 and SQL 2005 SP3 installs....

    • Proposed as answer by Paul Leclerc Tuesday, November 10, 2009 3:44 PM
    Friday, October 23, 2009 7:14 AM
  • Where normally you can find the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft
    SQL\Server\MSSQL.1\Setup\Resume

    As previous recommednations did not work, now I have to go with your recommendation!
    Monday, October 26, 2009 4:59 AM
  • The solution proposed by JiuJtsuMike worked for me.

    You can find what he's talking about in the registery: Start>run> then type: regedit

    Then navigate to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft
    SQL Server\MSSQL.1\Setup\Resume


    Tuesday, November 3, 2009 2:03 PM
  • The solution proposed by JiuJtsuMike also worked for me (registry fix). I tried the other methods (starting other SQL server services, enabling disable SQL Server services) and it did not work.

    BTW: I got this update after installing Visual Studio 2008 SP1 and running Windows Update again.  So, if you're puzzled why you'd get this update when you're not even "using" SQL Server, it's because VS 2008 and VS 2005 installs SQL Server 2005 Express.
    Tuesday, November 10, 2009 3:47 PM
  • This also worked for me. It is amazing how much pain people have to go through with M$ just to get the basic security flaws covered.

    I was banging my head for days on this one.

    Thank you for the research and the posting.
    Friday, November 20, 2009 5:35 AM
  • JiuJitsuMike's solution works

    Reinstalling SQL Server also works but reg edit is easier.
    Monday, November 23, 2009 3:29 PM
  • normally I see this quite a bit with SBS 2003, but this is what worked for me

    Under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft
    SQL\Server\MSSQL.1\Setup\Resume, if set to 1, change to 0. Once changed to 0

    This has worked for SQL 2005 SP2 and SQL 2005 SP3 installs....


    Yes, this works. I have never, ever, trusted myself to do anything with the registry-- the warnings about doom and gloom from a mistake scare the ____ out of a total novice like myself-- who just wants the stupid machine to work, doesn't mess around with settings, etc.

    Having failed to find any other trick that works, tried this one with some trepidation, and the problem is now resolved. Changed a 1 to a 0. For the life of me I have no idea how a person would ever get to the point that they look at a failed update and think.."humm, ya know I bet that value buried 5 levels down in the registry is probably set to 1 and thats causing the issue". Its amazing to me. But it worked. JiuJyutsu Mike, your kung fu is the best!
    Friday, November 27, 2009 7:41 AM
  • Try downloading the update and running the install manually.  I found for me that the problem came from trying to update x86 based versions or SQL server running on an x64 box.  The auto update attempted to update using the x64 version of the update software.  I did a manual update with the x86 version of the update software and it went fine.

    Friday, November 27, 2009 7:45 AM
  • Deleted
    Friday, November 27, 2009 10:58 PM
  • thanks, of all the options listed, for over a month, this is the only one that worked.  thank you.
    Tuesday, December 1, 2009 2:44 PM
  • I tried this solution with the services that were disabled set to manual.  I did not start the services and the install worked.  Thank you.
    Tuesday, December 8, 2009 1:00 PM
  • THANK YOU MIKE!

    This was happening on two of my SBSs.


    Wednesday, December 9, 2009 6:12 AM
  • normally I see this quite a bit with SBS 2003, but this is what worked for me

    Under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft
    SQL\Server\MSSQL.1\Setup\Resume, if set to 1, change to 0. Once changed to 0

    This has worked for SQL 2005 SP2 and SQL 2005 SP3 installs....


    Way to go JiuJitsu. This has been a pain for months!
    Friday, December 11, 2009 6:04 PM
  • I don't understand what you mean can you please explain "so I suppose the answer is to just disable the service and ignore the update, as most people don't need the server running locally anyway?"
    Myself I just want to retrieve data from database into Visual Web Developer. Can I do that without SQL Server?

    Regards TG
    Friday, December 11, 2009 6:18 PM
  • "so I suppose the answer is to just disable the service and ignore the update, as most people don't need the server running locally anyway?"

    > I just want to retrieve data from database into Visual Web Developer.
    Then you're not what I meant by "most people", who simply want to use their computers for surfing, games, the odd letter etc :-)

    > Can I do that without SQL Server?
    Yes. You don't need the SQL Server Service running locally if you have SQL server running on another machine and you've allowed connections to it.

    And no, you don't need to be restricted to Microsoft products. The world is your oyster if you've the time and motivation to look beyond the confined world of Microsoft.

    Before all the Microsoft aficionados start complaining,  I'm not knocking Visual Studio! the way VS2010 allows connections to ASP.net is excellent. Microsoft are even accepting that people outgrow Microsoft SQL Server and need access to faster and better designed SQL servers - hence the interfaces to Ingres, MySQL and Oracle now.
    Monday, December 14, 2009 10:12 AM
  • Thank you!!!
    Wednesday, December 16, 2009 11:30 PM
  • normally I see this quite a bit with SBS 2003, but this is what worked for me

    Under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft
    SQL\Server\MSSQL.1\Setup\Resume, if set to 1, change to 0. Once changed to 0

    This has worked for SQL 2005 SP2 and SQL 2005 SP3 installs....


    I am new to regedit, and have been completely annoyed by this update. I must've "installed" it a hundred times just to get it to go away and it never did - UNTIL NOW!! Thank you JiuJitsuMike!!
    Just to be clear to newbies like me (and correct me if I'm wrong, please), you must click on the Start button, then choose Run, then type regedit in the box, then click OK. Then follow the path above - except on my computer Microsoft SQL Server was all one folder, not Microsoft SQL\Server. Setup is the last folder. Then you have to double-click Resume from the list on the right. A dialog box will open with a 1 highlighted. Type 0. Click OK. Click File at the top of the window, then select Exit. Then install this update ONE LAST TIME. And it finally GOES AWAY!! YAY!!
    Monday, December 28, 2009 10:18 AM
  • normally I see this quite a bit with SBS 2003, but this is what worked for me

    Under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft
    SQL\Server\MSSQL.1\Setup\Resume, if set to 1, change to 0. Once changed to 0

    This has worked for SQL 2005 SP2 and SQL 2005 SP3 installs....

    yep.. worked for me too on windows 7 64bit.. thanks for the solution.
    Thursday, December 31, 2009 12:26 PM
  • JiuJitsuMike, works for me (w2k), thanks. What does resume controll? Does it need to be reset to 1?

    Tuesday, March 23, 2010 6:39 PM
  • JiuJitsuMike, works for me (w2k), thanks. What does resume controll? Does it need to be reset to 1?

    I dunno, never reset to 1 - just never want to have to keep switching to 0 or 1 just to get an update installed.
    Wednesday, March 24, 2010 2:56 AM
  • For me, it happened that the SQL server installation directory was compressed (in the explorer, for instance by the disk space utility of XP). I saw the problem when I tried to install the fix not from the auto update (which is not that much verbose) but by downloading it from the MS web site. After having uncompressed the installation folder, the fix seems to work fine.
    Wednesday, March 24, 2010 10:35 AM
  • normally I see this quite a bit with SBS 2003, but this is what worked for me

    Under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft
    SQL\Server\MSSQL.1\Setup\Resume, if set to 1, change to 0. Once changed to 0

    This has worked for SQL 2005 SP2 and SQL 2005 SP3 installs....


    Thanks! That works for me. I'm not sure why it was set to 1 instead of 0. I don't even have SQL Server installed. I just used Symantec Backup Exec and its SQL Server agent. Anyway, I hope setting it to 0 will not cause other issues.
    Tuesday, March 30, 2010 3:46 PM
  • thanks Mike,

    worked for me.

    Monday, May 3, 2010 11:37 AM
  • This worked for me too. sbsserver2003. Thanks JJM

    Friday, July 16, 2010 1:18 AM
  • Thanks/congrats - your suggestion was close enough to fix it! At the installation at hand (Express Edition SP2 being updated to SP3 on top of Windoze XP Pro SP3) the registry path to the key you described was actually "HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\Setup". Except from that, everything else was entirely bullseye!
    Saturday, July 17, 2010 7:58 PM
  • What does one do when in the registry and the number is already set to 0 not 1?  Nothing else has worked for me re the ideas on this forum so far.
    Thursday, September 30, 2010 6:01 PM
  • OMG! Hey JiuJitsuMike Y O U   A R E   G R E A T!!!!

    Guess what little yellow annoying MS Shield is no longer hanging out in my systray!!!!!

    T.Y.V.M.

     

    :-)

     

    • Proposed as answer by MasMantha Monday, January 31, 2011 6:20 PM
    Friday, October 8, 2010 4:10 PM
  • Amazing thanks JiuJitsuMike
    Monday, January 31, 2011 6:21 PM
  • tried this "regedit" out and it did not work for me until I changed both MSSQL1 and the MSSQL2 'resume' values to 0.

    It has now worked fine! Installed after weeks of annoying attempts.

    In zulu they say "Yebonga Ghukhulu" for Thanks So MUCH.

    Wednesday, February 9, 2011 6:27 PM
  • Worked 1st time, any adverse effects for changing to 0? Thank you.
    Thursday, February 10, 2011 10:11 PM