SQL Server 2008 R2 rebuild master database fails with error -2068643838


  • I want to change the server collation setting for SQL 2008 R2.  I'm using the command:


    The setup program starts, runs a while, then exits with a return code:

    Error result: -2068643838
    Result facility code: 1203
    Result error code: 2

    The final lines of the Detail.txt file in the ...\Setup Bookstrap\Log\<specific timestamp>\ directory are:

    2010-07-12 14:54:58 Slp: Running Action: ProduceStatusLogsBeforeFinishPage
    2010-07-12 14:54:59 Slp: Completed Action: ProduceStatusLogsBeforeFinishPage, returned True
    2010-07-12 14:55:00 Slp: Received request to add the following file to Watson reporting: C:\Users\<MyLoginName>\AppData\Local\Temp\2\tmpDAAF.tmp
    2010-07-12 14:55:00 Slp: The following is an exception stack listing the exceptions in outermost to innermost order
    2010-07-12 14:55:00 Slp: Inner exceptions are being indented
    2010-07-12 14:55:00 Slp:
    2010-07-12 14:55:00 Slp: Exception type: Microsoft.SqlServer.Setup.Chainer.Workflow.NoopWorkflowException
    2010-07-12 14:55:00 Slp:     Message:
    2010-07-12 14:55:00 Slp:         The state of your SQL Server installation was not changed after the setup execution. Please review the summary.txt logs for further details.
    2010-07-12 14:55:01 Slp:
    2010-07-12 14:55:01 Slp: ----------------------------------------------------------------------
    2010-07-12 14:55:01 Slp:
    2010-07-12 14:55:01 Slp: Error result: -2068643838
    2010-07-12 14:55:01 Slp: Result facility code: 1203
    2010-07-12 14:55:01 Slp: Result error code: 2

    The setup program appeared to complete everything, up until it tried to write a file to my account's temporary directory.

    I am performing this command in a Terminal Server/Remote Desktop connection to the server.  My login account is a member of the "MyDomain\Special Account Group" and this group is a member of the local administrators group on the server. I can't think of a reason why this setup should fail.

    Suggestions on resolution to this problem are greatly appreciated.

    • Edited by Wes Winkler Monday, July 12, 2010 11:54 PM minor typos
    Monday, July 12, 2010 11:33 PM

All replies

  • Although I haven’t tested this myself but 2 of the people I know have tried this without success. It looks like a bug in SQL Server 2008 R2.



    Next steps: create a ticket with MSFT and follow-up or rebuild the instance? scary!
    Tuesday, July 13, 2010 12:03 AM
  • If it is on Windows Server 2008 have you tried running it from an elevated Command Prompt with Administrative Priviledges?
    Jonathan Kehayias
    Please click the Mark as Answer button if a post solves your problem!
    Tuesday, July 13, 2010 12:45 AM
  • Yes, I have run this from a Command Prompt with elevated Administrative Privileges.

    The error conditions I describe above were returned from such a Command Prompt.

    Tuesday, July 13, 2010 10:20 PM
  • Hi Wes,

    Have you solved your issue?

    If this issue still exists, I recommend that you have a look at the link provided by Sankar above. Someone has provided a workround. It is recommend that we run setup.exe from the installation Media.

    Could you please have a look at it and have a try?


    Monday, July 19, 2010 1:36 AM
  • I ran into this issue today and beat my head against a wall trying to figure it out.  After about an hour I realized what the problem was.

    I have an x64 OS but am running the x86 version of SQL 2008.  I tried adding the /x86 parameter to the install, but that also failed miserably.  So, I had to change the install directory from C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Release\setup.exe to C:\Program Files (x86)\Microsoft SQL Server\100\Setup Bootstrap\Release\setup.exe AND add the /x86 switch for it to work.  After that, success!

    BOL does not make this very clear, nor did several of the blog posts I found about it.


    Tuesday, August 24, 2010 6:36 PM
  • Hi Kevin,

    Thanks for your post.

    I recommend that you ask it in a new thread then you will receive quicker support.

    Tom Li
    Wednesday, August 25, 2010 1:21 AM
  • I have just confirmed the bug on x64, x86 R2 release of SQL server express 2008. It seems that the express version does not allow to change the collation.
    Tuesday, September 14, 2010 7:43 AM
  • But I dont think its due to that .I have the same issue on ENT x64 cluster .....we tried to rebuild master ...same error .We tried to remove node .....same error ....

    Might open a case today or tomorrow with MS


    Abhay Chaudhary OCP 9i, MCTS/MCITP (SQL Server 2005, 2008, 2005 BI)
    Tuesday, September 14, 2010 8:28 AM
  • Apologies for replying to an old thread.  I, too, am having the same issue as the OP.  Trying to Rebuild master DBs from the cmd line and it fails with:

    Error result: -2068643838

    Result facility code: 1203
    Result error code: 2

    I have seen the official bug at Microsoft Connect and the workaround does not work for me.  I have tried using setup.exe from the Install DVD as well as from the following 2 local directories: C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Release and C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\SQLServer2008R2 and they all fails the same way.

    My syntax is:

    setup.exe /ACTION=REBUILDDATABASE /QUIET /INSTANCENAME="CustomInstanceName" SQLSYSADMINACCOUNTS="domain\administrator" /SQLCOLLATION="SQL_Latin1_General_CP1_CI_AS" /SAPWD="Complexpassw0rd"


    FWIW, the server is at the latest version, SQL2008R2 CU8 (10.50.1797.0) running on Windows 2008 R2 Ent x64


    Any and all help is appreciated!

    Tuesday, June 28, 2011 8:16 PM
    Friday, April 20, 2012 10:02 AM