none
ResultSet property not set correctly?

    Question

  • Using the SSMS Import and Export Wizard, I am trying to export tables from one database into another within the same sql server instance but am getting the error message below. I tried exporting one table; still doesn't work. I copied the wizard generated CREATE TABLE sql statement and ran it in a query in SSMS without incident. I looked up ResultSet property in BOL but there is no entry for it; just ResultSets and ResultSetType. How does one set ResultSet? I have frequently exported to text files without this problem. Can anybody help resolve this?

     

    - Execute the transfer with the TransferProvider. (Error)

    Messages

    ERROR : errorCode=-1073548784 description=Executing the query "" failed with the following error: "Retrieving the COM class factory for component with CLSID {7816B7A3-CD60-4539-BD38-C35AFC61F200} failed due to the following error: 80040153.". Possible failure reasons: Problems with the query, "ResultSet" property not set correctly, parameters not set correctly, or connection not established correctly.
    helpFile= helpContext=0 idofInterfaceWithError={8BDFE893-E9D8-4D23-9739-DA807BCDC2AC}

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&LinkId=20476

    ERROR : errorCode=-1073548784 description=Executing the query "" failed with the following error: "Retrieving the COM class factory for component with CLSID {7816B7A3-CD60-4539-BD38-C35AFC61F200} failed due to the following error: 80040153.". Possible failure reasons: Problems with the query, "ResultSet" property not set correctly, parameters not set correctly, or connection not established correctly.
    helpFile= helpContext=0 idofInterfaceWithError={8BDFE893-E9D8-4D23-9739-DA807BCDC2AC} (Microsoft.SqlServer.DtsTransferProvider)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&LinkId=20476

    Wednesday, April 23, 2008 4:54 PM

Answers

All replies

  • I'm still unable to use Import and Export Wizard in SSMS. Does anybody have any idea what is causing this & how it can be fixed?

    Thursday, April 24, 2008 9:12 PM
  • Hi,

    Refer Karthik's blog on this Karthick's Blog : Failed --Retrieving the COM class factory for ...

    If the above is not working, then you can download Database publishing wizard and make use of it. Refer the below link.Download details: SQL Server Database Publishing Wizard 1.1
    Friday, April 25, 2008 3:55 AM
    Moderator
  • I'm not sure what that link was for: I'm not running on a 64bit machine nor am I using BIDS with this particular issue. I already have Database Publishing Wizard. I'm just trying to export a few tables from one database into another. I am using SELECT INTO statements to get around the problem but that shouldn't be necessary. This is a feature built into SSMS and it is supposed to work.

     

    I'm moving this to the SSIS forum since it is related to import and export; maybe there's a simpler workaround.

    Friday, April 25, 2008 12:27 PM
  • After about two weeks struggling to find an answer to this problem, I finally found someone with the solution. All I had to do was Run:

     

    RegSvr32 SQLTaskConnections.dll

     

    The answer was in this post: http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2970083&SiteID=1

     

    I have posted this solution in each of the forums in which I asked the question; I would like to save others from this agony.

    Monday, May 05, 2008 12:19 PM
  • Dear All,

    I hv configured full backup thru Maintance plan but some time getting below error and some time backup is completed without error.

    Failed:(-1073548784) Executing the query "BACKUP DATABASE [DB] TO  DISK = N'X:\\xyz\\DB.bak' WITH NOFORMAT, INIT,  NAME = N'DB_20100812010004', SKIP, REWIND, NOUNLOAD,  STATS = 10 " failed with the following error: "Cannot open backup device 'X:\\xyz\\DB.bak'. Operating system error 5(Access is denied.).

    BACKUP DATABASE is terminating abnormally.". Possible failure reasons: Problems with the query, "ResultSet" property not set correctly, parameters not set correctly, or connection not established correctly.

     can you advice me why some time backup is failing with above error.

     SQL Server 2005 (Ent Edt) SP3 with latest service pack i  using.


    india
    • Proposed as answer by pankajsriv1 Tuesday, October 01, 2013 4:19 AM
    Friday, August 13, 2010 9:58 AM
  • You are the man

    Thanks you so much for the nice guide.

    Tuesday, March 15, 2011 7:19 AM
  • Amir but where is my answer ???
    india
    Wednesday, March 16, 2011 9:41 AM
  • Sorry dude.I was talking to "rwbta".

    Wednesday, March 16, 2011 12:40 PM
  • You are the Man!!!

    Thanks

    Thursday, February 23, 2012 3:28 PM