none
Error Cannot Acquire Connection From Connection Manager RRS feed

  • Question

  • Hi guys, I am struggling with one package built by one of my colleague. Situation: the package is in the folder newrelease (that's important, it comes later in my explanation), the user John has the rights for that folder. I've created the credential John (with username and password) and I've created the proxy_John with credential John. I set up a sql agent job running at 3.00 pm but it doesn't work (even if I run it automatically from SQL Agent). The problem is the connection manager IPExcel. This excel connection manager is structured in \\Network\Department\Folder\Subfolder

    Error ClassNotRegistered, CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER

    Any thoughts?

    Thanks


    • Edited by DIEGOCTN Thursday, May 21, 2015 3:12 PM
    Thursday, May 21, 2015 3:11 PM

All replies

  • That's the connection that gives problem.

    Thursday, May 21, 2015 3:18 PM
  • I set up a sql agent job running at 3.00 pm

    1) Are able run from package without sql agent ?

    Share error in error log.

    This help you lot.

    http://blogs.msdn.com/b/dataaccesstechnologies/archive/2009/11/10/ssis-error-code-dts-e-oledberror-an-ole-db-error-has-occurred-reasons-and-troubleshooting.aspx


    • Edited by AV111 Thursday, May 21, 2015 3:45 PM
    Thursday, May 21, 2015 3:41 PM
  • I can run without SQL Agent, yes...
    Thursday, May 21, 2015 3:55 PM
  • USe proxy account 

    http://www.mssqltips.com/sqlservertip/2163/running-a-ssis-package-from-sql-server-agent-using-a-proxy-account/

    If any error Let me know.

    Thursday, May 21, 2015 4:19 PM
  • Hi DIEGOCTN,

    Based on your description, you got the error message “CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER” for Excel Connection Manager when executing the package via SQL Agent Job.

    As per my understanding, the most common reason for this error is the lack of a 64 bit driver for the provider used by the connection manager mentioned in the error.

    To fix this issue, we need to execute the package using the 32-bit SSIS runtime. Depending on how you're running it now, the way to do that can change.

    • If you're using SQL Server 2008 and later version, there should be a checkbox on the Job Step page to run the package in 32-bit mode.
    • If you're using SQL Server 2005, you will have to change the Job Step from an Integration Services Step to an Operating System step, and specify a DTEXEC command line instead.  The DTEXEC command line needs to specify the DTEXEC.EXE from the Program Files (x86) folders, NOT the DTEXEC.EXE from the Program Files folders.


    Reference:
    64 bit Considerations for Integration Services

    Thanks,
    Katherine Xiong


    Katherine Xiong
    TechNet Community Support


    Friday, May 22, 2015 2:21 AM
    Moderator
  • Hi Katherine, I am already using "Using 32 bit". My understanding is that there is some problem with the connection string...
    Friday, May 22, 2015 8:10 AM
  • Hi Katherine, I am already using "Using 32 bit". My understanding is that there is some problem with the connection string...
    Could you please post the detail error message for the SQL Agent job? To find out detail error message about the job, please refer to the following steps:

    1. Right-click the SQL Server Agent job in Object Explorer and then click View History.
    2. Locate the job execution in the Log file summary box, view the details of the message for the job step.

    Thanks,
    Katherine Xiong


    Katherine Xiong
    TechNet Community Support

    Friday, May 22, 2015 8:55 AM
    Moderator