Trouble installing SQL Server ODBC driver - not found


  • I'm trying to install a SQL Server ODBC driver on Linux so that I can communicate with an SQL Server 2005 database.  Since it's a 2005 database server, I believe I can't use the latest driver which says it is for 2008 and above.  So I'm trying to install the file called sqlncli-11.0.1790.0.tar.gz.  After installing unixODBC, I tried installing the SQL driver, but the install failed.  Running ldd sqlncli-11.0.1790.0 shows that could not be found.  I read here ( ) that the linked libraries exist in /usr/local/lib rather than /usr/lib64, so I created a symbolic link with this command:  sudo ln -s /usr/local/lib/ /usr/lib64/
     Now running ldd shows it linked to the existing library: => /usr/lib64/ (0x00007f7d3427a000)

    However, when I try to install the SQL driver again, it still fails saying that I don't have the right version of unixODBC installed (I installed the latest version from the site).

    Please let me know if you have any suggestions - or if I should use another vendor's driver or a different ODBC driver manager.

    Thursday, May 02, 2013 3:21 PM

All replies

  • Hello,

    Even if I am not using Linux and the Microsoft SQL Server ODBC driver, I have done some searches. I am providing you some potentially useful links

    You will find :

    "The Microsoft ODBC Driver 11 for SQL Server provides robust data access to Microsoft SQL Server. It allows native C and C++ applications to leverage the standard ODBC API and connect to Microsoft SQL Server 2008, 2008 R2,  SQL Server 2012 and Windows Azure SQL Database"  ( nothing related to SQL Server 2005 )

    Another excerpt ( maybe useful ) :

    "Installation puts the driver in /opt/microsoft/msodbcsql/11.0.2270.0. The driver and its support files must be in /opt/microsoft/msodbcsql/11.0.2270.0.

    To verify that the ODBC Driver on Linux was registered successfully, execute the following command: odbcinst -q -d -n "ODBC Driver 11 for SQL Server" ".

    I would suggest you to verify whether the driver is correctly installed according the last excerpt.

    Another possible useful link :

    You have not told us whether you need a driver for RedHat or Suse. Please, could you tell us whch edition you need ?

    For Suse :

    We need also to know whether your driver is for 32-bit or 64-bit  

    Last link :

    For a possibility compatibility problem , I would suggest you to have a look at

    and especially the comments at the end of the article

    " It was not tested against SQL Server 2008 or SQL Server 2005.  So, this is not a supported scenario, at this time.  You may find, however, that you can connect to a SQL Server 2005 database using the Microsoft SQL Server ODBC Driver for Linux" replied by DavidDmsVcp ( I think that the poster is fully reliable according the quality and easiness to be understood by myself of his article(s) )

    I wrote before that Linux and ODBC drivers were little known for me. I have posted only to start this thread and because I thought that some important pieces of information were missing in your question ( I am doing no reproach as I know it is always difficult to provide the full information necessary to understand and to solve a problem ).

    Don't hesitate to post again for more help or explanations.

    Have a nice day.

    PS : As you are using SQL Server 2005, I would suggest to have a look at this link

    SQL Server 2005 SP4 is no longer supported since 2012 ( the extended support is available but not free ).You should investigate the upgrade towards SQL Server 2008 R2 or 2012 ( these both versions are compatible with the last version of the Microsoft Linux ODBC Driver and I think it would make easier to solve your current problem )

    Mark Post as helpful if it provides any help.Otherwise,leave it as it is.

    Thursday, May 02, 2013 5:22 PM
  • Thank you for the reply, Papy.  Earlier I had tried installed an older version of Microsoft's ODBC driver that said it was compatible with SQL Server 2005 - that file was sqlncli-11.0.1790.0.tar.gz.  I have now tried installing the one on this page - - for Red Hat 6 - 64 bit.  It seemed to install the driver manager properly, but when I try to install the SQL Server driver, I am still getting the same type of error:

    $ ./ verify
    Microsoft ODBC Driver 11 for SQL Server Installation Script
    Copyright Microsoft Corp.
    Starting install for Microsoft ODBC Driver 11 for SQL Server

    Checking for 64 bit Linux compatible OS ..................................... OK
    Checking required libs are installed ........................................ OK
    unixODBC utilities (odbc_config and odbcinst) installed ..................... OK
    unixODBC Driver Manager version 2.3.0 installed ......................... FAILED
    unixODBC Driver Manager configuration correct ...................... NOT CHECKED
    Microsoft ODBC Driver 11 for SQL Server already installed .......... NOT CHECKED

    Please let me know if anyone has a suggestion of how to get around the unixODBC Driver manager version issue.  I had just installed the version packaged in this driver.

    Monday, May 06, 2013 4:54 PM
  • Easysoft's ODBC driver for SQL Server supports SQL Server 7 to 2012. You can get details from the Easysoft Web Site
    Tuesday, May 07, 2013 8:57 AM
  • I hate to spend 950 pounds for an odbc driver if I don't have to.
    Tuesday, May 07, 2013 1:59 PM