Phantom tables in SSAS cube data source view RRS feed

  • Question

  • I'm trying to create an SSAS multi-dimensional cube using Visual Studio 2015 with SSDT 17.3.

    What's happening is that the Data Source View in the cube designer is showing several "empty" phantom tables, while the actual tables I'm using from my DSV are not showing any of the relationships between them. As well, these phantom tables appear to be repeating copies of an existing table, as if I mouse over them, it shows the name of another table.

    If I try to use the "Copy Diagram From" function, Visual Studio crashes on me.

    This doesn't seem to have any effect on the functionality of the cube, as I can deploy is to a 2012 SSAS instance and it works as expected.

    Has anyone else seen something like this, and know how to correct it?

    Tuesday, November 28, 2017 5:52 PM

All replies

  • I have got exactly the same problem. Anyone knows a solution ?
    Sunday, December 17, 2017 12:50 PM
  • Haven't been able to find a solution for this. But it seems to crop up when I'm using a combination of direct tables and views, as well as not having fully fleshed out foreign key relationships.

    Monday, January 15, 2018 2:32 PM
  • Same bug in Visual Studio 2017 with SSDT 15.5.2

    Wednesday, February 28, 2018 11:08 AM
  • Unfortunately same in VS 2015 regarding "my" cube.

    Easy to reproduce, just drop some tables from cube also from dsv, and you'll see the magic. :(
    Monday, March 12, 2018 3:53 PM
  • Thanks guys, nice to know I'm not the only one seeing it.

    Seems to be happening with all the cubes that I'm working with these days.

    Tuesday, March 20, 2018 2:48 PM
  • Same for me with SSDT 14.0.61712.050
    Wednesday, March 28, 2018 9:27 AM
  • Hi, i have the same issue. 

    Can someone from Microsoft AS support team provide some support please? 

    Many thanks

    Sunday, April 1, 2018 11:33 PM
  • same on ssdt 15.5.2 "cube structure", additionally the same fact table is displayed multiple times.
    Thursday, April 5, 2018 10:08 AM
  • I have this exact same issue, I try and re-import the diagram using "copy diagram from"  Visual studio crashes and goes into Debug mode, it will do this even when creating a cube from scratch.  I'm using VS 2015 with latest SSDT 17.4...unbelievable.  Anybody found a way around this?

    Friday, April 20, 2018 6:10 AM
  • Still having the issue. Found a new spot as well: Was working with a dimension today, changing it from one table to a different view, and the Data Source View in the dimension editor started showing duplicate tables when I selected the option to "Show Only Used Tables". Using the Copy Diagram From option crashed Visual Studio.

    Re-opening the dimension after the crash, the duplicates are now empty outlines, and I can't hide them.

    This is really getting annoying, particularly that there hasn't been a response from MS even acknowledging it.

    I've created an idea/bug on MS's new Azure Feedback site. All I can suggest at this point is people go there and up-vote it so it gets noticed.

    • Edited by emorgoch Tuesday, July 17, 2018 9:08 PM
    Tuesday, July 17, 2018 9:08 PM
  • Looking at the raw XML view in my cube, it looks like all the empty tables are a result of the multiple copies extra <ddscontrol> objects being added.

    An example of the full control that's an empty one is: 

    <ddscontrol controlprogid="DdsShapes.DdsObjectManagedBridge.3" tooltip="MyTable" left="-83279" top="-15143" logicalid="230" controlid="1" masterid="0" hint1="0" hint2="0" width="6376" height="5000" noresize="0" nomove="0" nodefaultattachpoints="0" autodrag="1" usedefaultiddshape="1" selectable="1" showselectionhandles="1" allownudging="1" isannotation="0" dontautolayout="0" groupcollapsed="0" tabstop="1" visible="1" snaptogrid="0">
        <ddsxmlobjectstreaminitwrapper binary="000c0000e818000088130000" />
        <ddsxmlobj />
      <shape groupshapeid="0" groupnode="0" />

    The difference between these vs. a "real" one is that the <ddsxmlobj> tag is fully flushed out. ie.:

      <property name="LogicalObject" value="dbo_factOE" vartype="8" />

    In my one dimension, I was able to "fix" it by manually removing all the trouble <ddscontrol> objects. However, trying to do the same in my cube caused it to crash. Presumably because there were also relationship lines in the cube that were pointing to those empty tables that were removed, rather than pointing to the real tables.

    Tuesday, July 24, 2018 3:53 PM
  • It is quite big mistake. I found out that duplicate fact table in cube data source view is created always when you add new measure from the same fact table. So as many measures you add from the same table as many duplicate tables you will get. After you save and close cube designer you will get only blank frame with the same fact table name. The only way how to make correct visual cube desing is to use cube wizard but once you need to add anything to this layout you have no chance to make it correct. I wonder that nobody fixed this bug since 2015. It is the same with SSDT 2015.
    Wednesday, July 25, 2018 6:05 PM
  • I have the same issue, VS 2015 with SSDT

    did someone find a solution?

    Monday, September 24, 2018 8:49 AM
  • I can confirm this. Right click -> New Measure from Column creates a shadow table in the cube designer DSV.
    Thursday, November 15, 2018 2:41 PM
  • You all only look at the visual aspect of this issue, but there is a more profound problem that underlies this issue.

    All phantom tables cause your aggregations to double, triple, etc. In my case I had hundreds of phantom tables after adding new fact groups, and after an auto layout. A cube partition that used to have a processing time of 30 seconds for 138MB on disk, went to processing for 2 hours, and resulted in 11GB of data.

    I cleaned the project visuals as I found the XML duplicates in the layout section, but that doesn't help. On the 3 projects that this has happened, the only solution I found was to rebuild the entire cube project.

    It is definately caused by the VS2017 SSDT. Also the new update for VS2015 SSDT has this issue, but in less places. My only installation that is stable to build cubes at the moment is VS2015 with the oldest SSDT plugin currently available : SSDT for VS2015 16.5

    This needs to be fixed ASAP, because anyone saving to the solution with an affected VS, then plants the problem in the project, and even version 16.5 cannot get it out anymore. As I said: it has cost me 3 full rebuilds of the entire cube project....we're talking weeks of development here, just because of Microsoft being very sloppy in their SSDT development. 

    I wonder if they even test a full cube build with aggregations? It should be obvious as it completely cripples processing and query performance.
    Monday, November 26, 2018 11:43 AM
  • I faced the same issue with my Cube project. Resolved the issue by manually modifying the Cube Definition XML file.

    <Measure dwd:design-time-name="##GUID1##">
        <Source dwd:design-time-name="##GUID2##">
            <Source xsi:type="ColumnBinding" dwd:design-time-name="##GUID3##">

    ** ##FIELD## = Measure Name = Column Name

    ** ##GUID1##, ##GUID2##, ##GUID3## = Generated new GUID by query "SELECT NEWID()"

    Then Place the Generate Output to Correct Measure Group Before </Measures> tag

    <MeasureGroup dwd:design-time-name="4cad1a22-37a5-4bae-a124-11071553a759">
    Existing Measures
    Add Generated Output here

    Wednesday, January 23, 2019 8:56 PM
  • I'm facing the same issue. Has anyone known the solution ?? ... Could someone from Microsoft SSAS support team provide information ??     tks a lot.
    Wednesday, January 30, 2019 11:45 AM
  • I have solved this issue by editing manually the .cube file:

    Remove all the <Annotation> entries at the beginning of file. Leave empty the <Annotations><Annotations/> entry.


    <Cube xmlns:xsd="" xmlns:xsi="http://... <ID>XXXXXXXXXXXXX</ID> <Name>XXXXXXXXXXXXX</Name> <CreatedTimestamp>0001-01-01T00:00:00Z</CreatedTimestamp> <LastSchemaUpdate>0001-01-01T00:00:00Z</LastSchemaUpdate> <Annotations> </Annotations> <LastProcessed>0001-01-01T00:00:00Z</LastProcessed> <State>Unprocessed</State> <Dimensions> <Dimension dwd:design-time-name="XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX"> <ID>XXXXXXXXXXXX</ID> <Name>XXXXXXXXXXXX</Name>


    Open the cube inside Visual Studio and everything will be all right again!

    Wednesday, February 6, 2019 9:48 AM
  • this solution has worked very well up to now.  thanks a lot
    Friday, February 8, 2019 10:19 AM
  • Toni,

    Thank you very much! It worked nicely!!!!

    Wednesday, February 20, 2019 5:30 PM
  • Solution of removing the Annotations worked! No more phantom tables TNX!
    Tuesday, February 26, 2019 4:07 PM
  • Thanks! I did the same thing you did, i think. I removed the Value under the Diagram Layout annotation.  I first tried removing all annotations and it gave me an error, asking for the name property.  So, I left all annotations except for the value field under the first annotation and it reset the diagram!
    Monday, March 11, 2019 9:08 AM
  • Hi for all.

    Anyone found a solution? What VS version you are working?

    I try to remove the annotation values, but the same error happens, appear a phantom tables in diagram when I set show all tables or used tables.

    Exist some stable version?

    Thiago Faria

    Monday, March 18, 2019 2:20 PM
  • Thank you so much, It works properly
    Thursday, April 11, 2019 8:41 PM
  • Thanks Toni,

    I did the same thing as you, and it seems to have caused the display to work properly now. I haven't been able to confirm what DSMulders said about this causing the aggregations to duplicate and increasing the cube size. I haven't noticed it in my environment.

    I don't consider this a solution (this is obviously a large bug in the designer and MS should work to resolve it there), but this is a decent work around to at least fix up the display.

    Friday, April 12, 2019 3:53 PM
  • This worked very well for me as well. After deleting all annotations I rearranged the cube diagram and the annotations were created without duplication or phantom boxes. Thanks a lot. A very annoying bug. 
    Monday, August 5, 2019 9:49 PM
  • Hi Toni, thanks to your solution, you saved my life. God bless you :-) 

    So stupid error but Microsoft did not care since 2015...

    Filip Sirucek 

    Sunday, September 15, 2019 6:11 PM