none
Missing URL parameter: IterationId RRS feed

  • Question

  • Error:  Missing URL parameter: IterationId

     

    I get this error when I add a footer to my report.  Is there a fix?

     

    Report viewer 2010

    Visual Studio 2008 sp 1

    .Net 3.5

    Browser = firefox, have not tried ie.

    IIS = whatever ships with Windows 7 prof.

     

    Thanks,

    Sam

    Sunday, August 22, 2010 12:30 AM

All replies

  • Hi Sam,

    This issue has been reported at microsoft connection, open https://connect.microsoft.com/VisualStudio/feedback/details/556989/?wa=wsignin1.0 for reading some its discussions. Finally, give it a try by installing the latest cu, for example you are running SSRS 2008 R2, the latest cu package is at http://support.microsoft.com/kb/2120979/ .

    thanks,
    Jerry

    Tuesday, August 24, 2010 8:01 AM
    Moderator
  • Thank you Jerry,  we are running SQL Server 2008, but not R2.  I search for an update and found none.  Is there a workaround in the meantime?

     

    Thanks,

     

    Sam Wheat

     

    Tuesday, August 24, 2010 4:21 PM
  • Hi, I Was with the same issue. and I could fiz that by resolving a paramether name.

    Take a look at your dataset properties and your query result. Need to be the same names.

    tks


    Caio Vitullo

    Tuesday, March 6, 2012 4:32 AM
  • (Apologies for bumping this old, old thread; it was the first hit in Google when searching for this problem myself, so I thought I'd post how I resolved my issue in case others stumble upon it.)

    Are you sure this is just from adding a footer?  I was getting this error message myself, and it was due to the Line control.  For whatever reason, the Line control tries to include a standard blank image right after it, but the URL is missing that parameter in FireFox and Chrome (but not IE, as far as I can tell). When I remove all the Line controls, the error goes away.  Make sure you don't have any Lines in your footer (or anywhere else on your report, for that matter.)

    Wednesday, December 12, 2012 6:38 PM
  • God Bless you!

    Bump away.

    This was a crazy problem. I can't believe it was the line control. This report is in SSRS and loads in a viewer control on an ASP page. It had always worked until we made a slight change and then we experienced this issue. I would have never thought that it was the line control.

    Thank you so much!

    Wednesday, October 22, 2014 5:52 PM
  • Thanks - this saved me a great deal of time!
    Thursday, January 29, 2015 10:09 AM
  • I had the same issue. The solution was to add the site to Internet Explorer's Compatibility View site list. Then the page renders without issue.
    Monday, November 2, 2015 10:22 PM
  • What's sad is that almost a year later, running SQL 2012, SP3 this is still a problem.  Compatibility View is not an option for me.  I have top tier clients that log in to our system and view reports.  Everything we do must run 100% out of the box, first time, every time in ANY browser.  I went in and removed lines from the footers in the 7 reports that were giving trouble and viola! Worked like a charm.  Thanks Tukaro.
    Monday, September 12, 2016 7:52 PM