none
SQL Server broken - cannot reset 'logon as ' built-in account - urgent

    Question

  •  

    SQL Server Express 2008, on a standalone XP Pro fully updated, with a named instance of COMPUTERNAME\SQLEXPRESS.

    As installed, the 'log on as' was set to NT\NETWORK SERVICE. Basically things worked, though I had some issues, now irrelevant. Foolishly I went into SQL Server Configuration Manager, clicked on SQL Server Services, in the right pane right-clicked on Sql Server (SQLEXPRESS) - Properties, on the logon tab - Built-in account, which showed Network Service.

     

    From the dropdown, I selected Local Service and probably Apply, then Start, though maybe vice versa.

     

    This stopped pretty much everything working, e.g. no access via Managment Studio etc (cannot login). Now if I attempt to select Network Service from the dropdown to put it back to what it was:

    - If I click Apply I get a message box : Cannot find object or property [0x80092004]

    - If I click Start there is a long wait while the progress bar ticks over, then a message box with 'The request failed or the service did not respond in a timely fashion. Consult the event log or other applicable error logs for details'

     

    In the logs folder the log starts with informational stuff that looks to me to be pretty standard, then the first entry that indicates problems, and the subsequent entries :

     

    2008-11-25 13:27:36.45 Server      Error: 17190, Severity: 16, State: 1.
    2008-11-25 13:27:36.45 Server      FallBack certificate initialization failed with error code: 1.
    2008-11-25 13:27:36.45 Server      Unable to initialize SSL encryption because a valid certificate could not be found, and it is not possible to create a self-signed certificate.
    2008-11-25 13:27:36.45 Server      Error: 17182, Severity: 16, State: 1.
    2008-11-25 13:27:36.45 Server      TDSSNIClient initialization failed with error 0x80092004, status code 0x80. Reason: Unable to initialize SSL support. Cannot find object or property.

    2008-11-25 13:27:36.45 Server      Error: 17182, Severity: 16, State: 1.
    2008-11-25 13:27:36.45 Server      TDSSNIClient initialization failed with error 0x80092004, status code 0x1. Reason: Initialization failed with an infrastructure error. Check for previous errors. Cannot find object or property.

    2008-11-25 13:27:36.45 Server      Error: 17826, Severity: 18, State: 3.
    2008-11-25 13:27:36.45 Server      Could not start the network library because of an internal error in the network library. To determine the cause, review the errors immediately preceding this one in the error log.
    2008-11-25 13:27:36.45 Server      Error: 17120, Severity: 16, State: 1.
    2008-11-25 13:27:36.45 Server      SQL Server could not spawn FRunCM thread. Check the SQL Server error log and the Windows event logs for information about possible related problems.

    Tuesday, November 25, 2008 1:37 PM

All replies

  • That wasn't foolish - it's actually the correct place to change the SQL Server service account.

     

    Have you tried setting it to a domain user account?  The reason why you're supposed to use SQL Server Configuration Manager to change the service account is because SQL Server uses the credentials for that service account to maintain a certificate for code-signing (to ensure that it's code modules aren't tampered with).  You can try setting the account via services.msc, but I don't think that this will work.  It sounds like ForceEncryption might be on for each of your protocols - is this the case?  If so, you might try turning ForceEncryption off for now.  I'm not entirely sure what's preventing the certificate from being generated.

     

    Let me know if this helps.

     

    Tuesday, November 25, 2008 2:41 PM
    Moderator
  • Anynick,

     

    Any luck?

     

    Monday, December 1, 2008 5:56 AM
    Moderator
  • Hi,
    I am having the same problem here. My server was running OK after installation. I have tried to change the protocol settings and login account now I can not even start my server. I am getting "can not find object or property [0X2009xxxx]. I was having issue connecting to server from Visual Studio 2008.

    Can anybody help me with this please?

    Regards,

    Liton
    Monday, March 9, 2009 5:29 AM
  • I am also having the same issue, did anyone get a answer?
    Friday, March 13, 2009 2:34 AM
  • I was encountering this same issue (WMI provider Error cannot find object or property 0x80092004) when trying to change the SQL Server Account using SQL Server Configuration Manager.

    The following resolved it for me

    Configure SQL Service back to the original account it was using (Local System in my case)
    Expand SQL Server Network Configuration
    Right Click Protocols for MSSQLSERVER and select Properties
    Change Force Encryption to no
    Select Certificate Tab
    Click Clear
    Click Ok
    Restart the SQL Server

    I was then able to change the SQL Service Account

    • Proposed as answer by djboge Tuesday, December 18, 2012 12:39 AM
    Thursday, April 9, 2009 7:12 PM
  • This worked for me:

     

    Start>All Programs>Administrative Tools>Services

    Scroll down to SQLServer.exe and Right Click>Properties

    Stop service if running.

    Go to "LogOn" tab and click "Local System Account" Radio button

    Click Apply

    Restart Service if necessary.

    • Proposed as answer by bmw325ist Wednesday, June 30, 2010 11:04 PM
    Wednesday, June 30, 2010 11:04 PM
  • This solution also worked perfectly for me
    Monday, September 20, 2010 5:30 PM
  • This solution worked for me

     

    Thanks

    Tuesday, November 2, 2010 6:24 PM
  • thanks its work
    Thursday, December 2, 2010 5:23 PM
  • Nick & All,

    You did the right thing when you changed the service account from  SQL Server Configuration Manager. For others who are using services.msc, please don't as a service change for SQL does not set ACL's for the new account and does not add it to the security group. SSCM is the right place!


    As far the messages you posted, these are specific to security permissions & Local Profiles. You mentioned that during the install you ran into issues. Did you by any chance have the issue of SQL not being able to start during setup with the following entry in the ERRORLOG

    Error: 15209, Severity: 16, State: 1.
    An error occurred during encryption.

    For this issue, apart from changing the service account to LocalSystem (which I consider to be a workaround, not a solution), here are some other things to do:

    1. Ensure there is no file with the name Microsoft, present in C:\WINDOWS\system32 location. If so, delete the FILE.
    2. If this is happening for a Domain User, then most likely it is either of the two:-

    a. Local Profile does not exist for the new service account. In which case, login to the server using the new account, this will create the profile.
    b. User Profile could be corrupted. Use this KB http://support.microsoft.com/kb/816593/en-us to fix it.
     

    In general, have a look at this post of mine to see if this issue is the same as yours,

    SQL Server service does not start after enabling SSL encryption
    http://thesqldude.wordpress.com/2011/08/03/sql-server-service-does-not-start-after-enabling-ssl-encryption/


    For any other SQL service startup issues, have a look at,

    Guide to Troubleshooting SQL Server Service startup issues
    http://thesqldude.wordpress.com/2011/08/09/guide-to-troubleshooting-sql-server-service-startup-issues/


    Patience is a Virtue... So is "Delayed IO" :)
    • Proposed as answer by Arun_Kumar Tuesday, February 26, 2013 5:05 PM
    Thursday, August 11, 2011 5:09 PM
  • HI RDCF, this did not work for me. any workaround? 

    PS: as per MS it is not advisable to change the log on service in services.msc (Should always use SQL Server Configuration Manager)


    stazera
    Thursday, December 8, 2011 5:27 PM
  • This solution works like a magic. Thanks!!!
    Monday, January 30, 2012 8:13 AM