none
Arithabort settings RRS feed

  • Question

  • Hi,

    A user came to me with a query that was running slower through ODBC than if he ran it in SSMS.

    Initially I looked at the execution plan and changed a couple of joins to inner loop join, to remove the problem.

    However I believe that the root of the problem is the Arithabort setting, and I'm a little confused about how exactly this is set. I recommended to the developer to set arithabort on , at the beginning of the stored procedure.

    Since then I've been looking at the settings on the server & databases and I can see that in the server properties under connections none of the settings I would expect is ticked including Arithmetic abort. Also at the database level Arithmetic abort is not enabled.

    Initially I thought that with a SQL 2008 R2 server and all databases at compatibility level 100, they would automatically have the Arithabort feature set to "ON".

    My question is basicically should I change these settings, should I set the server property to set arithmetic abort on for all connections, will this work for ODBC? Is it advisable to make this chage ? Should I set this seting on at the database level, what are the potential downsides and will it make any difference ?


    Sean

    Wednesday, March 6, 2013 12:08 PM

Answers

All replies