Manual removal of SQL Express 2008 - usual uninstall routine does not work


  • Hi, folks

    I have been using Arcserve V12 on a Windows 2008 storage server. Arcserve used SQL Express 2005.

    Last week I upgraded Arcserve to V16 and during the installation it tried to upgrade SQL 2005 Express to SQL 2008 Express but it failed.

    I have been working with Arcserve Support to fix this but we have been going round in circles. Using the domain administrator account initially failed because it did not have the neccessary permissions, but we fixed this. I have also tried uninstalling using the server's local administrator account but we get the same results:

    We got to a state were using the Uninstall/Change option from within Programs and Features would successfully report that SQL Server Express has been successfully removed: 'Your SQL Server 2008 removal completed successfully'. However, all the entries are still present in the Programs list:

    Microsoft SQL Server 2008
    Microsoft SQL Server 2008 Browser
    Microsoft SQL Server 2008 Native Client
    Microsoft SQL Server 2008 Setup Support Files
    Microsoft SQL Server Native Client
    Microsoft SQL Server VSS Writer

    And, all the folders are still present off Program Files:

    C:\Program Files (x86)\Microsoft SQL Server>dir
     Volume in drive C is OS
     Volume Serial Number is 1252-E50F

     Directory of c:\Program Files (x86)\Microsoft SQL Server

    15/03/2013  14:49    <DIR>          .
    15/03/2013  14:49    <DIR>          ..
    09/03/2013  08:17    <DIR>          100
    09/03/2013  08:18    <DIR>          80
    09/03/2013  12:17    <DIR>          90
    04/05/2010  13:37    <DIR>          MSSQL.1
    09/03/2013  08:18    <DIR>          MSSQL10.ARCSERVE_DB

    The services window shows the following:

    Attempting to start a service results in an error message stating the file cannot be found.

    I have now uninstalled Arcserve and would like to completely remove SQL Server Express 2008 and start again. Can someone assist me with this please?

    I am a complete noob when it comes to SQL Server and have never needed to install or uninstall it on it's own before. If you need further information please ask.



    Friday, March 15, 2013 3:35 PM

All replies

  • Hello,

    Please try the following:

    If the  above does not work, please try instructions provided by YoYo Yu on the following thread:

    Hope this helps.


    Alberto Morillo

    Friday, March 15, 2013 5:15 PM
  • Thank you, I appreciate your response but as I said in my original post the usual routine does not work.

    Also - there are several accepted solutions in your second link (which I have also seen previously), so which one should I follow?


    Friday, March 15, 2013 5:50 PM
  • Hello,

    Use the solution posted by YoYo Yu on August 23, 2010 8:51 AM.

    Hope this helps.


    Alberto Morillo

    Friday, March 15, 2013 6:02 PM
  • Thank you, Alberto.

    The problem is that the first instruction says:

    To work around this issue, we suggest you to re-install SQL Server Express, and you can try the following steps:

        1. Uninstall the existing SQL Server 2008 R2 Express and all the components from the control panel.

    I cannot do this because, as stated above, although the uninstaller says says it has succeeded, all the SQL entries remain in the Programs list and all the files/folders are still in ..\Program Files. Also, running the SQL Express installer from the Arcserve installation setup file continually fails.

    Are you saying I should download a copy of SQL Express and try to install it, then try to uninstall it again from the Programs and Features window in Control Panel?

    Full information about the problems I have been having are available in Arcserve's forum here


    • Edited by Mark-Blood Saturday, March 16, 2013 7:34 AM
    Saturday, March 16, 2013 7:33 AM
  • Hello,

    Please continue with the other steps.

    Hope this helps.


    Alberto Morillo

    Sunday, March 17, 2013 3:29 AM
  • Hi, Alberto

    I followed the instructions in that post as far as I was able. I removed the registry keys and I renamed the SQL folders on the server. Because Arcserve tries to upgrade the installation to SQL Express 2008 SP1 I downloaded SQL Express 2008 SP1 and ran through the installation procedure for that. However, exactly the same error message was displayed during the installation that I saw when the Arcserve installer tried to upgrade to Express SP1. Here's the text:


    Overall summary:
      Final result:                  SQL Server installation failed. To continue, investigate the reason for the failure, correct the problem, uninstall SQL Server, and then rerun SQL Server Setup.
      Exit code (Decimal):           -2068643839
      Exit facility code:            1203
      Exit error code:               1
      Exit message:                  SQL Server installation failed. To continue, investigate the reason for the failure, correct the problem, uninstall SQL Server, and then rerun SQL Server Setup.
      Start time:                    2013-03-19 18:55:18
      End time:                      2013-03-19 19:17:33
      Requested action:              Install
      Log with failure:              C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20130319_185351\Detail.txt
      Exception help link: 

    Machine Properties:
      Machine name:                  ORION
      Machine processor count:       8
      OS version:                    Windows Server 2008
      OS service pack:               Service Pack 2
      OS region:                     United Kingdom
      OS language:                   English (United States)
      OS architecture:               x64
      Process architecture:          64 Bit
      OS clustered:                  No

    Product features discovered:
      Product              Instance             Instance ID                    Feature                                  Language             Edition              Version         Clustered
      Sql Server 2008      ARCSERVE_DB.INACTIVE MSSQL10.ARCSERVE_DB            Database Engine Services                 1033                 Express Edition      10.1.2531.0     No       
      Sql Server 2008      ARCSERVE_DB.INACTIVE MSSQL10.ARCSERVE_DB            SQL Server Replication                   1033                 Express Edition      10.1.2531.0     No       

    Package properties:
      Description:                   SQL Server Database Services 2008
      SQLProductFamilyCode:          {628F8F38-600E-493D-9946-F4178F20A8A9}
      ProductName:                   SQL2008
      Type:                          RTM
      Version:                       10
      Installation location:         d:\ce106b497658372f36ac0de7eb6614\x64\setup\
      Installation edition:          EXPRESS

      Slipstream:                    True
      SP Level                       1

    User Input Settings:
      ACTION:                        Install
      AGTSVCPASSWORD:                *****
      AGTSVCSTARTUPTYPE:             Disabled
      ASBACKUPDIR:                   Backup
      ASCOLLATION:                   Latin1_General_CI_AS
      ASCONFIGDIR:                   Config
      ASDATADIR:                     Data
      ASDOMAINGROUP:                 <empty>
      ASLOGDIR:                      Log
      ASPROVIDERMSOLAP:              1
      ASSVCACCOUNT:                  <empty>
      ASSVCPASSWORD:                 *****
      ASSVCSTARTUPTYPE:              Automatic
      ASSYSADMINACCOUNTS:            <empty>
      ASTEMPDIR:                     Temp
      BROWSERSVCSTARTUPTYPE:         Automatic
      CONFIGURATIONFILE:             C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20130319_185351\ConfigurationFile.ini
      ENABLERANU:                    True
      ERRORREPORTING:                True
      FEATURES:                      SQLENGINE,REPLICATION
      FILESTREAMLEVEL:               0
      FILESTREAMSHARENAME:           <empty>
      FTSVCACCOUNT:                  <empty>
      FTSVCPASSWORD:                 *****
      HELP:                          False
      INDICATEPROGRESS:              False
      INSTALLSHAREDDIR:              C:\Program Files\Microsoft SQL Server\
      INSTALLSHAREDWOWDIR:           C:\Program Files (x86)\Microsoft SQL Server\
      INSTALLSQLDATADIR:             <empty>
      INSTANCEDIR:                   C:\Program Files\Microsoft SQL Server\
      INSTANCEID:                    SQLExpress
      INSTANCENAME:                  SQLEXPRESS
      ISSVCACCOUNT:                  NT AUTHORITY\NetworkService
      ISSVCPASSWORD:                 *****
      ISSVCSTARTUPTYPE:              Automatic
      NPENABLED:                     0
      PCUSOURCE:                     d:\ce106b497658372f36ac0de7eb6614\PCUSOURCE
      PID:                           *****
      QUIET:                         False
      QUIETSIMPLE:                   False
      RSINSTALLMODE:                 FilesOnlyMode
      RSSVCACCOUNT:                  <empty>
      RSSVCPASSWORD:                 *****
      RSSVCSTARTUPTYPE:              Automatic
      SAPWD:                         *****
      SECURITYMODE:                  <empty>
      SQLBACKUPDIR:                  <empty>
      SQLCOLLATION:                  Latin1_General_CI_AS
      SQLSVCACCOUNT:                 htlincs\administrator
      SQLSVCPASSWORD:                *****
      SQLSVCSTARTUPTYPE:             Automatic
      SQLSYSADMINACCOUNTS:           HTLINCS\administrator
      SQLTEMPDBDIR:                  <empty>
      SQLTEMPDBLOGDIR:               <empty>
      SQLUSERDBDIR:                  <empty>
      SQLUSERDBLOGDIR:               <empty>
      SQMREPORTING:                  True
      TCPENABLED:                    0
      X86:                           False

      Configuration file:            C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20130319_185351\ConfigurationFile.ini

    Detailed results:
      Feature:                       Database Engine Services
      Status:                        Failed: see logs for details
      MSI status:                    Passed
      Configuration status:          Passed

      Feature:                       SQL Server Replication
      Status:                        Failed: see logs for details
      MSI status:                    Passed
      Configuration status:          Passed

    Rules with failures:

    Global rules:

    Scenario specific rules:

    Rules report file:               C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20130319_185351\SystemConfigurationCheck_Report.htm


    Do you have any suggestions on how I might get around this, please?

    I am not worried about keeping the existing Arcserve instance. I have downloaded SQL Express Management Studio but have not yet installed it in case it is required (but I would not know how to use it anyway).

    If anyone can help me with this I would be so grateful. I have been battling with this for a week and a half now.



    Tuesday, March 19, 2013 7:28 PM
  • Hello,

    Please share with us the content of the following file:

    C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20130319_185351\Detail.txt

    Thank you in advance.


    Alberto Morillo

    Tuesday, March 19, 2013 7:48 PM
  • Thanks, Alberto.

    The file is 1.7MB. Here's a link to the file on Skydrive:

    Wednesday, March 20, 2013 6:57 AM
  • All that we want is to be in a position where we can install Arcserve and it can either use an existing SQL 2008 SP1 installation, or get the computer in a state where SQL Server Express 2008 SP1 can be installed by Arcserve's installation routine.

    The problem we have had, as you can see from the thread I referenced on Arcserve's forums, is that we are unable to uninstall SQL Server Express and start from scratch because Arcserve's installaer was unable to update the existing SQL 2005 installation. Hence this question

    It seems to me from what I have been reading that you cannot install SQL Server Express 2008 over a failed installation and that it must be uninstalled - something that has repeatedly failed. Unfortunately, SQL is a technology that I am completely unfamiliar with.

    Our situation is becoming desperate - Arcserve's support have not been able to help with this. We have not beenm able to get a backup completed for nearly two weeks now.

    If anyone can offer any suggestions at all I will be very grateful until Alberto or someone else can hopefully pinpoint what the issue is from the detail.txt log I uploaded.

    I won't try those suggestions until Alberto, or someone who has looked at the log posts back.

    Thanks in advance!

    Thursday, March 21, 2013 9:00 AM
  • Arcserve Support got back to me on this and ended up opening a support case with Microsoft.

    A Microsoft SQL Engineer spent over an hour fixing it, but fix it he did! Hooray :)

    Tuesday, April 09, 2013 3:22 PM