Error running Sql 2008 Import Wizard - Cannot create a task with the name "STOCK:PipelineTask". Verify that the name is correct.


  • Running on Vista Business, SP 2
    System has Visual Studio 2005 and 2008 Professional installed

    Clean install of Sql Server 2008 Standard (after uninstalling Sql Server 2005 Express).

    Install showed no errors.

    When I try to run the Import or Export Wizard, it throws the error:


    The SSIS Data Flow Task could not be created. Verify that DTSPipeline.dll is available and registered. The wizard cannot continue and it will terminate. (SQL Server Import and Export Wizard)


    Cannot create a task with the name "STOCK:PipelineTask". Verify that the name is correct.

    Program Location:

       at Microsoft.SqlServer.Dts.Runtime.Wrapper.IDTSExecutables100.Add(String bstrMoniker)
       at Microsoft.SqlServer.Dts.DtsWizard.DTSWizard.InitializeObjectModel(WizardInputs inputs)

    I've tried multiple uninstall/re-installs.  I've tried to manually register DTSPipeline.dll (it failed).  There was a post in this forum but the potential solution was removed from the site.

    any advice would be greatly appreciated - been at this for 2 days

    Wednesday, October 14, 2009 7:19 PM


All replies

  • Hi,

    Please try to register the DTSPipeline.dll again, it should be in "C:\Program Files\Microsoft SQL Server\100\DTS\Binn".

    Registering and unregistering .DLL files:

    If it still does not work, based on my research, the following link may help you, please follow the steps as eva jamiel said.

    Please feel free to let me know if I’ve misunderstood anything.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Friday, October 16, 2009 6:33 AM
  • Thanks for the reply.  I have re-tried to un-regsiter/re-register.  When doing so, I'm getting the following error:

    The module "dtspipeline.dll" was loaded but the call to DllRegisterServer failed with error code 0x80070005.

    I get the same error when using the un-register flag except the message says "...the call to DllUnregisterServer failed..."

    I'm wondering if the problem is with the dll.  I tried turning off the Sql Server Integration Services 10.0 service (just to see if it was the service causing the issue)  and then attempted to launch the wizard again and received the original error.  So, it apears as if it is not even getting that far.

    I have also made sure all of the sql server services are running under my id - which is an administrator.  In addition to that, I followed the links you provided and ensured the dtspipeline.dll was in the registry with the correct path.

    Any other suggestions are appreciated.  Thanks!
    Monday, October 19, 2009 3:10 PM
  • The error 0x80070005 is saying the access is denied. Could you try to run regsvr32 from a command prompt ran as administrator?

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, October 26, 2009 5:16 PM