locked
SQL Server 2012 Error RRS feed

  • Question

  • SQL Server Management Studio fails to load with the error message "Microsoft Visual Studio Isolated Shell Environment." "Cannot find one or more components.  Please reinstall the application." 

    This started happening after I tried to install the "Beta" of Visual Studio 11.  That installation failed during install.  I have removed all of the artifacts that I can find from that installation and I have completely removed SQL Server 2012 and reinstalled multiple times in different ways.  All other features seem to work. 

    Any idea's on which file I messed up by trying to install the beta?

    Michael Buller

    Monday, April 9, 2012 2:13 PM

Answers

All replies

  • Hello,

    Please try the following:

    http://msdn.microsoft.com/en-us/library/cc646006.aspx

    Hope this helps.


    Regards,

    Alberto Morillo
    SQLCoffee.com

    Monday, April 9, 2012 2:37 PM
  • Alberto,

    I have repaired, reinstalled, removed everything off of my machine and resinstalled. Short of reverting to a backup or reformatting and starting from scratch... Not sure what to do.  There is obviously something that is needed during start of the Isolated Shell that does not get checked during the repair or install.

    Michael

    • Proposed as answer by jizhong gao Monday, July 22, 2013 1:20 AM
    Monday, April 9, 2012 5:22 PM
  • Can you install Microsoft Visual Studio Isolated shell 2010 from

    http://www.microsoft.com/download/en/details.aspx?id=1366

    Then apply Visual Studio 2010 SP1



    Regards,
    Ahmed Ibrahim
    SQL Server Setup Team
    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you.
    This can be beneficial to other community members reading the thread.

    Monday, April 9, 2012 5:34 PM
  • Ahmed,

    I did as you said here, installed the Isolated shell 2012 from your link and then reapplied the Visual Studio 2010 SP1.  Then reinstalled SQL Server 2012 Enterprise Edition from disk and in the middle of setup at step Installation Progress, "ManagmentToolConfig_install_postmsi_Cpu64"  it errored out with the same error as above.  "Microsoft Visual Studio Isolated Shell Environment." "Cannot find one or more components.  Please reinstall the application."

    Monday, April 9, 2012 7:16 PM
  • are you installing the same plattform for both SSMS 2012 and Visual Studio 11 Beta? (32-bit vs. 64-bit)

    I assume that you're installing 64-bit SQL Server 2012 (and tools) but Visual Studio 11 Beta probably only as 32-bit.

    SSMS 2012 is effectively a Visual Studio 2010 shell and the same functionality can be installed by installing SSDT and its functionality is included in VS11 Beta as well.

    As such, could you install SQL Server 2012 without SSMS selected and than install SSDT.

    BTW - SSDT CTP4 was not compatible with VS11Beta and it's very likely that this had not been changed in the RTM version and will be fixed in official release of next Visual Studio version (currently called VS11).

    Monday, April 9, 2012 8:21 PM
  • Daniel,

    64 bit SQL Server and I am not trying to install Beta any longer.  I just want to get SSMS back.  SSDT works fine on my machine it is only the SSMS that has an issue loading.  I guess I can just wait until the official release of VS 11 to get SSMS back.  In the mean time I will just use SSDT to work with the database...

    I just wish I knew what I messed up so I could fix it.

    I think it is in the VS SP 1 as when I tried to uninstall that, it gave me an issue, when I reinstalled it, it reinstalled without fail. 

    Tuesday, April 10, 2012 11:36 AM
  • No, Sigh, The SSDT says that "This server version is not supported.  Only servers up to Microsoft SQL Server 2008 are supported."

    So no way to access my 2012 databases.

    Tuesday, April 10, 2012 11:39 AM
  • No, Sigh, The SSDT says that "This server version is not supported.  Only servers up to Microsoft SQL Server 2008 are supported."

    So no way to access my 2012 databases.

    what version of SSDT are you installing ?

    Tuesday, April 10, 2012 11:57 AM
  • Hi Michael,

    Please try:

    • Start regedit.exe

    • Go to HKEY_CURRENT_USER\Software\Microsoft\SQL Server Management Studio

    • Delete 11.0_Config

    • Restart ssms.exe

    There is a similar problem in this feedback to Microsoft, please refer to it:

    http://connect.microsoft.com/VisualStudio/feedback/details/690773/after-installing-visual-studio-11-my-sql-server-denali-cannot-be-opened


    Best Regards,
    Iric
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, April 11, 2012 6:44 AM
  • That worked like a charm!

    That was really easy to fix.  Thank You!!!!

    Wednesday, April 11, 2012 1:30 PM
  • Hi All,

     "Cannot find one or more components.  Please reinstall the application."  "

    Please  try with below  which may resove the issue.

    1. Install powershell 2.0

    2.Reboot the server

    3.repair the SQL server installation

    4. location path where dump located through command line

    run the below command

    Setup.exe /q /ACTION=Repair /INSTANCENAME=MSSQLSERVER

    5. it will take long time may be an Hour

    6. you will receive a message for reboot the machine then do it

    7. shutdown the server

    8.start  the server

    now you will  able to see below regestries comonents after SQL server 2012 repair which not eailier.

    Now you can open SSMS witout an Error :)

    Jayant Kumar Das

    MVP, MS SQL Server DBA

    SQL Server 2012 installation error
    Sunday, October 28, 2012 9:25 PM
  • Sunday, October 28, 2012 9:27 PM
  • Fantastic, it was just what I'm looking for! :)

    Ygor Lazaro

    • Proposed as answer by betaFaktor Thursday, November 29, 2012 1:34 PM
    • Unproposed as answer by betaFaktor Thursday, November 29, 2012 1:34 PM
    Thursday, November 15, 2012 8:32 PM
  • Awesome bro...

    such an easy fix... Thank you so much..

    yo genious!!

    Wednesday, March 6, 2013 8:28 AM
  • Deleting the reg key HKEY_CURRENT_USER\Software\Microsoft\SQL Server Management Studio\11.0_Config worked for me. A frustrating problem, but thanks for providing a solution on the forums.
    • Edited by mattypiper Monday, May 6, 2013 2:43 AM
    Monday, May 6, 2013 2:42 AM
  • Iric Wen, I have been trying to figure this out for weeks.  Only one user was having the problem, i deleted the 11.0_Config, restarted SSMS and everything is working well.  Thank you for taking the time to post this solution!

    Sunday, May 12, 2013 7:57 AM
  • Brilliant! Two machine rebuilds and a new c drive and I was still getting the MS VS Shell Isolated error on a Win 7 Clean Build image. Always assumed that a win re-build would have left the machine in a good state for a clean SQL Server 2012 install - how wrong I was, only wish I'd thought to look for this fix earlier instead of re installing Win7 three times. Deleting the 11.0_Config fixed the issue post SQL Server 2012 install.
    Friday, July 19, 2013 12:33 PM
  • Thanks Ahmed,

    It resolved my problem, I tried to find the solution myself but in the last your suggestion get work

    • Proposed as answer by MSArain Sunday, November 3, 2013 10:19 PM
    • Unproposed as answer by MSArain Sunday, November 3, 2013 10:19 PM
    Sunday, November 3, 2013 10:19 PM
  • Hi, thank you a lot, deleting 11.0_Config solved my issue too...

    Saturday, January 11, 2014 10:44 PM
  • Hi Iric,

    Thanks a alot i also had similar issue, resolved by deleting file from Regedit

    Friday, April 4, 2014 8:06 AM
  • Thankyou. That fixed it for me too.
    Sunday, May 4, 2014 3:21 AM
  • Boom! Worked perfectly for the same problem with SQL Server 2014 Express. Deleted the 11.0_Config and 12.0_Configs, restarted, and it worked great. Thanks so much!
    Tuesday, June 17, 2014 9:55 PM
  • One possible solution is to delete the XX.0_Config in the registry.

    I recently could start my SqlManagementStudio only with elevevated rights.

    I was assuming that something with file/reg-permission must be broken.

    So i changed the REG-permission on the HKCU to Owner=me and Permission=full.

    And did also on filesystem C:\Users\<myname> Owner=me and Permission=full.

    Now everything is working fine again (without elevation).


    Thursday, July 10, 2014 8:46 AM
  • Hello Jayant,

    I installed SQL 2014 Business intelligence 64 edition on my Windows 2012 Standalone node and the SQL Management Studio 2014 does not open and displays the same error specified above.

    I performed the steps like repairing the instance,deleting the 11.0_config from registry,restarted the server but still it does not work and comes up with the same error

    Please help :(

    Friday, July 11, 2014 5:15 PM
  • I am having the same problem with SQL Server 2014 Enterprise x64, but after deleting the X_Config it still does not work with 2014 Server Version :(

    seems this is not a solution anymore :(

    Furthermore, I tried to repair it but got an error at the end of the process... there seems a sql_common_core_loc.msi to be missing, but it is in the Install folder on disk, I manually tried to execute, but it said Access denied, no permission...... something very weird I don't know whats going on...
    • Edited by MALMAL Thursday, July 17, 2014 12:56 PM
    Thursday, July 17, 2014 12:54 PM
  • It's working now :)Thanks a lot :)
    Tuesday, August 5, 2014 7:43 AM
  • Thanks a lot!!! It worked for me!!
    Saturday, August 9, 2014 2:07 PM
  • It worked!  Thank you so much. 
    Monday, August 11, 2014 7:05 PM
  • This did the trick for me! Thanks!

    MS uninstalls are apparently even worse than their installs ...

    Tuesday, September 16, 2014 6:09 PM
  • This worked for me too! Had really tough time to re-install & repair SSMS...Thank you Iric!
    Monday, May 25, 2015 5:24 AM
  • Dear Iric, 

    I tried but it is again showing the same error.

    I reinstalled the sql server but i still have same problem. 

    I am stuck. Please help.

    Best Regard,

    Manoj Joshi

    Sunday, July 19, 2015 10:49 AM
  • this is works for me.i have installed sql server 2012 first and then installed visual studio 2015. after this my management studio stopped working in windows 10.

    regards, Par_11


    Wednesday, December 16, 2015 12:32 PM
  • I am in the same boat.  I have tried every solution mentioned above:

    • Delete 11.0_Config
    • repair Visual Studio 2010
    • apply SP1
    • uninstall and reinstall SQL2012
    • repair SQL2012

    I am running Windows 7, 64-bit and have never installed any beta versions of Visual Studio.

    Everything else in my SQL2012 installation works fine.  But I cannot get SSMS to launch, even if I try launching it from SQL Server Profiler.

    What do I need to look at to determine where the break is?


    Tuesday, March 22, 2016 2:52 PM