none
SSRS FQDN URL Issue RRS feed

  • Question

  • Hi,

    I m facing a series with SSRS URL.

    When i try Access URL http://Localhost/Reports/browse it is working properly but 

    when i try access the URL http://<machinname>.<domainname>.com/ReportServer it is asking for windows credential. once i give it is working fine. 

    Could any one please tell what went wrong here.

    thanks in advance.


    Friday, June 2, 2017 6:32 PM

Answers

  • Hi Nagarajan Venu,

    This issue could be caused by Kerberos Authentication. 

    On a report server that is configured for Negotiate or Kerberos authentication, a client connection to the report server will fail if there is a Kerberos authentication error. 

    If the URL includes a fully qualified domain name, Internet Explorer selects NTLM. If the URL specifies localhost, Internet Explorer selects NTLM. If the URL specifies the network name of the computer, Internet Explorer selects Negotiate, which will succeed or fail depending on whether an SPN exists for the Report Server service account. 

    To solve this issue, you could try to add the URL http://<machinname>.<domainname>.com/ReportServer in the trusted site from Internet Options in Internet Explorer and check “Auto logon with current user name and password”. For detailed information and steps, you could refer to the similar thread SSRS prompting for login when using full domain server name

    If you have any questions, please feel free to ask.

    Best Regards,

    Henry 

    Monday, June 5, 2017 8:18 AM
  • Like Henry was saying, it's probably a Kerberos issue.  If you're wanting to implement using Kerberos - try running the Kerberos Configuration Manager Tool and check for a misconfiguration.  Download link: https://www.microsoft.com/en-us/download/details.aspx?id=39046

    If you don't want/need Kerberos, you can try setting the authentication type to NTLM.  More documentation can be found here: https://docs.microsoft.com/en-us/sql/reporting-services/security/configure-windows-authentication-on-the-report-server

    Thursday, June 15, 2017 12:01 AM

All replies

  • Hi Nagarajan Venu,

    This issue could be caused by Kerberos Authentication. 

    On a report server that is configured for Negotiate or Kerberos authentication, a client connection to the report server will fail if there is a Kerberos authentication error. 

    If the URL includes a fully qualified domain name, Internet Explorer selects NTLM. If the URL specifies localhost, Internet Explorer selects NTLM. If the URL specifies the network name of the computer, Internet Explorer selects Negotiate, which will succeed or fail depending on whether an SPN exists for the Report Server service account. 

    To solve this issue, you could try to add the URL http://<machinname>.<domainname>.com/ReportServer in the trusted site from Internet Options in Internet Explorer and check “Auto logon with current user name and password”. For detailed information and steps, you could refer to the similar thread SSRS prompting for login when using full domain server name

    If you have any questions, please feel free to ask.

    Best Regards,

    Henry 

    Monday, June 5, 2017 8:18 AM
  • Hi Thanks for your reply.

    I have add the URL in the trusted site from Internet options but still I am getting the pop up for credentials.


    Wednesday, June 14, 2017 9:31 PM
  • Like Henry was saying, it's probably a Kerberos issue.  If you're wanting to implement using Kerberos - try running the Kerberos Configuration Manager Tool and check for a misconfiguration.  Download link: https://www.microsoft.com/en-us/download/details.aspx?id=39046

    If you don't want/need Kerberos, you can try setting the authentication type to NTLM.  More documentation can be found here: https://docs.microsoft.com/en-us/sql/reporting-services/security/configure-windows-authentication-on-the-report-server

    Thursday, June 15, 2017 12:01 AM