Not Receiving Incoming Email from Drop folder RRS feed

  • Question

  • Hello,
    I hope that someone out there will be able to help me with this issue. I am fairly new to MOSS2007 but belive that I have configured e-mail to list correctly, I followed the steps set out by Steve Smith


    The process all follows fine and when I attempt to send to a configured mail enables list I can see the mail make it to the drop folder as it should. This is where the problem occurs, it is never picked up by the Windows SharePoint Services Timer service. The e-mail's I send just sit in the drop folder and nothing is happening.

    As this is a fairly simple thing to setup there isn't a great deal of troubleshooting info out there and most of it just says check the basics like making sure that in the central administration console>Incomming Mail Settings the drop folder is specified as C:\inetpub\mailroot\drop (which it is)

    I've been through the event logs and those created by sharepoint but can't see anything that looks like an error causing this issue and nothing in the applications logs either. I'm in limbo at the moment because so far as I can see I have setup correctly, mail delivery is succesful and nothing to suggest what is causing the issue.

    I have reset the permissions on the drop folder to grant full access to the service account that runs the Windows SharePoint Services Timer service, I have even added the Windows SharePoint Services Timer service account to the domain administrators group to try and make sure its not a permissions issue.

    Any advise would be appreciated because I've ran out of idea's now!?

    Thanks in advance.

    Tuesday, August 11, 2009 12:09 PM


  • I finally called Microsoft Support on my issue.  Mine was two fold. 

    1.First on the CA Incoming Email settings I "had" to select Advanced Mode and enter the location of the drop folder.  Microsoft could not tell me why I had to now when it was working for 3 years with selecting that.

    2. You will have to run stsadm.exe -o enumservices > c:\services.txt    to get the exact full name for the Incoming Email service to list in the next step.

    3. Then after that they had to stop my Incoming Email Service manually at the command prompt. They ran stsadm.exe -o -provisionservice -action start -servicetype "Microsoft.SharePoint.SPIncomingEmailService, Microsoft.SharePoint, Version=, Culture...."  

    4. Then IISreset /noforce

    then my emailing started sending from my drop folder.   Hope this helps.
    MSI-Linda SharePoint Architect & Designer
    Tuesday, September 22, 2009 2:19 PM

All replies

  • Hi,


    Did you select “Directory Management Service” option, if so, please make sure you configure the Central Administration application pool identity account to have the Create, delete, and manage user accounts right to the container that you specify in Active Directory.


    Did you install Exchange server 2003 in your MOSS environment? If so, you should add an SMTP connector in Exchange Server, if you don’t know how to do that, you can post your issue into the following forum:




    Also, please check whether your configuration meet the following requirements, If not, correct them and check the effect.


    ·         The application pool account for Central Administration, the logon account for the Windows SharePoint Services Timer service, and the application pool accounts for your Web applications should have the correct permissions to the e-mail drop folder.


    ·         The domain controller running Active Directory has a Mail Exchanger (MX) entry in DNS Manager for the mail server that you plan to use for incoming e-mail.


    For more information about how to configure incoming e-mail settings, please refer to the following article:


    Configure incoming e-mail settings



    Introduction to incoming e-mail



    Demo: Configure a SharePoint Server 2007 site to receive e-mail



    Enable and configure e-mail support for a list or library



    Rock  Wang 

    Rock Wang– MSFT
    Wednesday, August 12, 2009 3:22 AM
  • Hello Rock
    Thanks for the responce, I did select Directory Management service option and its working fine, when I mail enable a list in sharepoint i can see the entry into the container in AD setup correctly, so I know that permissions are working fine there.

    I have an Exchange 2007 box which has an SMTP connector setup to send to the MOSS server which is running SMTP server on it, this is why mail is succesfully making it to the drop folder. The account for central administratoion, windows sharepoint services timer service account and application pool account at all the same one and they have correct permissions to the drop folder. I have tested this by logging on as that account and writing\deleting from the drop folder.

    There is also an MX entry in the DNS manager for the incoming mail server.

    Thanks for the links, I have been through them all but they aren't getting me any closer to a fix for this issue because everything is setup as it should be, I'm still stuck!

    Everything prior to pickup from the drop folder works fine and I can't see why the timer service isn't delivering them to the list.

    Thanks again for your help.


    Wednesday, August 12, 2009 8:08 AM
  • Hi Drew,

    Restart the Windows SharePoint Timer Service and check whether it pick up your mail in the drop folder or not

    Good luck,
    Long Nguyen
    Wednesday, August 12, 2009 8:19 AM
  • Hi Long

    Thanks for the tip, unfortunatly I've reached a point where aimlessly restarting services and servers is all I have been doing for 2 days in the hope that it will somehow just start working, but as yet this has been unsuccesfull.

    Thanks again.
    Wednesday, August 12, 2009 8:20 AM
  • Can you please tell me where you have configured the 'Relay Restriction' settings to grant permission to the IP address of MOSS server

    As I understand that you have Exchange server in different system and MOSS with SMTP in different one, so you have to configure the 'Relay Restriction' settings on Exchange server... have you done that?.....please confirm

    Wednesday, August 12, 2009 10:18 AM
  • Hi yes i can confirm this is done.

    Wednesday, August 12, 2009 11:17 AM
  • Hello,
    I'm having the exact same problem.
    The difference is that I'm using automatic settings.

    The EML file gets to the drop folder just fine. But never gets to the Document Library.

    Friday, September 4, 2009 8:46 PM
  • I've bit the bullet and paid for Microsoft support on this, they have been scratching their head's for over a week now trying to work out whats causing the issue, I'll get back to you with the solution they provide once I have one.

    Tuesday, September 8, 2009 12:21 PM
  • I have the same problem.

    I have had a Farm working in production for 3 years now, and I migrated it to 64bit and SP2 and now Incoming email is no longer working.  I am using Automatic rather than Advanced, and the EML messages just sit there in the DROP folder.  No errors are logged anywhere at all.  I have applied all suggestions currently in the Forums with no improvement.

    Please post your fix here when Microsoft Support resolves this for you. THANKS!
    MSI-Linda SharePoint Architect & Designer
    Sunday, September 13, 2009 8:32 PM
  • This is the e-mail I recieved from MS, I'm not happy because they can't find a solution to the problem so they are just recommending a rebuild, I could have done this myself and saved my £250!

    Everything was working with before the corrupt installation of SP2, I'm sorry I can't be of more help to those of you who are having the same issues.

    Hi Drew,


    as discussed, the summary of our phone call.


    I discussed your problem with the next level. What we can say for sure is that there are several problems on the server, e.g.

    ·         Tracing Service isn’t running properly

    ·         Timer Jobs aren’t starting (to troubleshoot this we need to get the Tracing Service running)

    ·         Problems with the Alternate Access Mappings

    ·         Maybe also Kerberos Problems

    ·         Problems with Authentication


    This list is not complete, just examples what we found out while analysing the problem with the timer jobs. We have to go step by step through the problems and maybe other Service Requests will be necessary to be able to fix the problems on the server. It’s also not sure if you will run into other problems in future.


    For this reason we would recommend to make a fresh farm installation and migrate the content database to the new installation.

    This will would be the fastest solution and probably the solution with the fewest effort.

    Monday, September 21, 2009 9:45 AM
  • To make things worse the support I will recieve, another E-mail from MS, basically I paid money to be told what I already knew and if I want any assistance fixing the issue which I raised the case for then I have to pay again and again for support:

    Unfortunately, we cannot give you any guarantee that a fresh installation would not cause any problems.

    Should you run into problems by installing a clean SharePoint, we are also not allowed to assist you with issues that are not related to the actual problem of this support call. Our support guideline and the licence agreement that you also signed is forcing us to work on only one single problem within a support request. Even if the problem is caused by suggestions and actions provided by the engineer within the context of the support request a new incident is needed of which the increment depends on the nature of the incident.


    After discussing your situation with our escalation level, we could provide you with a number of actions. It is not clear how long and how many actions could be required to find a possible solution. It is possible, however, that this would be an ongoing process that takes a considerable period of time until we have narrowed down the issue to eventually provide a solution. Neither can we guarantee that a solution will not entail a new installation as there are settings in the global SharePoint databases that cannot be tweaked  by the means of the SharePoint administration tools. Manually editing the SQL databases is not allowed as the farm would then get into an unsupported state. For this reason we can never advise you to tweak your database.


    I believe it is in your interest to have the quickest possible solution for your issue, therefore a fresh scratch installation of SharePoint is recommended.


    We are aware of the workload involved in editing the global configuration settings of SharePoint again since they are not located in the content databases of your web applications.


    If you follow our recommendation and reinstall your SharePoint Farm, I can try to assist you. As long as I’m able to answer your easier questions, I will do my best to provide you with answers for it. But if research and analysis is needed to answer some questions related to the installation process, I would need to ask you to open another support request for it as it is part of our policy which we all need to adhere to. This additional support request is then, as explained above, subject to costs involved.

    Monday, September 21, 2009 9:49 AM
  • I wouldn't go as far as redoing my Sharepoint farm or even one server just to see that this was not the problem, i exibit exactly the same issue.

    If i mail-enable a website sharepoint even creates a username in the apropriate OU and i can send an email to it, i see the *.eml in the drop folder and then it disapears afterwards.

    My setup:
    Exchange 2007
    Sharepoint 2007 SP2
    on Windows 2008 SP1

    ...not sharing any helpful information yet but rather a confirmation that something is not working as it should. If i find a solution i will come back and post it...
    Tuesday, September 22, 2009 8:58 AM
  • Do you have any filters enabled on the Exchange - SMTP Virtual Server?  IMF, Connection Filter, etc?

    Have you enabled Message Tracking within Exchange and reviewed the logs?
    Tuesday, September 22, 2009 1:10 PM
  • I finally called Microsoft Support on my issue.  Mine was two fold. 

    1.First on the CA Incoming Email settings I "had" to select Advanced Mode and enter the location of the drop folder.  Microsoft could not tell me why I had to now when it was working for 3 years with selecting that.

    2. You will have to run stsadm.exe -o enumservices > c:\services.txt    to get the exact full name for the Incoming Email service to list in the next step.

    3. Then after that they had to stop my Incoming Email Service manually at the command prompt. They ran stsadm.exe -o -provisionservice -action start -servicetype "Microsoft.SharePoint.SPIncomingEmailService, Microsoft.SharePoint, Version=, Culture...."  

    4. Then IISreset /noforce

    then my emailing started sending from my drop folder.   Hope this helps.
    MSI-Linda SharePoint Architect & Designer
    Tuesday, September 22, 2009 2:19 PM
  • Hi,
    Just a quick update, in the end I have rebuilt my MOSS enviroment by building a basic server farm and migrating the db's to a dedicated sql server. Obviously this has resolved the issue and we're back up and running again.

    Sorry I couldn't be of more help to others that are having the same issue but I tryed everything I could find online and through Microsoft support and nothing resolved the issue so rebuild it was.

    Thanks for all your comments and suggestions.

    • Proposed as answer by harold.gray Friday, April 13, 2012 11:22 AM
    • Unproposed as answer by harold.gray Friday, April 13, 2012 11:22 AM
    Thursday, January 7, 2010 8:52 AM
  • Thank you Linda - Your solution worked for me!
    Wednesday, June 16, 2010 10:21 PM
  • Hi Linda,

    I have my smtp and pop3 servers running on my win 2003 server. My WSS server is running on a separte machine (but in the same domain).

    The problem I have is that my library desn't receive incomiing emails. I can send the emails to the library ( document@domain.com) and I see the email in the "document" mailbox in POP3, but it sits these for ever!

    I tried your solution but got error message after running line 3 ( stsadm ...... servicetype "Microsoft...." )


    Any advice?


    Thank you.


    Tuesday, February 8, 2011 12:35 AM
  • There is no dash in front of provisionservice
    • Proposed as answer by Santosh Gore Sunday, May 24, 2020 1:13 PM
    Thursday, February 10, 2011 11:52 PM
  • I would like to thank Linda for posting her fix because I am able to finally get a list to receive emails, and I would like to thank SF Terry for putting the reply in about the dash.  I am now able to see receive email via my SharePoint list.


    Thanks Kim

    Saturday, April 23, 2011 3:26 AM
  • +1 - Thanks Linda!


    Friday, June 17, 2011 4:48 PM
  • Thanks Linda.... worked like a charm..
    Friday, April 13, 2012 11:22 AM
  • Hi, did you get it worked?
    Wednesday, August 1, 2012 4:06 PM
  • How you stop the Incoming Email Service manually at the command prompt?
    Wednesday, August 1, 2012 4:07 PM
  • When i try to do the 3rd step i gets "Missing operation name or the operation name is invalid."
    Wednesday, August 1, 2012 4:09 PM
  • provisionservice shouldn't have a dash before it...

    stsadm.exe -o provisionservice -action start -servicetype "Microsoft.SharePoint.SPIncomingEmailService, Microsoft.SharePoint, Version=, Culture...."  

    • Edited by Ryan.Hayden Wednesday, August 1, 2012 7:48 PM
    Wednesday, August 1, 2012 7:48 PM
  • I found this article that helped me with an issue of e-mails sitting the the drop folder.


    Jerry M. Bakels

    • Proposed as answer by sathyaav Tuesday, September 25, 2012 10:04 AM
    Thursday, August 2, 2012 4:10 PM
  • Additional possible solution for some people:

    One of the patches in 2014 has introduced the same bug that is known in SP2013, where if the Sandbox quota is < 600 for a site collection containing email enabled lists/libraries, the incoming email doesn't work.

    Just found this with help from MS Tech Support.  Teach me for not using quotas in dev/test.

    • Proposed as answer by Nik SS Friday, March 24, 2017 5:12 PM
    Tuesday, March 31, 2015 4:47 AM
  • Hi Linda, i am facing the same issue in my test environment . i have 2 WFE and 1 app server . i tried doing what you suggested , 'stsadm.exe -o enumservices > c:\services.txt ' but i do not get any result of this command . am i doing something wrong?
    Thursday, February 4, 2016 5:16 AM
  • Thanks Craig, this is worked for me,i am investigating further to understand the root cause

    If my contribution helps you, please click Mark As Answer on that post and Vote as Helpful

    Thanks, ShankarSingh(MCP)

    Friday, March 24, 2017 5:14 PM
  • Thanks Linda, this worked for me. Just a correction, there is no dash(-) in front of provisionservice
    Sunday, May 24, 2020 1:16 PM