none
Cannot compare Schema nor Data using SSDT RRS feed

  • Question

  • Hello,

    I've been fighting with SSDT comparison feature, but the problem is not mentioned anywhere and I'm slowly dying in finding what else can I do.

    I want to do a Schema/Data compare, but whichever I pick, after choosing the source and target databases and clicking next/Compare, Visual Studio tells me that error occurred and in the Error List window there is:

    Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).

    The error actually does not help at all, because I don't know what is causing this. I did a lot of research and so far I have found that this error shows up only on a specific database machine. I also tried to install SSDT directly on the database server and run the comparison from there, but the results are still the same.

    I'm using the latest version of SSDT and the SQL Server is 2012 Developer Edition x64. The OS on which it is installed is Windows Server 2012.

    Can anyone shed some light on where the problem might be?

    Sunday, August 31, 2014 8:47 AM

All replies

  • This does sound odd. Are you able to share the database schema so we can investigate. Can you run  DBCC CHECKDB see if something wrong with your db? If this doesn't show anything please file a connect bug and attach the sample schema that is failing.

    File a Connect bug

    Saturday, September 27, 2014 2:29 AM
  • Hey,

    DBCC CHECKDB results in this:

    CHECKDB found 0 allocation errors and 0 consistency errors in database 'MPT_GTMPT'.

    Sample schema is fairly easy: empty database. That's right - I have an empty database and I want to compare that to another empty database. The collation is Polish_CI_AS but that should not have any influence on the error (as I have tested the same on other SQL Server machines and it worked without problems).

    That said, I have same message in both Schema and Data compare.

    Thursday, October 2, 2014 9:24 AM
  • Are you using Integrated Security or SQL Auth to connect to the server? If so, does switching to the other method of authentication have any effect?

    Does the problematic instance of SQL Server work correctly when used from other tools, e.g. can you run queries against it in SQL Server Management Studio?

    Friday, October 3, 2014 1:35 AM
    Moderator
  • I use both - and both auth works correctly. I've already tried to test if changing the methods does any change, but no no avail.

    Problematic SQL instance actually work without an issue - well, except data and schema comparison problem. I've already tried to compare it's settings to other SQL instances that we have, and they seem to be identical, both in the configuration as well as in the updates installed on the machines.

    If there is any way you guys would be interested in any kind of configuration information on the machines and SQL instance itself, let me know, I will post the information here.

    Already opened a ticket here: https://connect.microsoft.com/SQLServer/feedback/details/989091 but they cannot repro the issue (I'm not surprised) and did not respond when I offered shared desktop over Lync meeting, so I guess I'm stuck with the problem for now... It's frustrating though, not being able to use such a neat feature as data compare, especially since this problematic instance is our dev database.


    • Edited by Nyuno1 Monday, November 24, 2014 7:42 PM
    Monday, November 24, 2014 7:41 PM