none
Microsoft.ACE.OLEDB.12.0 provider is not registered RRS feed

  • Question

  • Hi,

    I'm trying to import a csv file into a tabular model via VS2012 with data import wizard. I get following error message:

    Der Anbieter 'Microsoft.ACE.OLEDB.12.0' ist nicht registriert (german). English translation: Microsoft.ACE.OLEDB.12.0 provider is not registered

    I use Windows 7 64-Bit, with Office 2013 32-Bit. I already tried following things:

    - Install Microsoft Access Database Engine 2010 Redistributable 32-Bit on my local machine

    - Install Microsoft Access Database Engine 2010 Redistributable 64-Bit (via command line and /passive) on my local machine

    - Install Microsoft Access Database Engine 2007 on my local machine

    Nothing worked for me. Any ideas for solving this problem???

    Thanks and best regards,

    Kalle

    Monday, August 17, 2015 2:07 PM

Answers

  • https://social.msdn.microsoft.com/Forums/en-US/1d5c04c7-157f-4955-a14b-41d912d50a64/how-to-fix-error-the-microsoftaceoledb120-provider-is-not-registered-on-the-local-machine?forum=vstsdb

    Vote As Helpful if it helps to solve your issue

    Monday, August 17, 2015 2:48 PM
  • I've solved this issue recently on a couple of servers.  If you installed the appropriate driver from the latest redistributable (i.e. 64 bit driver is you have a 64 bit OS and 64 SQL Server or the 32 bit driver is you have a 32 bit installation), you need to updated the provider properties on the SQL Server instance.

    In the Properties window of the Microsoft.ACE.OLEDB.12.0 provider, I needed to Enable the Allow inprocess provider option.  By default, this option is not enabled.  However, for the ACE driver to work, it has to be enabled.  Depending on how you use the driver, you may need to Enable the Dynamic parameter option as well.

    Monday, August 17, 2015 2:57 PM

All replies

  • https://social.msdn.microsoft.com/Forums/en-US/1d5c04c7-157f-4955-a14b-41d912d50a64/how-to-fix-error-the-microsoftaceoledb120-provider-is-not-registered-on-the-local-machine?forum=vstsdb

    Vote As Helpful if it helps to solve your issue

    Monday, August 17, 2015 2:48 PM
  • I've solved this issue recently on a couple of servers.  If you installed the appropriate driver from the latest redistributable (i.e. 64 bit driver is you have a 64 bit OS and 64 SQL Server or the 32 bit driver is you have a 32 bit installation), you need to updated the provider properties on the SQL Server instance.

    In the Properties window of the Microsoft.ACE.OLEDB.12.0 provider, I needed to Enable the Allow inprocess provider option.  By default, this option is not enabled.  However, for the ACE driver to work, it has to be enabled.  Depending on how you use the driver, you may need to Enable the Dynamic parameter option as well.

    Monday, August 17, 2015 2:57 PM