2008 R2 security question


  • <p>I am having a devil of a time trying to get service broker working. My user has db_owner rights on two databases within the same instance. I do not have sysadmin privileges but can get them if needed. I have setup SB using 2005 successfully using different instances and now am perplexed when having these issues. before I go the 'sa' route I would like to know if setting everything up using the sysadmin priv and using&nbsp;'execute as owner' on Activation procedure would alleviate my pain. I have tried everything I can think of. I shouldn't have to setup endpoints and such since this is internal to the instance, correct? If I run through everything in the tutorial as is in this instance <em>I get this.

    This message could not be delivered because the targeted service does not support the service contract. Targeted service: '//ProCred_DB/CME_UpdHoursTargetService', service contract: '//UpdateCMEHours/CMEUpdateHoursContract'.</p>

    BEGIN DIALOG @InitDlgHandle
         FROM SERVICE [//CME_DB/CME_UpdHoursInitService]
         TO SERVICE N'//ProCred_DB/CME_UpdHoursTargetService', '10C4F502-5912-4EED-BE52-CA4D28BF0044'
         ON CONTRACT [//UpdateCMEHours/CMEUpdateHoursContract]


    Tuesday, April 23, 2013 4:06 PM


All replies