none
Cannot remotely connect to SQL 2008 x64 on Server 2008 R2 x64 RRS feed

  • Question

  • Hi

    I've installed SQL Server 2008 x64 Enterprise Edition on a Windows Server DataCentre Edition 2008 R2 server. I have a named SQL instance installed, called GAMS. I can connect to this instance on the machine itself with SSMS, but not remotely.

    In the SQL Configuration Manager, TCP/IP, Named Pipes and Shared Memory is enabled. Under the Protocols for GAMS option, I edited the properties for the TCP/IP protocol, removing 0 at each Dynamic Port, and setting the TCP port to 1433 for each IP address list, including IPALL. All the IP's are enabled and active, and I made sure that there is a IPv4 and IPv6 localhost IP present. The external IP (10.50.130.40) is also present, enabled, active and set to 1433. In Management Studio, I edited the properties for the instance, and under Connections I set 'Allow remote connections' to be enabled.

    I've also opened the ports needed by SQL on my firewall, but even when I disable the firewall completely, I'm still unable to connect to the SQL instance.

    In Management Studio, I connect to <ServersIP>\GAMS,1433. Doesn't work.

    Is there another setting somewhere?
    Wednesday, May 13, 2009 10:16 PM

Answers

All replies

  • have u turn on SQL Server Browser Turns on? refer to books online, SQL Server Browser listens for incoming requests for Microsoft SQL Server resources and provides information about SQL Server instances installed on the computer. SQL Server Browser contributes to three actions:

    1. Browsing a list of available servers


    2. Connecting to the correct server instance


    3.Connecting to dedicated administrator connection (DAC) endpoints.

    if the problem still exists after u turn on this service browser try to use alias in configuration manager and click SQL Native  Client configuration

    Wednesday, May 13, 2009 10:43 PM
  • If you are saying the external IP address is 10.x.  This cannot be.  10.x is a private IP range and is not routed on the Internet.  You must have a "public" IP address assigned to the server if you are trying to access it via the Internet.  It might be possible to access using a VPN on 10.x.

    Once you have that resolved, you connect to the server using ServerIP,1433. 
    Thursday, May 14, 2009 7:27 PM
    Moderator
  • Was a firewall setting on another firewall...
    Friday, February 4, 2011 10:09 AM