none
Silent installation of SQL Express 2005 SP3 (English) on localized European Windows Systems fails with error 28075

    Question

  • Dear Colleagues,  

    We deliver C++ med. application with several prerequisites, including SQL Express 2005 SP3. All installations are flawless but!

    The problematic installation is on German\French systems (this far it was Windows 7 32-bit, but I would expect it to fail on all flavors of supported Windows, including 64-bit, Vista etc).

    Details

    SQL Express 2005 SP3 fails to recognize localized parameter [German or French]  with error 28075

    SQL Server Setup could not validate the service accounts. Either the service accounts have not been provided for all of the services being installed, or the specified username or password is incorrect. For each service, specify a valid username, password, and domain, or specify a built-in system account.


    Here is full command I'm using (installation of SQL Express 2005 SP3 on German Win7 32-):

    Executing this command manually  (typing in cmd prompt) on German system goes through with no problem; executing the same command through batch file (just to experiment and debug possibly) turns NT-AUTORITÃT into this: NT-AUTORIT-T (in cmd prompt)

    Installer in its turn, verifiablty misinterpretes à character, turning it into SQLACCOUNT=NT-AUTORITÄT

    And this is what reported by MSI log after SQL Exp 2005  installation fails:

    MSI (s) (40:D0) [14:22:21:421]: Command Line: INSTANCENAME=xxxxx SQLACCOUNT=NT-AUTORITÄT\SYSTEM

    Installation on French OS fails as well, eventhough there are no special characters involved AUTORITE NT\SYSTEM

    I'm running out of ideas on how to fix this issue and.., well, release time is getting close.

    Could someone please ! help and share his\her expertise on how to pass (correctly!) localized parameters to SQL Express 2005 (English) being installed on localized Windows OS..?

    (I presume .NET2.0 Framework on localized OS is also localized, right..?)

     

    Sunday, October 10, 2010 6:43 PM

Answers

  • Hello Tom,

    thank you for the response. Yes, I've tried all possible Save As combinations including Unicode, Unicode big endian, UTF-8 as well.

    Finally I've ended up with creating INI file for installing SQL Express 2005 on German Windows, and surprizingly enough it took Ä just fine. German installation resolved:

    [Options]
    ADDLOCAL=SQL_Engine
    INSTANCENAME=xxxx
    SQLACCOUNT="NT-AUTORITÄT\SYSTEM"
    SQLSYSADMINACCOUNTS="VORDEFINEIRT\Administratoren"
    ADDUSERASADMIN=1
    SQLAUTOSTART=1
    DISABLENETWORKPROTOCOLS=1

    Hope this information will be helpful for someone else struggling with similar problem.

    Oh, one detail: SQL Express installer requires exact path reference to where INI is located:

    sample: /qn /settings C:\Windows\Temp\filename.ini (path should be in quotes if names include spaces)

    Thank you!

     

    Tuesday, October 12, 2010 9:33 PM

All replies

  • Colleagues,

    SQL Express 2005 SP3 silently installs - by using command line options and switches - well on all English editions of Windows.

    However, when it comes to German (localized) Windows 7 (I suspect that other German OS editions as well), SQL Express fails to recognize recommended SQLACCOUNT="NT-AUTORITÄT\SYSTEM"; simple removal of this option from command line - and silent install goes through but sets default account to Network Service, and we really need LocalSystem instead. Oh, manual installation goes fine with all configurations, including LocalSystem; unfortunately we have to use silent install for all our customers.

    Similar problem detected while installing SQL Express 2005 on French Windows 7 - SQLACCOUNT="AUTORITE NT\SYSTEM" is not taken well by installer.

    Please kindly recommend a solution for this issue

    Alex S

    Monday, October 11, 2010 5:07 PM
  • Hi AlexSeleznev,

     

    Executing this command manually  (typing in cmd prompt) on German system goes through with no problem; executing the same command through batch file (just to experiment and debug possibly) turns NT-AUTORITÃT into this: NT-AUTORIT-T (in cmd prompt)

    Is this batch file created in the same server or in another server?

    If it is created in another server, this issue might be caused by that this batch file is stored in ANSI encoding. If this file is stored in ANSI encoding, it might be interpreted incorrect in another server in different language.

    In this situation I would like to recommend that you save this file in UTF-8 encoding and try again. To save this file in UTF-8 encoding, please open this file in Notepad and click “File | Save As …”. In the popup dialog, please change the encoding from ANSI to UTF-8.

     

    If you create this file in the same machine, before further investigation and test, please provide us the full command you use.

     

    If anything is unclear, please let me know.


    Regards,
    Tom Li
    Tuesday, October 12, 2010 5:37 AM
    Moderator
  • Hello Tom,

    thank you for the response. Yes, I've tried all possible Save As combinations including Unicode, Unicode big endian, UTF-8 as well.

    Finally I've ended up with creating INI file for installing SQL Express 2005 on German Windows, and surprizingly enough it took Ä just fine. German installation resolved:

    [Options]
    ADDLOCAL=SQL_Engine
    INSTANCENAME=xxxx
    SQLACCOUNT="NT-AUTORITÄT\SYSTEM"
    SQLSYSADMINACCOUNTS="VORDEFINEIRT\Administratoren"
    ADDUSERASADMIN=1
    SQLAUTOSTART=1
    DISABLENETWORKPROTOCOLS=1

    Hope this information will be helpful for someone else struggling with similar problem.

    Oh, one detail: SQL Express installer requires exact path reference to where INI is located:

    sample: /qn /settings C:\Windows\Temp\filename.ini (path should be in quotes if names include spaces)

    Thank you!

     

    Tuesday, October 12, 2010 9:33 PM