none
HOW TO Grant the Manage All Subscriptions rights RRS feed

  • Question

  • I current have a problem in that I am wanting to create Data Driven Subcriptions on a report. These are the steps I follow.

    Click on the report in the report server and then click subscriptions but it only shows Windows File Share. I have full enterprise version of the software as I know this is a known problem if you have a lesser version.

    Please can someone help. The only article I have found states that if you don't see the New Data Driven Subscriptions button, you either don't have Manage All Subscriptions right or you are not running Developer or Enterprise edition.

     

     

    Monday, May 24, 2010 7:01 AM

Answers

  • Hi Greg,

    You are right. Only Enterprise and Developer edition have the Data-Driven Subscription feature. And only the user who has "Manage all subscriptions" and "Manager Reports" permissions can create Data-Driven subscriptions.
    By default, we can find the option to create Data-Driven subscription in the following page:


    To assign user "Manager All Subscriptions" or "Manager Reports" permissions, please follow these steps:
    1. Run SQL Server Manager Studio as administrator.
    2. Connect to "Reporting Services".
    3. Under "Security"
    4. Right click "Roles" to create a new role with "Manager All Subscriptions" or "Manager Reports" permissions. Or double-click an existing role to modify it to have these permissions.
    5. Now, open Report Manager using URL http://<server>/Reports by defautl.
    6. In the Home page, click "Properties"
    7. Click "New Role Assignment", and then assign the user the role we created before.

    Now, the user will be able to create Data-Driven Subscription.

    For more infomration, please see:
    Creating, Modifying, and Deleting Data-Driven Subscriptions: http://msdn.microsoft.com/en-us/library/ms156012.aspx

    If you have any more questions, please feel free to ask.

    Thanks,
    Jin Chen


    Jin Chen - MSFT
    Tuesday, May 25, 2010 8:49 AM
    Moderator

All replies

  • Hello, Did you configure the SMTP setting in RSConfig file?

    Pls check this link to get an insight on this

    http://www.sqlservercentral.com/Forums/Topic506764-150-1.aspx


    Regards, KarthikShanth. "Mark as Answer" if this helps you!

    Shanth's techwitz

    ↑ Grab this Headline Animator

    Monday, May 24, 2010 7:56 AM
  • Thanks for getting back to me but I am not wanting to do email subscriptions. when I go to the report and click on the Subcriptions Tab I should have the obtain or what time of subscription I want. I.e Data Driven, File Share etc. I dont have the data driven option thats what I need.

     

    Thanks

     

    Greg

    Monday, May 24, 2010 8:38 AM
  • Hi Greg,

    You are right. Only Enterprise and Developer edition have the Data-Driven Subscription feature. And only the user who has "Manage all subscriptions" and "Manager Reports" permissions can create Data-Driven subscriptions.
    By default, we can find the option to create Data-Driven subscription in the following page:


    To assign user "Manager All Subscriptions" or "Manager Reports" permissions, please follow these steps:
    1. Run SQL Server Manager Studio as administrator.
    2. Connect to "Reporting Services".
    3. Under "Security"
    4. Right click "Roles" to create a new role with "Manager All Subscriptions" or "Manager Reports" permissions. Or double-click an existing role to modify it to have these permissions.
    5. Now, open Report Manager using URL http://<server>/Reports by defautl.
    6. In the Home page, click "Properties"
    7. Click "New Role Assignment", and then assign the user the role we created before.

    Now, the user will be able to create Data-Driven Subscription.

    For more infomration, please see:
    Creating, Modifying, and Deleting Data-Driven Subscriptions: http://msdn.microsoft.com/en-us/library/ms156012.aspx

    If you have any more questions, please feel free to ask.

    Thanks,
    Jin Chen


    Jin Chen - MSFT
    Tuesday, May 25, 2010 8:49 AM
    Moderator