locked
Running a Report Via URL RRS feed

  • Question

  • Hey Guys,

     

    I am creating a button in a app with some jscript, but for the life of me can not get the report running while passing a parameter to the URL.

    The Parameter in the report design is not set to internal as was suggested on some other posts.

     

    This is the URL I am building:

    http://server/reports/Pages/Report.aspx?ItemPath=%2fVITAL%2ftest&rs:Command=Render&Hospital=1

     

    This part I copied from just trying to run the report manually and input the parameter myself:

    http://saintrah04/reports/Pages/Report.aspx?ItemPath=%2fVITAL%2ftest

     

    I was led to believe from other posts I saw that adding &rs:Command=Render&Hospital=1 to the end of the URL would then pass the Parameter "Hospital" with the value of "1" and the Command=Render would automatically run it...

     

    Just to cover the normal things, yes I am sure the parameter name is correct and yes the report does work normally

     

    Thanks,

     

    Caz

     

    Tuesday, July 19, 2011 7:52 AM

Answers

  • You are giving the path of report manager and not report server

    the path would be like

    http://10.23.52.223/ReportServer/Pages/ReportViewer.aspx?%2fConfigurer%2fReports%2fStores&rs:Command=Render


    --------------------------------------------------------

    Surender Singh Bhadauria

     


    • Marked as answer by Caz1224 Wednesday, July 20, 2011 4:38 AM
    Tuesday, July 19, 2011 8:07 AM