VS2008 unable to load Integration Services package document after creation


  • Upon creating a new IS project in Visual Studio 2008, I get this error message in a tabbed window:

    "Microsoft Visual Studio is unable to load this document: To design Integration Services packages in BI Development Studio, IS has to be installed by one of these editions of SQL Server 2008: Standard, Enterprise, Developer, or Evaluation.  To install IS, run SQL Server setup and select Integration Services."

    But I do have IS installed.  I have two databases, one from the free Express Advanced edition and one from Developer edition.  SQL 2008 setup (Developer edition) shows IS installed as a shared component.  I installed the Express edition before later installing the Developer edition and had no problems.  What needs to be done here?  Help, and thanks for any help!

    I experienced this problem while running and following a video tutorial "Creating a Basic Package," from this MSDN site:

    If it helps, I have .NET 3.5 SP1 installed.
    • Moved by YiChun Chen Monday, July 13, 2009 9:34 AM SSIS issue (From:Visual Studio Setup and Installation)
    Friday, July 10, 2009 2:24 PM

All replies

  • Hi Mdoc7,

    I am moving this thread from Base "Visual Studio Setup and Installation" forum to the "SQL Server Integration Services" forum, since the issue is related to SSIS. There are more experts in the "SQL Server Integration Services" forum.

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, July 13, 2009 9:34 AM
  • We made a couple of fixes for this similar error, which allows Business Intelligence Design Studio (ie. Visual Studio with a BI Project) to be used and to run packages.

    That fix was in "Cumulative update package 4 for SQL Server 2008" 963036 

    Can you try that patch on the affected machine to see if it resolves the issue for you?

    If not, see my signature on how to open a support ticket and someone in the support team may be able to dig in deeper to build a repro and diagnose it.
    Didn't get enough help here? Submit a case with the Microsoft Customer Support team for deeper investigation -
    Tuesday, July 21, 2009 7:16 PM
  • Sorry if you get this twice Jason as I posted on SQLServerCentral to a similar thread


    I have the same problem. I know I have Integration Services installed because I have uninstalled them twice and reinstalled twice (second time trying SQL Server 2008 R2). It also appears in Services under SQL Server Integration Services 10.0 , and it is currently running. I also installed Service Pack 2 a few weeks ago. When I go to Add/Change installation features Both BIDS and Integration Services are checked and grayed out.

    Any ideas how to get this fixed other than reinstalling Windows.

    I am running Windows 7 64bit and have the following Microsoft Products installed:

    SQL Server 2000 Enterprise Manager
    SQL Server 2005 Management Studio & Integration Services & BIDS
    SQL Server 2008 R2 Management Studio & Integration Services & BIDS

    Visual Studio 2005
    Visual Studio 2008
    Visual Studio 2010

    Office 2010


    Thursday, August 19, 2010 11:23 PM
  • BIDS reports the same problem for R2 when Integration Services is already installed . . .

    "Microsoft Visual Studio is unable to load this document: To design Integration Services packages in Business Intelligence Development Studio, Integration Services has to be installed by one of these editions of SQL Server 2008 R2: Standard, Enterprise, Developer, or Evaluation.  To install Integration Services, run SQL Server setup and select Integration Services."

    . . . upgraded an instance of 2008 to 2008R2 on Windows 7/x64; both are the same edition 'developer".  Integration Services was originally a 2008 install.  R2 express was already installed at the time of the upgrade.  Haven't tried Integration Services unstall/restall over concern about existing Integration Services packages, e.g. UCP.  Repair doesn't work either, reports . . .

    "Error 1316.A network error occurred while attempting to read from the file E:\1033_ENU_LP\x64\setup\SSCERuntime-ENU-x86.msi"

    . . . that file does not exist on the official MS DVD media.

    Recommended action?

    • Edited by Mike McIver Friday, November 12, 2010 8:27 AM changed display name
    Thursday, November 11, 2010 1:10 PM
  • Took care of the latter issue by unstalling CE . . . Repair of integration services succeeds now but does not correct the former issue.
    Mike McIver
    Sunday, November 14, 2010 10:33 AM
  • Unstalled both BIDS and Integration Services and restalled but issue persists.
    Mike McIver
    Sunday, November 14, 2010 1:21 PM
  • Most likely its MSXML, which is the most common one to get damaged since it supports multiple side-by-side install and uninstalls, but doesn't repair itself during SQL reinstall.

    Try this:

    1. Manually re-register the MSXML6 Dlls on the system where you are experiencing the problem by executing the following commands at a command prompt (you need to run these commands from an Administrative Command prompt on the newer operating systems.)

    On a 32-bit machine:

    regsvr32 %windir%\system32\msxml6.dll
    regsvr32 %windir%\system32\msxml3.dll

    On a 64-bit system, reregister both the 32-bit and 64-bit Dlls:

    regsvr32 %windir%\system32\msxml6.dll
    regsvr32 %windir%\system32\msxml3.dll
    regsvr32 %windir%\SysWOW64\msxml3.dll
    regsvr32 %windir%\SysWOW64\msxml6.dll

     2. Restart the failing application. For example, if BIDS is experiencing the error, close BIDS and start it again. Test the application in the same way which generated the error noted in the symptoms section.

    3. If you are still experiencing the problem after Step 2, you may need to reinstall MSXML6 and then run Windows Update to ensure that the MSXML dlls are patched with the latest security updates. You can download MSXML6 from the following location:

    4. If that doesn't so it, you can run process monitor and see which COM class id in the registry, which dll, or which GAC Native Image or Assembly is out of wack.

    Download Process Monitor tool, and run it to monitor with filter process name = devenv.exe and examine the logs of the tool to see if registry keys are reported as NAME NOT FOUND or ACCESS DENIED.

    On another thread, they COM was out of wack:

    regsvr32 oleaut32.dll

    regsvr32 actxprxy.dll

    Thanks, Jason 

    Didn't get enough help here? Submit a case with the Microsoft Customer Support team for deeper investigation -
    Sunday, November 14, 2010 4:27 PM
  • Thank you very much for your suggestions.  While they did not resolve the issue in my case, the Process Monitor did confirm the R2 Express instance was the problem.  For whatever reason, the BIDS system checks resolved R2 Express as having been the source of the Integration Services install which it was.  However, there was apparently a disconnect in correctly updating that information when the 2008 instance was upgraded to 2008 R2.  I suppose Integration Services was not part of that upgrade hence leaving it's installation designated as that of R2 Express.

    Resolution was to unstall R2 Express, Integration Services, and BIDS then restall Integration Services and BIDS from the R2 Developer media.

    Again, thank you for helping to resolve this issue.

    Mike McIver
    Tuesday, November 16, 2010 1:57 PM
  • I would like to know how you got SQL 2K EM on the Win7 64bit system.... the install keeps kicking errors back to me.
    Tuesday, December 21, 2010 9:19 PM
  • Same procedure worked for me 2.



    Monday, August 29, 2011 12:54 PM
  • Hi Mike

    I have similar problem to yours, however, I am not sure how to un-install the Integration services and the BIDS of the R2 Express with Advanced services? I am new to SQL Server and I can't find these features in my program to uninstall them.

    Thanks in advance.


    Saturday, March 10, 2012 7:41 AM
  • I'm the originator of this thread.  I'm sorry, but it looks like I forgot this and moved on.
    Saturday, May 02, 2015 6:22 PM