SQL Server service health check failed


  • I am trying to do an in-place upgrade of the default instance of SQL Server 2000 SP4 (Standard) to SQL Server 2008 (Standard) and get to the "Upgrade rules" part of the install and it fails the SQL Server Service health check with the following error:

    "The SQL Server Service cannot be restarted, or for a clustered instance, the SQL Server resource is not online"

    I can see that it is stopping the SQL Server Agent Service and then it is stopping the SQL Server service and it is restarting the SQL Server service but it is not restarting the SQL Server agent service. Since it is succesfully restarting the SQl Server service the error seems to be misleading or is should be refering to the SQL Server Agent service which I can manually start with no problems.

    Any ideas?
    Thursday, May 07, 2009 7:23 PM


All replies

  • I am experiencing the same issue, except that I'm attempting to upgrade from SQL Server 2005 SP2, and mine is a named instance. 
    Wednesday, May 27, 2009 8:53 PM
  • I am getting the same error. PLease update if you have the solution for this.

     thnaks in advance.
    Tuesday, July 21, 2009 2:35 PM
  • As far as we can tell it MAY be a rights issue with the domain account we are using to do the install. Even though it is an administrator on the server itself it may lack some other rights that are required.

    I am on vacation right now and will not be looking at this again for a few weeks. If you find something yourself, please post it here.


    Tuesday, July 21, 2009 2:49 PM
  • Can you check event log and see if there is something interesting there?

    Balmukund Lakhani | Please mark solved if I've answered your question |
    Tuesday, July 21, 2009 3:31 PM
  • as I mentioned I am on vacation but I had checked the event log and I could see it stopping both services and starting the SQL Server service but not starting the SQL Server Agent service and there were no errors in the event log as to why.
    Tuesday, July 21, 2009 3:37 PM
  • This link has the answer that helped me:

    Basically, the account you're using to install (or the local Administrators group) needs to be granted the debug programs policy.  You can do this under the Local Security Policy program if need. be.  Be sure to log out and log back in if you do this.
    • Marked as answer by chasers213 Tuesday, January 19, 2010 2:57 PM
    Saturday, September 19, 2009 4:20 PM