none
SSIS 2014 - Error in task validation RRS feed

  • Question

  • Hi,

    I have a project in Integration Services (2014) with one master package that executes many tasks of type "Execute Package Task" that was recently upgraded from 2008 R2 to 2014.
    This project is in SSISDB Catalog and I have a job in SQL Server Agent that executes the master package with a proxy account that have Administrator access in Windows Server.
    The job execution in SQL Server Agent is intermittent, sometimes the execution fails and sometimes ends with success.
    The error reported in the SSIS Catalog Reports are:

    PS: I have already enable Verbose Logging and didn't helped trying to figured out the root cause of the problem. I also tried to enable DelayValidation in the SSIS master package and in the Package Execution Tasks and didn't solved the problem.

    Thank you!


    • Edited by FLauffer Tuesday, January 5, 2016 12:43 PM Update the image
    Tuesday, January 5, 2016 12:41 PM

All replies

  • Hi FLauffer,

    Could be because the package was instructed to run whereas the previous execution hasn't finished yet.

    The task in question is "high performance..." please take a look at what it is doing and share with us.


    Arthur

    MyBlog


    Twitter

    Tuesday, January 5, 2016 2:59 PM
    Moderator
  • First of all, thank you for reply.

    There is no such task "high performance...". It looks like a generic error from Integration Services.

    Below is a image from the Control Flow of the master package:

    Tuesday, January 5, 2016 3:06 PM
  • What do you see in "View Context", we need the component name, and can you paste the exact error message?

    I have seen I think this error now I recall. The issue could be due to a timeout validating the package. It may happen on a low spec and overloaded hardware with many remote sources/destinations


    Arthur

    MyBlog


    Twitter

    Tuesday, January 5, 2016 3:11 PM
    Moderator
  • Arthur,

    Thank you.

    There are only these messages:

    --Sequence Container:Error: Cannot create a task from XML for task "ODS_GRUPOREGRAPAGAMENTO", type "SSIS.ReplacementTask" due to error 0x80070057 "The parameter is incorrect.".
    --ODS_GRUPOREGRAPAGAMENTO:Error: Failed to load task "ODS_GRUPOREGRAPAGAMENTO", type "". The contact information for this task is "Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server v10; (C) 2007 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1".
    --ODS_GRUPOREGRAPAGAMENTO:Error: The task has failed to load. The contact information for this task is "Performs high-performance data extraction, transformation and loading;Microsoft Corporation; Microsoft SQL Server v10; (C) 2007 Microsoft Corporation; All Rights Reserved;http://www.microsoft.com/sql/support/default.asp;1".
    --ODS_GRUPOREGRAPAGAMENTO:Error: There were errors during task validation.

    Below is the tab "View Context":



    • Edited by FLauffer Tuesday, January 5, 2016 4:12 PM Update the image
    Tuesday, January 5, 2016 4:11 PM
  • There is very little reference re the error

    -Sequence Container:Error: Cannot create a task from XML for task "ODS_GRUPOREGRAPAGAMENTO", type "SSIS.ReplacementTask" due to error 0x80070057 "The parameter is incorrect.".

    So it must been something to do with the deep SSIS internals.

    I can see only a few options here:

    Either contact the Microsoft Support, or start disassembling the package until you see what task/component is responsible for throwing this error out. Then try fixing it.

    It sometimes is possible to recover by applying any missing updates.


    Arthur

    MyBlog


    Twitter

    Tuesday, January 5, 2016 6:56 PM
    Moderator
  • Thank you Arthur!

    I'm trying to solve the problem.

    When I discover the root cause of it I'll post here the solution.

    Tuesday, January 5, 2016 7:14 PM
  • I found out that the error occurs only when the proxy account is logged off of the server.

    I found out the KB3041857 of Microsoft too that have the symptom described in the error of Integration Services "Code 0x80070057 The parameter is incorrect". This KB is for our Windows Server version (2012 R2).

    https://support.microsoft.com/en-us/kb/3041857

    If anyone have some suggestion please share.


    Felipe Lauffer MCSA: SQL Server | MCP

    Thursday, January 7, 2016 12:03 PM
  • I have tried a lot of solutions and didn't find it yet.
    I have opened a possible bug in Connect:

    https://connect.microsoft.com/SQLServer/feedback/details/2219665/errors-0x80070057-and-0xc0012050-when-executing-an-ssis-2014-package-with-a-job-in-sql-server-agent-that-uses-a-proxy-account

    If I get a response or find the solution, I'll post it here again.
    Thanks for your time and help.


    Felipe Lauffer MCSA: SQL Server | MCP

    Friday, January 22, 2016 3:36 PM
  • Hey Felipe,

    I am experiencing the same issue. It's been a while since your last post, but maybe you solved it eventually? Do you remember anything about it? :)

    Tuesday, September 18, 2018 11:33 AM
  • The only way I found to resolve this issue is with a workaround removing the proxy account in the job configuration and using the SQL Server Agent account.

    Felipe Lauffer
    MCT | MCSE: Data Management & Analytics | MCSE: Data Platform | MCSA: SQL Server 2012/2014 | MCP

    [ Blog ] - [ Profile ] - [ Wiki ] - [ Gallery ] - [ LinkedIn ]


    Friday, September 28, 2018 3:13 AM