Error code = 80004002 No such Interface Supported


  • Hello All,

    Iam  getting this  Error "No such Interface Supported"   when iam trying to access multiple clients remotely to SQL Server2008Ri.

    Error Message:

    Error code = 80004002 No such Interface Supported


    * Iam able to connect one client and I can run the applliaction remotley.

    * Iam working  on VMware ESX Mahines.

    Any ideas on this problem ?

    Mahesh KJ

    • Edited by Mahesh KJ Thursday, January 03, 2013 6:16 PM
    Thursday, January 03, 2013 6:16 PM


All replies

  • Are you sure that your provider shouldn't be SQLNCLI10  instead of SQLNLI10?

    Chuck Pedretti | Magenic – North Region |

    Thursday, January 03, 2013 6:18 PM
  • Hai  Chuck  ,

    Yes it is SQLNCLI10.

     any Ideas????


    Thursday, January 03, 2013 6:55 PM
  • Hai  Chuck  ,

    Yes it is SQLNCLI10.

     any Ideas????


    My idea would be to fix your connection string - which currently says: provider=SQLNLI10;  

    Chuck Pedretti | Magenic – North Region |

    Thursday, January 03, 2013 7:06 PM
  • Sorry that was just a typo, the connection string is correct (it says SQLNCLI10).  I have installed the SQL Server native client on the client pc, but I get this error when I try to connect to the server.  Is there anything else that needs to be installed on the client in order to connect to the SQL Server instance on the server?


    Thursday, January 03, 2013 10:09 PM
  • I have a fairly simple SSIS package that runs fine locally but when I run from a command line, it runs the design time configuration for the source files, evidently because I have a ForEach File container filtering which files to load. I suppose I have to configure the ForEach container from the command line as well.

    I have a dtexec command like this, and I use this for other files with only 1 source connection and 1 sql connection, but no ForEach loop.

    dtexec /f %DTSPackageName% /Decrypt MyPassword /CONN cm_sql;%cm_sql_USTG% /CONN ffs_raw_file;%SourceFullFilePath% /CONN cm_ffs_FooterFinder;%SourceFullFilePath%

    SourceFullFilePathMasked is in the format "C:\Test\MyFileName1.txt" and I have tried "C:\Test\MyFileName*.txt" since there are other files, such as "C:\Test\MyFileName2.txt", etc.

    cm_sql is a standard sql connection string and works fine as data does go into the table.

    The problem is it is ignoring the ffs_raw_file connection, but it only does this when I have a ForEachFile loop container. Evidently I have to configure that, too. How can I do that?

    • Merged by Eileen Zhao Wednesday, January 23, 2013 8:49 AM duplicate
    Wednesday, January 09, 2013 7:32 PM
  • Do you have a config file?

    Thing is if you run it from command line it does not work as well as running [from Agent?] then the package does not get the config applied, and you supposed to see a warning about this nuance.

    Please also provide the version of SSIS build used as in SSIS 2008 design time settings get re-applied.

    Arthur My Blog

    Thursday, January 10, 2013 8:13 PM
  • Thank you for your reply. I forgot to say that I do not have a config file. They don't really want that. We only have these 2 or 3 connections we want to configure right from the command line.
    Thursday, January 10, 2013 8:21 PM
  • duplicate post :

    Please mark the post as answered if it answers your question | My SSIS Blog: | Twitter

    Friday, January 11, 2013 6:54 AM
  • Hi Mahesh KJ,

    SQL Server Native Client requires Windows Installer 3.0. Windows Installer 3.0 is already installed on Microsoft Windows operating systems. For all other platforms you need to explicitly install it. For more information, see Windows Installer 3.0 Redistributable

    For more information about it, please see:
    System Requirements for SQL Server 2008 Native Client:


    If you have any feedback on our support, please click here

    Eileen Zhao
    TechNet Community Support

    • Marked as answer by Eileen Zhao Wednesday, January 30, 2013 8:24 AM
    Wednesday, January 23, 2013 9:11 AM