none
How to determine cause of "The permissions granted to user 'domain\user' are insufficient for performing this operation. (rsAccessDenied) " RRS feed

  • Question

  • I have been reading about this problem almost non-stop for 2+ days, and trying every suggested "fix", and none work. Clearly, the approach of "change this and see if it fixes the problem" is not working (as it rarely does for black-box problems with many variables).

    So rather than experimenting endlessly with changes to the configuration, how can I determine the underlying cause? In other words, "breakpoint" at the point of the exception in order to determine what specific permission is insufficient to access which specific resource.  

    Given this entry in the log:

    library!ReportServer_0-2!2798!08/09/2012-08:32:07:: Call to GetItemTypeAction(/).
    library!ReportServer_0-2!2798!08/09/2012-08:32:07:: e ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException: ,  Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException: The permissions granted to user 'domain\user' are insufficient for performing this operation.;

    ... how do I determine what GetItemTypeAction is complaining about????

    DC 

    Thursday, August 9, 2012 1:50 PM

Answers

  • I too had this issue. Here is how I solved it.

    1. Go to User Account Control in your control panel and turn it off (requires reboot)
    2. Log into reporting services using IE because if your IE is set up right you don't have to enter your UN/PWD http://localhost/Reports unless it is somewhere else or you have an instance of the report server
    3. Go to site settings at the top right and find the security roles. Add yourself to all roles
    4. Go back to Home (top left link)
    5. Go to the folders link on the toolbar
    6. Under security settings add the same so you can have access to all of the report folders
    7. Go to "C:\Program Files\Microsoft Sql Server\<<Report Server Folder>>" and provide the required permissions for yourself (If you don't do this then you can't do the next step) that way even when you are not running as an admin you can still get to the reports
    8. Set UAC back (if you want) to medium so you don't have to worry about it too much (Reboot)

    That should get it for you.

    • Proposed as answer by Edward Zhu Monday, August 13, 2012 1:24 AM
    • Marked as answer by Edward Zhu Thursday, August 16, 2012 8:59 AM
    Friday, August 10, 2012 1:53 PM

All replies

  • Hi,

    Can you check a couple of things:

    1. Please check the role this user is assigned for this particular report.

    2. Can you please post the screen shot of the data source being used by that report?


    Shahfaisal Muhammed http://shahfaisalmuhammed.blogspot.com

    Thursday, August 9, 2012 3:33 PM
    Moderator
  • The error occurs just after I have installed SSRS... there are not yet any reports or users (unless the install pre-loads some???).

    I am trying to install SSRS in order to learn it. I'm installing it on Windows 7 Ultimate SP1.  This computer is not part of a domain.

    The error occurs on Reporting Services Configuration Manager - Web Service URL panel just after I've done the initial configuration...

    I click the URL that's listed (http://[mycomputername]:80/ReportServer) and enter my local userid and password (which is a local Administrator of my computer), and I get the error. And clicking the URL on the Report Manager URL (http://[mycomputername]:80/Reports) gets the same error.

    I have tried installing both SQL Server 2008 R2 Express with Advanced Services and also SQL Server 2008 R2 Developer. Both fail with the same error.

    I watched as another developer installed and configured SQL Server 2008 R2 Developer with Reporting Services on his Window 7 system, and it worked OK on his.

    But after yet another clean re-install on my system - following exactly the same steps that he followed (and documented) - mine still fails!

    DC

       

    Thursday, August 9, 2012 4:03 PM
  • Hi,

    Can you run the internet explorer with "Run as administrator"  and then try to run the url.

    To run the IE in "Run as adminisrtrator mode", Right click the IE Icon and click "Run as administrator".

    If the url  (http://[mycomputername]:80/Reports)  work fine, then please add your local user to the role setting for report manager.

    Regards

    Harsh

    Thursday, August 9, 2012 4:26 PM
  • I've already tried running IE9 as administrator. Doesn't help.

    As I said in the post, I've been trying everything I've read about this problem on MSDN and StackOverflow for a couple of days.

    How can I determine the underlying cause?

    DC

    Thursday, August 9, 2012 6:56 PM
  • Greetings DadCat,

    From my experiance this error mostly occures if the executing user doesnt have rights to a physical folder or object.
    So you can ask yourself the next questions:

    Which user is the SQL-reporting service account?
     - Does this user have rights on the SSRS-folder?
    Do you use images or (external) files in the report?
     - Are these accessable if you browse them as the executing user?


    Friday, August 10, 2012 7:25 AM
  • I too had this issue. Here is how I solved it.

    1. Go to User Account Control in your control panel and turn it off (requires reboot)
    2. Log into reporting services using IE because if your IE is set up right you don't have to enter your UN/PWD http://localhost/Reports unless it is somewhere else or you have an instance of the report server
    3. Go to site settings at the top right and find the security roles. Add yourself to all roles
    4. Go back to Home (top left link)
    5. Go to the folders link on the toolbar
    6. Under security settings add the same so you can have access to all of the report folders
    7. Go to "C:\Program Files\Microsoft Sql Server\<<Report Server Folder>>" and provide the required permissions for yourself (If you don't do this then you can't do the next step) that way even when you are not running as an admin you can still get to the reports
    8. Set UAC back (if you want) to medium so you don't have to worry about it too much (Reboot)

    That should get it for you.

    • Proposed as answer by Edward Zhu Monday, August 13, 2012 1:24 AM
    • Marked as answer by Edward Zhu Thursday, August 16, 2012 8:59 AM
    Friday, August 10, 2012 1:53 PM
  • This worked for me. Thanks.
    Sunday, September 15, 2013 7:02 PM
  • In my case adding the [Domain\User] to Administrators, IISUser local groups resolved my Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException: The permissions granted to user '[Domain\User]' are insufficient for performing this operation

    • Proposed as answer by Feorentian Thursday, September 20, 2018 12:53 PM
    Thursday, September 20, 2018 12:52 PM
  • Hi,

    I get the same problem, but put someone in the local administrator group is not the best solution I think.

    We had 2 domains, could this be a kind of problem?

    With Kind regards,

    Andreas

    Wednesday, January 9, 2019 10:46 AM
  • Hi,

    In our case it solved this issue to add the specific user to the "Site settings" of the SQL Reporting Services "webpage".

    regards,

    Ivo

    Saturday, February 2, 2019 1:18 PM