none
New install of SQL Server 2012 x64 Express on Windows 2008 Server, keep getting error when using Management Studio? RRS feed

  • Question

  • After installing the x64 with all tools excluding the SDK from the SQL Express Edition, I go to Management Studio, log in and get the error when I click under the Instance name- Databases...Have reinstalled many times, removed all directories and registry keys from both HKEYs(regular and Wow6432Node) before rebooting and reinstalling. No VS installed on this computer..put it looks like it installed "MS Visual Studio 2010 Shell (Isolated)-ENU" and "Visual Studio 2010 Prerequisites".....tried working past the error, it just hangs the Studio after it tries to add things...HELP..PLEASE!!!

    Object reference not set to an instance of an object. (Microsoft.VisualStudio.Platform.WindowManagement)

    ----------------------------

    Program Location:


       at Microsoft.VisualStudio.Platform.WindowManagement.DocumentObjectSite.QueryService(Guid& guidService, Guid& riid, IntPtr& ppvObject)
       at Microsoft.VisualStudio.Shell.ServiceProvider.GetService(Guid guid, Type serviceType)
       at Microsoft.VisualStudio.Shell.ServiceProvider.GetService(Type serviceType)
       at Microsoft.VisualStudio.Shell.WindowPane.GetService(Type serviceType)
       at Microsoft.SqlServer.Management.SqlStudio.Explorer.ObjectExplorerToolWindow.GetService(Type serviceType)
       at Microsoft.VisualStudio.Shell.WindowPane.System.IServiceProvider.GetService(Type serviceType)
       at System.ComponentModel.Design.ServiceContainer.GetService(Type serviceType)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.ObjectExplorerControl.GetService(Type serviceType)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.ObjectExplorerControl.System.IServiceProvider.GetService(Type serviceType)
       at System.ComponentModel.Design.ServiceContainer.GetService(Type serviceType)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItem.GetService(Type serviceType)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NodeContext.GetService(Type serviceType)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItemBuilder.<GetColumnsFromNavigationService>d__11.MoveNext()
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItemBuilder.AddFields(List`1 list, IEnumerable`1 fields, IDictionary`2 allValidFields, AddFieldsFlags flags)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItemBuilder.GetParentFields(INodeInformation source, Dictionary`2& allValidColumns)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItemBuilder.BuildDynamicItemWithQuery(IList`1 nodes, INodeInformation source, INavigableItem sourceItem, String urnQuery, Boolean registerBuilder, Boolean registerBuiltItems)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItemBuilder.BuildDynamicItem(IList`1 nodes, INodeInformation source, INavigableItem sourceItem, IFilterProvider filter)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItemBuilder.Build(IList`1 nodes, INodeInformation source, INavigableItem sourceItem, IFilterProvider filter)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.NavigableItem.RequestChildren(IGetChildrenRequest request)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.ExplorerHierarchyNode.BuildChildren(WaitHandle quitEvent)

    Monday, July 9, 2012 5:13 PM

Answers

All replies

  • Hello,

    Please see the following thread:

    http://social.msdn.microsoft.com/Forums/en-US/sqlsetupandupgrade/thread/aeff13b3-3960-4724-bb9a-7e585651d7f4

    Hope this helps.

    Regards,
    Alberto Morillo
    SQLCoffee.com

    Monday, July 9, 2012 5:58 PM
    Moderator
  • Thanks, but deleting that key and rebooting didn't help. I also read in that thread that installing Visual Studio 2010 SP1 would help and it didn't? Any other ideas?
    Monday, July 9, 2012 6:32 PM
  • Hello,

    Try installing the following and then applying SP1 for Visual Studio.

    http://www.microsoft.com/en-us/download/details.aspx?id=1366

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    Monday, July 9, 2012 6:51 PM
    Moderator
  • Hi igorteper,

    Any progress?

    "MS Visual Studio 2010 Shell (Isolated)-ENU" and "Visual Studio 2010 Prerequisites" had been installed in your computer, or there is no Visual Studio installed on this computer?

    You log in SQL Server Management Studio and get an error. For further investigation the issue, please post the error messages in detail.

    TechNet Subscriber Support
    If you are
    TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Thanks,
    Maggie

     


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. This can be beneficial to other community members reading the thread.

    Tuesday, July 10, 2012 6:54 AM
    Moderator
  • Hi,

    I'm also getting the same error as soon as I connect to SQL Server or try to expand any object (Databases, Security, etc.). Please help.

    Friday, January 31, 2014 3:00 PM
  • The solution is

    unregister and register ieproxyy.dll and actxprxy.dll (regsvr32 /u ieproxy.dll, regsvr32 ieproxy.dll, regsvr32 /u actxprxy.dll, regsvr32 actxprxy.dll) from C:\Program Files\Internet Explorer, C:\Program Files (x86)\Internet Explorer, C:\WINDOWS\system32, C:\Windows\SysWOW64. And also, if those doesn't helps, reinstall internet explorer, run ccleaner and fix registry errors, and search and deregister all ieproxyy.dlls and actxprxy.dlls from machine as well as from registry. It should work :)

    Thursday, September 8, 2016 3:54 PM