none
Fatal Error 615 with DROP RRS feed

  • Question

  • I'm new to SQL, and I've been working through the fantastic 'Joes2Pros Vol 1 SQL Queries' tutorial book and finally got myself stuck in Chapter 10 (just 2 chapeters to go!).
     

    With SQL Express 2012 SP2 on my Win7 laptop, I created a new SQL user "Sara", granted her control server access, set the server to allow SQL logins, and quit SSMS. I re-opened SSMS, logged in as Sara, and created a new database called dbSara. I then tried to drop dbSara, and got Fatal Error 615.

     Technet shows #615 is "Could not find database table ID %d, name '%.*ls'."

    Symbol Meaning
    %d, %ld, or %D Decimal integer
    %x Hexadecimal number
    %ls or %.*ls Character string

    The funny thing is this is an empty db with no tables. I can drop it just fine when I'm logged in as a Windows user.

    Sara is the db owner. When I look under login properties, she has 'public' server role checked off only. Under Securables, there are two entries (rows) for Connect SQL and Control server. Is this normal?

    Sara has Connect SQL and Control Server granted, for the 2nd row of each. My login (sa) has the 2nd row of Connect SQL checked, for what that's worth <shrug>.

    I'm stumped. It's frustrating when you get stuck in a tutorial! Any ideas?  Thank you very much for help & guidance.

    Tuesday, October 14, 2014 3:03 PM

Answers

All replies

  • and got Fatal Error 615.

     Technet shows #615 is "Could not find database table ID %d, name '%.*ls'."

    The exact error message for error 615 is:
    Could not find database ID <Name>. The database may be offline. Wait a few minutes and try again.

    The database was not found by the used name; have you used the right database Name? Is the database online; a offline database has a different Icon in SSMS object Explorer.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Tuesday, October 14, 2014 3:08 PM
    Moderator
  • Olaf,

     Thanks for the reply. The db is online (called dbSara). I refreshed the databases, and it appears with the same gold cylinder icon as the rest (including master).

      I tried again by logging in as SQL user Sara, created dbSaraII, and tried to drop it, with the same #615 error. I log in as myself, and was able to drop it.

    Using SSMS Object Explorer, I tried deleting the database while logged in as Sara, with the same result. It seems like Sara doesn't have true Control Server permissions.

    Tuesday, October 14, 2014 5:30 PM
  • Resolved, courtesy of Robert at Spiceworks at http://community.spiceworks.com/topic/604682-fatal-error-615-with-drop?page=1#entry-3897223

    I followed (http://sqlmag.com/blog/worst-practice-allowing-autoclose-sql-server-databases), found autoclose was set to True, changed it to False, and was able to drop dbSara when logged in as Sara. No idea why it’d be set as True by default when creating new db’s. I didn’t do anything besides the tutorial steps <shrug>.

    Anyways, if someone else has this same issue, have them change autoclose to False on dbSara.

    Tuesday, October 14, 2014 6:08 PM
  • No idea why it’d be set as True by default when creating new db’s.

    That' unfortunatly the default in SQL Server Express Edition.

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Wednesday, October 15, 2014 6:43 AM
    Moderator
  • Olaf,

     Thanks for your help. I'm sure there are a ton of these little details I'll learn first hand.

    Wednesday, October 15, 2014 12:23 PM