none
Maintenance plan for DB backup failed with the error : 64(The specified network name is no longer available.).

    Question

  • Hi
           I have a maintenance plan for taking the bakup of a database. Size of the database is "5 GB". The maintenance plan was working fine last month. But it is currently failing each day with the following error

    Executing the query "BACKUP DATABASE [Projcom] TO  DISK = N'\\\\aaa102252net\\MHA102963$\\DailyBackup\\ComDB_Backup\\Com_backup_200910292345.bak' WITH NOFORMAT, NOINIT,  NAME = N'Com_backup_20091029234523', SKIP, REWIND, NOUNLOAD,  STATS = 10
    " failed with the following error: "A nonrecoverable I/O error occurred on file "\\\\aaa102252net\\MHA102963$\\DailyBackup\\ComDB_Backup\\Com_backup_200910292345.bak:" 64(The specified network name is no longer available.).
    BACKUP DATABASE is terminating abnormally.
    10 percent processed.
    20 percent processed.
    30 percent processed.
    40 percent processed.
    50 percent processed.
    60 percent processed.
    70 percent processed.
    80 percent processed.
    90 percent processed.
    Processed 467824 pages for database 'Projcom', file 'Projcom' on file 1.
    100 percent processed.
    Processed 6 pages for database 'Projcom', file 'Projcom_log' on file 1.". Possible failure reasons: Problems with the query, "ResultSet" property not set correctly, parameters not set correctly, or connection not established correctly.

    But I am getting the bakup file. For Info there is no change in the n/w setting. We have applied the regular hotfixed released from MS.
    I have searched the net for the solution, MS has proposed for some hotfixes. My question is how it was working before, and how i am getting the backup file with the backup failure message. Can I rely upon the backup file I am getting ??

    Friday, October 30, 2009 5:10 AM

Answers

  • Hi,

    Based on my experience, you could check particular registry key SESSTIMEOUT in:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters.
    If this key is not available, you need to add the SESSTIMEOUT key and give the value 360.

    For more information about SESSTIMEOUT key, please see http://support.microsoft.com/?id=102067


    If there are any more questions, please let me know.
    Thanks.


    ***Xiao Min Tan***Microsoft Online Community***
    Wednesday, November 4, 2009 8:48 AM
    Moderator

All replies

  • Check

    first that you do have sufficient disk space avialable for the backup.

    Secondly, access the backup location from the server is it successful?

    Third, Run the same command from Query Analyzer in SSMS.

    HTH

    Friday, October 30, 2009 5:44 AM
  • Thanks

    for the reply

    I have verified

    all the things before.
    The Disk has sufficient space.
    I can able to access the backup location from the server.
    If I am running the backup manually it is creating the backup file without any error.

    Please check my points in the last post. The server is creating the bakup file with the error message.
    If I am restoring the backup file it is working.

     

     

    Friday, October 30, 2009 6:11 AM
  • humm... looks strange.

    is it possible for you to run DBCC CHECKDB (Projcom)  ???

    RUN ONLY IF YOUR SERVER IS NOT PRODUCTION ELSE RUN DURING OFF PEACK HRS.

    Friday, October 30, 2009 6:24 AM
  • My guess is that it is the verification (RESTORE VERIFYONLY) which causes the failure - not the backup command (these are two semarate commands). Try unchecking the verify to diagnose. Perhaps some AV program kicks in so that the verification can't get to the backup file?
    Tibor Karaszi, SQL Server MVP http://www.karaszi.com/sqlserver/default.asp http://sqlblog.com/blogs/tibor_karaszi
    Friday, October 30, 2009 7:09 AM
    Moderator
  • Thanks Tibork

    Yes In the backup Maintenance plan the "Verify integity" of the backup file was ticked.
    I have unticked it. So when it will run next time I will come to know abt the status.

    Friday, October 30, 2009 8:16 AM
  • Hi Tibrok
             I uncheck the Verify integity" check box on friday. But the maintenance plan failed for the friday, saturday and sunday with the same message.

    So If there is any other options to stop this error from further happending, Please suggest.
    Monday, November 2, 2009 4:13 AM
  • Hi Tapas,

    Are you taking the backup on share location or locally? If you are taking backup on shared location what’s the version of OS on which your shared file exist.

    And also check the configuration of antivirus and make sure that shared location are excluded from antivirus.

    If your shared location on Windows Server 2008 than there is issue with network packet drop, please update it with SP2.


    Nandan Pandey
    Monday, November 2, 2009 6:21 AM
  • Hi,

    Based on my experience, you could check particular registry key SESSTIMEOUT in:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters.
    If this key is not available, you need to add the SESSTIMEOUT key and give the value 360.

    For more information about SESSTIMEOUT key, please see http://support.microsoft.com/?id=102067


    If there are any more questions, please let me know.
    Thanks.


    ***Xiao Min Tan***Microsoft Online Community***
    Wednesday, November 4, 2009 8:48 AM
    Moderator
  • I have had a similar situation with a backup copy failing part way through; I ended up just altering the schedule and this resolved the problem.

    One way to test is to set up another backup regime to backup a couple of the system databases; apply one schedule to run late afternoon and the other to run at the same time as when the problem occurs; if the first backup succeeds and the second one fails then this would indicate an error with the destination Server (perhaps somebody has set up a scheduled reboot or failover?).
     

    Tony C
    Wednesday, November 4, 2009 4:28 PM
  • Hi,

    Based on my experience, you could check particular registry key SESSTIMEOUT in:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters.
    If this key is not available, you need to add the SESSTIMEOUT key and give the value 360.

    For more information about SESSTIMEOUT key, please see http://support.microsoft.com/?id=102067

    Just a small addition here if putting SESSIONTIMEOUT value as 360 does not works make it 600 i.e 10 mins, it would work.

    Cheers,

    Shashank

    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it

    My TechNet Wiki Articles

    MVP

    Thursday, June 2, 2016 4:06 AM
    Moderator