none
Error Migrating Access Table to Azure SQL Database RRS feed

  • Question

  • I have databases that were built in:

    Microsoft Access 365 ProPlus (64Bit V1808 Build 10730.20348 Click-to-Run)

    I am trying to migrate them to my (confirmed is working) Azure SQL Server using SQL Server Migration Assistant for Access v8.2.0 64bit

    Everytime I try it, it errors when adding a .accdb database and says, "The database you are trying to open requires a newer version of Access"

    I have tried most eveything to get this to work.  Have tried multiple versions of the runtime engines, currently have 2010 installed.  (2013 installed but same error, 2016 did not install due to incompatibility with click to run access.)

    Any help would be greatly appreciated.

    Thank you,

    Monday, June 24, 2019 8:27 PM

All replies

  • Hi TbDcEn,

    >> The database you are trying to open requires a newer version of Access"

    This issue occurs if you try to open a database that contains a table that uses the BigInt data type. BigInt support was added to Access 2016. BigInt appears within the table's data type as Large Number.

    To resolve this issue, determine whether the use of BigInt is required. If so, update users to Access 2016 version 16.0.7xxx.xxxx or later. Alternatively, change the data type from Large Number to just Number.

    Note Create a backup of your database before you change the data type. If there is Large Number data in a column when you change the data type to Number, you receive a "Microsoft Access encountered errors while converting the data" dialog box. If you click Yes to proceed, the records that contain large numbers are deleted.

    Hope this could help you.

    Best regards,
    Cathy 

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, June 25, 2019 2:53 AM
  • Thank you for your reply.

    The database I have been trialing with only has 4 Data Types across 33 Columns. (AutoNumber,Short Text, Number, Currency) And includes a primary key on a unique value field.

    I went ahead and started trying different databases I had and the others worked!  

    It must have been this specific database that has the issue.  Fortunately, I can easily recreate it.

    Thank you.

    Tuesday, June 25, 2019 2:02 PM
  • Hi,

    Did you can open the database after you recreated it?

    Thursday, June 27, 2019 9:10 AM