none
Microsoft Edge browser to use SSRS in Native Mode RRS feed

  • Question

  • How can you configure SQL Server Reporting Services to be able to run in the Microsoft Edge browser on a local server if you cannot establish a trusted site for the local server?
    Friday, August 28, 2015 7:36 PM

All replies

  • Do you need to use the Edge browser, can you use Internet Explorer 11, which is installed with Windows 10?
    Friday, August 28, 2015 7:40 PM
  • Of course I can but if Microsoft is promoting the Edge browser as the future with the intent of phasing out IE, then there needs to be a solution to the problem that you cannot have trusted sites in Edge otherwise the environment is useless to the business environment.

    Microsoft cannot expect to protect everyone and maintain functionality for those working in an advanced environment.

    If there is no solution then the Edge browser is useless to the future of the Internet for the business user.  SSRS will play a major role and is another fine product in the SQL environment.  How can Microsoft promote a product as a cutting edge web browser if it cannot support one of it's own very successful products?

    Friday, August 28, 2015 8:45 PM
  • Hi DevlnCal, 

    According to your description, you cannot open Report Manager in Microsoft Edge browser, right? 

    In our local environment, we have tested this scenario and the Reporting Services report can work properly in Edge browser. In your scenario, when opening Report Manager in Edge browser, have you received any error message? If have, please post the error message or image. And Reporting Services can work properly in other browser without no issue? 

    If you have any other question, please feel free to ask. 

    Regards,
    Shrek Li

    Monday, August 31, 2015 7:37 AM
    Moderator
  • In the line below I am using zzzz instead of http because you can't post a link.  In place of server is my server name.

    When I type in the url in Microsoft Edge zzzz://<server>/reports  the browser returns:

    Hmmm, we can't reach this page.

    Try this:

    Make sure you've got the right url  http://<server>

    Refresh the page

    Search for what you want.

    When I type in exactly the same address in Internet Explorer where I have established my server as a trusted website it goes to my reports.

    Do I need to configure SSRS with a SSL, and if so how do I do that?

    Is there something else that I am missing?

    Monday, August 31, 2015 5:24 PM
  • This is assuming by local server you are referring to having SSRS installed on the machine with the Edge browser, otherwise disregard....

    What if instead of using the server name you use localhost or 127.0.0.1 (i.e., "http://localhost/reports" or "http://127.0.0.1/reports" or even "http://<The IP Address>/reports?

    some other things to consider...

    Do you need to configure the BackConnectionHostNames or try and disable the loopback check?  These things you can put in and reverse pretty easily...

    https://support.microsoft.com/en-us/kb/896861#/en-us/kb/896861

    https://technet.microsoft.com/en-us/library/cc281307.aspx

    The information in the links might seem unrelated, but i've had to use them before...


    • Edited by JJordheim Monday, August 31, 2015 5:43 PM
    Monday, August 31, 2015 5:42 PM
  • Now we are making some progress!

    When I used localhost I got exactly the same response as when I used the server name.

    When I used the IP Address, I received the following response:

    SQL Server Reporting Services Error:

    User <server>\<username> does not have required permissions.  Verify that sufficient permissions have been granted and Windows User Account Control (UAC) restrictions have been addressed.

    The user logged in is myself where I am the system administrator.

    Any help please?  Thank you!

    Monday, August 31, 2015 5:59 PM
  • By the way when I used the IP address before it gave me the message described above the browser asked me for credentials.
    Monday, August 31, 2015 6:07 PM
  • By default the account(s) granted "system administrator"/"content manager" in SSRS are those users that are in the builtin\administrators group.  This would be the users that are local administrators on the computer.

    Here are a couple things to try.  Run the Edge browser as an administrator, if you get in, explicitly add the account as content manager and system administrator in system settings and folder settings.  Otherwise, attempt this with Internet Explorer and get logged in and do the same.  By adding your account explicitly the system will not need to interrogate that group to determine membership.

    Monday, August 31, 2015 7:09 PM
  • I don't think you can run the edge browser as administrator.

    Through IE I have already added my user account in system settings as system administrator and in folder settings as content manager.

    This problem still exists in the edge browser but not in IE.

    Monday, August 31, 2015 7:19 PM
  • Give this a try...

    http://www.virtualizationhowto.com/2015/07/windows-10-edge-opened-builtin-administrator-account/

    It would appear that as Edge is a universal app and runs in super protected mode, it's attempting to prevent you from harm...

    Monday, August 31, 2015 7:40 PM
  • This did not change anything I still get the same messages.
    Monday, August 31, 2015 8:16 PM
  • Any resolution on this? I see it is dated over a year ago. I'm just now spinning up SQL 2014 Reporting Services on my local development machine. I too needed to launch IE as an Administrator, then add myself as a System Administrator on the site and Content Manager on the root folder.

    Using IE, I can browse to and get access to the Reports folder.

    Using Edge, after supplying my credentials, I get the message that I do not have required permissions.

    FYI I am running Windows 10 with the recently released Anniversary Update.


    Todd C - MCSE SQL Server Business Intelligence MCITP BI Dev 2008 MSCTS SQL Server 2005 Please mark posts as answered where appropriate.

    Friday, October 14, 2016 3:40 PM
  • Hi all,

    Has this issue resolved? I have similar problem, already give access from IE, and it looks fine over there. But in Edge browser, it still give me error "User "xxx" does not have required permissions. Verify that sufficient permissions have been granted and Windows User Account Control (UAC) restrictions have been addressed."

    Thanks,

    Ton

    Sunday, April 16, 2017 2:11 AM
  • This works in the latest insider builds/skip ahead. 17692  Hopefully it will soon be supported for all.

    Monday, June 18, 2018 5:56 PM