none
Processing a model in VS Failing because it's not using the impersonated account? RRS feed

  • Question

  • As per title - I'm trying to process a model but its' giving me an authorization failure. I do not have access to the system / data set but the impersonated account I am using does so there should be no issue?

    Am I not understanding the use of Impersonated Accounts properly?

    This is the specific error:

    An attempt to Process the data model which calls a connection to WIMS fails for me with the following error:
    Failed to save modifications to the server. Error returned: 'The remote server returned an error: (401) Unauthorized.. The exception was raised by the IDbConnection interface.
    A connection could not be made to the data source with the Name of 'WIMS OData'.


    Thursday, January 23, 2020 9:49 PM

All replies

  • Hi TroyB1,

    Welcome to MSDN forum.

    Could you tell me what model you use? Tabular or Multidimensional models?

    In addition, for Tabular model, please have a look at this link to sign in credentials when processing data.

    It is noted that the account need to have user access rights on the server, you could refer to this link to set impersonation option.

    BTW, considering your issue is about SSAS and our forum is to discuss the Visual Studio IDE issue. If the issue still persists, I recommend you restart a new thread to ask in the SSAS forum for a more professional help.

    If you have any other Visual Studio General Questions issue in the future, please feel free to let us know.

    Thanks for your understanding.

    Best Regards,

    Anna 

    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, January 24, 2020 8:35 AM