none
Access Denied to SQL Replication Snapshot folder

    Question

  •  I have a SQL server 2008 installed, Transactional(PULL) Replication has been implemented der,everthng was working fine but suddenly snapshots are failing to generate.When I execute the snapshot agent it shows me error that,

    Access to the path 'path of a snapshot folder' is denied.

    snapshot folder is shared to everyone with all securities,I can access the path through run.Folder is shared to SQL agent and main SQL service.

    ANY HELP........?

    Thursday, December 06, 2012 11:59 AM

Answers

  • There are two parts to this - the share must be shared to the account which is doing the pulling - apparently you are using the everyone group. This group must have at least read access to the share.

    Then the account you are using must have folder rights to read and list files and folders permissions to the folder which underlies the share. So grant this right also to the everyone group. To do this right click on the folder using file explorer and select Properties and Security, then ensure that for the Everyone account you have checked List Folders and Contents, and Read. You may need to click on the Advanced button and select Edit and then do the same thing and ensure that the Replace all child objects... check box is checked.


    looking for a book on SQL Server 2008 Administration? http://www.amazon.com/Microsoft-Server-2008-Management-Administration/dp/067233044X looking for a book on SQL Server 2008 Full-Text Search? http://www.amazon.com/Pro-Full-Text-Search-Server-2008/dp/1430215941

    Thursday, December 06, 2012 12:35 PM
    Moderator

All replies

  • There are two parts to this - the share must be shared to the account which is doing the pulling - apparently you are using the everyone group. This group must have at least read access to the share.

    Then the account you are using must have folder rights to read and list files and folders permissions to the folder which underlies the share. So grant this right also to the everyone group. To do this right click on the folder using file explorer and select Properties and Security, then ensure that for the Everyone account you have checked List Folders and Contents, and Read. You may need to click on the Advanced button and select Edit and then do the same thing and ensure that the Replace all child objects... check box is checked.


    looking for a book on SQL Server 2008 Administration? http://www.amazon.com/Microsoft-Server-2008-Management-Administration/dp/067233044X looking for a book on SQL Server 2008 Full-Text Search? http://www.amazon.com/Pro-Full-Text-Search-Server-2008/dp/1430215941

    Thursday, December 06, 2012 12:35 PM
    Moderator
  • ISSUE RESOLVED------

     Sharing and Security was not an issue....just a SQL service restart is solved my problem.I dont know the root cause bt may be impact was depend on restart.

    Friday, December 14, 2012 4:55 AM
  • Hi Hilary,

    Thanks for this tip. For me, permissions was the issue. I finally had to share my snapshot folder, assigning the necessary permissions.

    However, what you explained wasn't quite clear, it did confuse me at first. All the same, thank you.

    Arthur...



    Wednesday, November 13, 2013 8:56 AM
  • Hi Q_SQL,

    I tried, like you did, to restart SQL SERVICE, yet my issue wasn't resolved. In all, SHARING, SECURITY AND PERMISSIONS was the issue. Cheers...

    Arthur...


    Wednesday, November 13, 2013 8:59 AM
  • Are you using push or pull subscriptions? Did you enable auditing on that folder to see what account is being used to access it and what it is trying to do?

    An easy way to determine if security is the issue is to grant the everyone group to list files and folders and read permissions to the folder and read access to the share.

    If this works it is truly a security problem. If it does not there is another problem masquerading as a security problem.


    looking for a book on SQL Server 2008 Administration? http://www.amazon.com/Microsoft-Server-2008-Management-Administration/dp/067233044X looking for a book on SQL Server 2008 Full-Text Search? http://www.amazon.com/Pro-Full-Text-Search-Server-2008/dp/1430215941

    Wednesday, November 13, 2013 12:41 PM
    Moderator
  • Hi Hilary,

    I was using a pull subscription.  I didn't enable auditing on the folder, but when I granted the Everyone Group READ and WRITE permissions to the Snapshot folder, the issue was resolved.


    --Arthur--

    Tuesday, November 19, 2013 12:42 PM
  • " was using a pull subscription.  I didn't enable auditing on the folder, but when I granted the Everyone Group READ and WRITE permissions to the Snapshot folder, the issue was resolved." 

    Same with me.

    Tuesday, April 26, 2016 10:23 AM
  • All you should require is read permission on the share, and read files and list folder contents on the folder which underlies the share. They everyone group is a quick fix but may be a security risk. You should give the account the subscriber is using to connect to the snapshot share the read permission on the share, and list folder contents and read files on the physical folder.

    looking for a book on SQL Server 2008 Administration? http://www.amazon.com/Microsoft-Server-2008-Management-Administration/dp/067233044X looking for a book on SQL Server 2008 Full-Text Search? http://www.amazon.com/Pro-Full-Text-Search-Server-2008/dp/1430215941

    Tuesday, April 26, 2016 1:39 PM
    Moderator