none
Unable to Install SQL Server Management Studio 2017 (v17.7), Fatal Error (0x80070643) RRS feed

  • Question

  • I have a problem installing SQL Server Management Studio 2017 version on my new Dell laptop running Windows 10. It's pretty much the same problem as reported prevously here. I tried the suggested solutions in that thread that had worked for others (including deinstalling Visual Studio and .NET and running chkdsk /F /R as suggested) but I get the same error back all the time when it is time to install "Microsoft Visual Studio 2015 Shell (Isolated)" in this setup. The installation just hangs there for a while and then everything is rolled back with a Fatal Error exception message 0x80070643. Here is the same snippet of error message as reported in prevoiously by others for previous version of this software as shown in the log file:

    [07A4:2198][2018-06-05T16:48:21]e000: Error 0x80070643: Process returned error: 0x643
    [07A4:2198][2018-06-05T16:48:21]e000: Error 0x80070643: Failed to execute EXE package.
    [3F1C:2EE8][2018-06-05T16:48:21]e000: Error 0x80070643: Failed to configure per-machine EXE package.
    [3F1C:2EE8][2018-06-05T16:48:21]i000: MainViewModel.OnPackageAction: Install Completed for package Microsoft Visual Studio 2015 Shell (Isolated)
    [3F1C:2EE8][2018-06-05T16:48:21]i319: Applied execute package: VS2015IsoShell, result: 0x80070643, restart: None
    [3F1C:2EE8][2018-06-05T16:48:21]e000: Error 0x80070643: Failed to execute EXE package.
    [07A4:2198][2018-06-05T16:48:21]i351: Removing cached package: VS2015IsoShell, from path: C:\ProgramData\Package Cache\FE948F0DAB52EB8CB5A740A77D8934B9E1A8E301\
    [07A4:2198][2018-06-05T16:48:21]i326: Removed dependency: {a4f19bdb-56d9-4fe3-8139-f4b0ffe2b9f7} on package provider: {D17B5D3D-3BC7-4AFA-AD90-600B5453826E}, package sql_common_core_loc_x86
    [3F1C:2EE8][2018-06-05T16:48:21]i000: MainViewModel.OnPackageAction: Install Started for package SQL Server 2017 Common Files
    [07A4:2198][2018-06-05T16:48:21]i301: Applying rollback package: sql_common_core_loc_x86, action: Uninstall, path: C:\ProgramData\Package Cache\{D17B5D3D-3BC7-4AFA-AD90-600B5453826E}v14.0.1000.169\x86\sql_common_core_loc_msi\sql_common_core_loc.msi, arguments: ' MSIFASTINSTALL="7" AddLocal="Client_Components_CLS,CommonFiles_Loc,Connectivity_CLS"'

    Btw, the "Microsoft Visual Studio 2015 Shell (Isolated)" software is shown as installed on the system so I guess it was not rolled back successfully either.

    I do understand that it is difficult to track down the source of this problem. But it's quite a serious problem that you can't even install the software and that the problem has been around for quite a long time. May I suggest that you improve the error logging when this software is installed at least so that it is possible to better pinpoint what went wrong. For instance what EXE package that can't be executed? That can be a privilege problem I guess (although I of course run as an elevated administator). Please come back with a suggestion on how to make this installation work. 

     

    Tobi

    Tuesday, June 5, 2018 3:30 PM

All replies

  • Hi TobyBari,

     

    I understand that there occurs errors about Microsoft Visual Studio 2015 Shell (Isolated) when installing SSMS. If anything is misunderstood, please let me know.

     

    Generally this problem is related to the based package of SSMS like Visual C++, please find Microsoft Visual C++ 2015 Redistributable in Control Panel\All Control Panel Items\Programs and Features and repair them. Besides, have you installed Visual Studio before installing SSMS. If yes, please uninstall Visual Studio and then reinstall SSMS.

     

    Best Regards,

    Emily Fei

    Wednesday, June 6, 2018 9:20 AM